Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Why is adobe shockwave Flash being such a pain?

  • 24 replies
  • 51 have this problem
  • 7260 views
  • Last reply by kobe

more options

http://oi40.tinypic.com/2u5f4hf.jpg

It keeps doing this every time I use FF and it's going to make me stop completely if someone doesn't fix it.

I have been in the middle of doing work and it will do this, and I lose my work.

Google chrome is working better. And the only thing wrong is this Adobe Shockwave.

Edited title to add "Flash" since, based on the linked image, this question is about the Shockwave Flash plugin. aw

Modified by AliceWyman

All Replies (20)

more options

http://oi40.tinypic.com/2utg20i.jpg

then when the adobe plugin crashes firefox, i have to go into Ctrl+Alt+Delete task manager and disable firefox.exe myself

more options

Hey, the same thing happenning with me and as i googled we are not alone.

You can spare your time and don't try uninstalling and reinstalling every adobe plugin, flash player and your firefox probly won't help.

I guess we just have to wait till adobe or ff fixes it. Interesting how much users this thing have costed them(ff)

more options

recently, the Shockwave error message is still popping up - and for some reason won't recognize when I click "don't show me again" - but when it does the browser hasn't been immediately crashing like it did before. so i guess somebody fixed something

by the way I am running Windows 7 on an HP 2000 laptop

more options

This is some standard guidance that addresses the most common issues with Flash. I'm sure you've seen some of it before, but just in case:

(1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them.

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista/7/8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

more options

Thank you, I will see if this works better now.

more options

Nope, still doing the same thing it was before.

Also, I don't think it has much to do with videos, as I'm not playing them except once in a blue moon. And this freeze/crash glitch is happening all the time.

I reported a bug to Adobe. Other than that, I don't know what to do.

I'm not gonna screw around with protected mode either, not to look a gift horse in the mouth.

more options

Hi cantthinkofausername, you wrote:

I'm not gonna screw around with protected mode either, not to look a gift horse in the mouth.

Well, keep it in mind for the future in case you get frustrated waiting for Adobe to fix it!

more options

No, I did all of the things you said, and it didn't make any difference.

It hasn't changed since last week.

more options

Do you get the error on a site where use of Flash is obvious, like a video player, or does this usually come up on other sites where it's hard to see why Flash is being used?

Some sites use Flash for global storage, i.e., they can store information that is accessible when you visit that site from any browser. If you have any security/privacy add-ons in Firefox (or external security software) that alter how sites can store data or cookies on your computer (or clear it at scheduled intervals), there could be a glitch there.

If there is a site where you can reliably reproduce this problem, try visiting it in Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Although extensions and themes are disabled, plugins including Shockwave Flash continue to be available.

Any difference?


Speaking of add-ons, perhaps the FlashBlock extension will reduce the prevalence of the problem by requiring your approval before Flash runs? https://addons.mozilla.org/firefox/addon/flashblock/

more options

i was doing research on multiple websites. the problem does not seem to be isolated to a specific one.

i will try safe mode and let you know.

more options

My love/hate relationship with Adobe soured long ago. They've made their proprietary 8-freaking part settings manager worthless for laymen to accomplish anything useful because they're more interested in pandering to advertisers than pleasing viewers. Now they can't even make the Shockwave "player" play nice with browsers. I can no longer run their own demo shockwave game (which was actually an amusing diversion at one time) - http://www.adobe.com/products/shockwaveplayer/mountainbike_game/ It loads the parts, then freezes with the DEMO's white progress bar fully filled. Their own bloody flash and shockwave test pages report I'm up to date for FF. I refuse to drop all my defenses against 3rd party ad servers but I don't even see where anything is being blocked! Do we curse the "programmers" or the "greedy corporate suits?"

more options

Hi nearearthobject, I don't have any insight into that demo.

Another option for adjusting Flash settings (Shockwave Flash) is in the Windows Control Manager Panel, System and Security category. Might not be as comprehensive as the one on the web, I didn't compare.

Edit: Whoops...

Modified by jscher2000

more options

Please check if all your plugins are up-to-date. To do this, go to the Mozilla Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.


Recent crashes of certain multimedia contents (this includes Youtube videos, certain flash games and other applications) in conjunction with Firefox are most probably caused by a recent Flash update and/or a malfunctioning browser plugin such as Real Player.

Other, more technical information about these issues can be found under these Links:


Please tell us if this helped!

more options

jscher2000 - Thanks for trying. I was surprised to hear you can manipulate Adobe Flash settings via Windows Security. I'm stuck using Vista which might explain why I didn't recognize the path you offered - "Windows Control Manager, System and Security category" as I'd never heard of "Windows Control Manager" If I go to Control Panel> System> Security Center, there is nothing for Adobe. I'd love to see all of the Adobe crap put on one page instead of strewn over that 8 popup proprietary Settings Manager the Adobe idiots designed. Coincidentally (or perhaps not?), Adobe released an update of some sort shortly after my last slam at them was posted here. That didn't fix their motorbike demo,

more options

@ComputerWhiz = thanks for the link to the Mozilla Plugin Check site. I use Secunia and Belarc to keep on top of software updates and religiously update virus defs. Glad to know I can add a step to my pretty thorough updating/maintenance steps. However, your plugin check has a glitch. While it confirms my Adobe Flash/Shockware/Director items are up to date, it tells me I'm using a "vulnerable" version of VLC media player (2.0.6) when I'm actually using the up-to-date 2.0.8. It also says my Adobe Reader plugin version is "vulnerable" but that is up-to-date as well. (v10.1.8) and I'm told no update is necessary. Are we having fun yet?

more options

Hi nearearthobject, you're right, Control Manager was a typo of Control Panel. I never used Vista, but if you switch to the "classic view" which lists all the different items alphabetically, you should find one for Flash.

more options

The VLC Media Player issue that you mentioned has been noticed and reported to the author of the plugin. Continue to use your version of VLC plugin.


Please try updating Firefox to the most recent version.

more options

@ComputerWhiz - thanks for passing along the glitch. For the record, the only way I could update to a "more recent version" of FF is if I were part of a beta testing group. For laughs I tried to update and a cheerleader pop up came on saying "Hooray! Your Firefox is up to date."

@jscher2000 - now you're just teasing to be cruel. LOL I'm an crusty old win user so I ALWAYS use Classic but don't know of or have a FLASH or SHOCKWAVE item on that list unless it's buried in a submenu. Windows useless fuzzy search from HELP doesn't point to anything either, near as I could tell. Do you have a road map, perchance?

more options

Hi nearearthobject, when you view the Windows Control Panel, is it grouped by categories or does it list everything? Try to switch it so it lists everything and see whether you can find a Flash icon there. I am running Windows 7, so can't vouch for Vista.

more options

Here is the funniest part. Shockwave has crashed and locked my computer TWICE while reading this section. This is a real problem. It causes me to reboot 3 times a day. And it is ALWAYS the shockwave plugin locking everything up. Please fix. Please do not keep suggesting the same "solutions" that do not work.

  1. 1
  2. 2