X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I cannot play soundcloud using the firefox browser but am told it may work if I turn off the flashblocker extension - how do I do this?

Posted

The soundcloud page will open in my firefox browser but none of the songs will play. (Youtube seems to work atm.) I read that:

I should clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

   Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" 

"Remove Cookies" from sites causing problems:

   Tools > Options > Privacy > Cookies: "Show Cookies" 

But, there is no "options" tab under "tools" for me and I'm not sure how to delete the cache. I am using firefox 21.0 on the "release update channel" and it is up to date. So, how can I make soundcloud work for me? AI would also like to play songs on bandcamp but this doesn't work because I need to install Adobe's latest flash player. m I giving up any privacy by fixing these 2 problems?

Additional System Details

Installed Plug-ins

  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • DivX Plus Web Player version 2.2.1.2
  • DivX VOD Helper Plug-in
  • Microsoft Office for Mac SharePoint Browser Plug-in

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96798 answers

For Mac, use these instructions:

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
vsin 0 solutions 2 answers

Helpful Reply

I have had the same problem since the latest Adobe Flash update. I have the same problem in IE too. I also have the problem with some YouTube videos at times and a certain video at another website. These are ones I can remember and it didn't start until I updated Adobe Flash. Google Chrome uses it's own flash, so when I use that browser, no problem. So it must be Adobe Flash update being flawed. Maybe it can be rolled back to an earlier version? For doing that, try this link. I haven't fully check it out yet, just found it at the same time I came across this thread.

How to roll back Adobe Flash to earlier version.

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Hi vsin, Adobe is ending support for Flash 10.3 in the near future, so rolling back will be a less appealing option.

This is some standard guidance that addresses the most common issues with Flash in Firefox (not sure about IE). I'm sure you've seen some of it before, but just in case:

(1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them.

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista/7/8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

hordon 0 solutions 7 answers

Did you try to include Soundcloud to Flashblock's white list? I remember I had this problem long-long time ago, I've added SC to Flashblock's white list and it has been working just fine since then.

Though I understand it's not a perfect fix (autoplay etc.), but could be a temporary solution.

Modified by hordon