X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Cannot change History settings.

Posted

Hi, I recently installed Firefox on a brand new laptop with Windows 8. I have noticed that in the privacy settings, I can't change the History setting. There are 3 options there: remember history, never remember history and custom. If I try to change the setting, which is on custom, it keeps reverting back to this setting.

I have Firefox on my Win 7 desktop, and there it works normal. What is going on?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122
  • 5.1.20125.0
  • 0.3
  • Uplay PC Plugin
  • iTunes Detector Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPWLPG
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • Unity Player 3.3.0f4
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.732
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • CANON iMAGE GATEWAY Mycamera Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

Andrew
  • Top 25 Contributor
  • Moderator
252 solutions 3020 answers

Are you saying that changing a setting on 'remember' and 'never' will automatically go to custom? If so I think this is normal.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

The "Use custom settings for history" choice allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings.
Firefox shows the "Use custom settings for history" selection as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made.
If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History".
"Never Remember History" means that Private Browsing is active and "Always use private browsing mode" gets a check mark.

"Use custom settings for history" stays selected if at least one of the History or Cookie settings is not the default to make you aware that changes from the default setting have been made.

Question owner

I have been ticking off all the options one by one, and checking if the "remember all history" selection stays on or not. I found that the one option that causes this strange behaviour is the box:

"remember my navigation and download history"

Not ticking this box, and only this one, causes the "remember all history" option not to stay selected, and makes the pull-down menu go back to custom on its own. (I really can't belief that this is intended)

Ticking this box, and making any other changes, causes the functionality to work normal and as expected. Changing it back then to custom show you which boxes were then automatically selected by this option. Again, normal and expected behaviour in my opinion.

In reply to the answer above: I find this very odd behaviour to be honest. Such pull-down options are meant to quickly select a setting, not to be some sort of indicator. I would change that since it is confusing. Especially since choosing one of these pull-down options does cause boxes to be ticked on or off when you change the selection back to custom.

Edit: You can easily test this. Any combination of boxes ticked, with "remember my navigation and download history" also ticked, makes the "remember all history" selection work normally. So I can't belief this is working as intended. Why would you make this single box more important than any of the others??

Modified by Thijme

careyt39 0 solutions 11 answers

and mine is just the reverse - Changing it to Custom will revert in seconds back to 'Remember history'.

Any relationship between these two behaviors. With the new 23.0.1 - I get a new tab labelled 'Please enable cookies', every time. Have tried everything I can think of, finally found this odd behavior on that Privacy option which WILL NOT persist.