X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I get Firefox to remember logins and passwords for sites I've been using, but originally didn't choose to save on the first visit?.

Posted

I'm updating the logins and passwords for sites I've been visiting, and changing some of the security settings in Firefox. I originally declined to remember the password, but would like to add them now, and the sites are not listed in the "exceptions" list. How do I revisit the "remember password" function for these sites?

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10759 solutions 96838 answers

If you have clicked "Not now" then Firefox should offer to save again on a next visit. If you have clicked "Never" then Firefox has created a block exception that you need to remove.

You can inspect and manage the permissions for all domains on the about:permissions page or for the current domain via the "Site Identity Button" (globe/padlock) on the location bar and click "More Information" to open "Page Info" and go to the Permissions tab.

You can delete the permissions.sqlite file to reset all permissions.

Question owner

I believe I chose "not now" but I don't get the drop-down option anymore when I return to the sites. (more than one site involved.) I've checked, and there is not a block exception for the sites in question, and "store passwords" in permissions shows "allow". Do I need to delete all info stored for the site ("forget about this site") and start again?

cor-el
  • Top 10 Contributor
  • Moderator
10759 solutions 96838 answers

Did you check the permissions for the domain?

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"

The website may be using autocomplete=off to prevent Firefox from saving and filling the name and password.

You can remove autocomplete=off with a bookmarklet to make Firefox save names and passwords and other form data.