Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My ff icons are missing, for example

  • 5 replies
  • 6 have this problem
  • 1823 views
  • Last reply by gb66pack66

more options

My ff icons are missing after formatting hdd and reinstalling, for example home is only in text, no icon, how do I turn it back to an icon

Chosen solution

Are you referring to the favicons on the Bookmarks Toolbar?

Do you have any extensions installed that may suppress those icons?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
Read this answer in context 👍 0

All Replies (5)

more options

Firefox Menu > View > Toolbar > Customize
At the bottom > Show > Choose - ICON > DONE

more options

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.


Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure that you allow pages to choose their own colors in Firefox.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

If images are missing then check that you aren't blocking images from some domains.

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

Make sure that you do not block third-party images, the permissions.default.image pref should be 1.

There are also extensions like Adblock Plus (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images and other content.

See also:

more options

here is a screenshot, you can see, no icons, just text where there used to be icons

more options

Chosen Solution

Are you referring to the favicons on the Bookmarks Toolbar?

Do you have any extensions installed that may suppress those icons?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
more options

Thanks, it was some old extension that was labeled as disabled but in fact wasn't.

Thanks again, case closed