X
Tap here to go to the mobile version of the site.

Support Forum

Firefox stuck selecting text on Win8 touchscreen laptop

Posted

Windows 8 | Acer Aspire V5 touchscreen Open Firefox. (Google is default home.) Type a search phrase, press Enter. List of results displays. Swiping screen ONLY selects displayed text - no scrolling. Nothing turns off Selection mode: not pressing keys or key combinations, switching tabs, or closing & reopening the browser. Open IE10. (Google is default home.) Type a search phrase, press Enter. List of results displays. Swiping screen scrolls as expected.

Here's what I *don't* want: "Try installing <insert name of favorite obscure 3rd-party utility here>."

Already uninstalled and reinstalled, and problem is still 100% repeatable. This is a Firefox issue, and what I'd like is for Firefox to be fixed, not to have to install some 3rd-party workaround. A Firefox patch, an update, a new version - I don't care which. But Firefox is clearly *not* compatible with touchscreen laptops running Win8 right now. As much as I LOATHE IE - and I do - I'll have to use that for now because at least it works with the brand-new, month-old hardware I have. I'm a longtime Firefox loyalist so my disappointment is deeper than it might otherwise be.

Windows 8 | Acer Aspire V5 touchscreen Open Firefox. (Google is default home.) Type a search phrase, press Enter. List of results displays. Swiping screen ONLY selects displayed text - no scrolling. Nothing turns off Selection mode: not pressing keys or key combinations, switching tabs, or closing & reopening the browser. Open IE10. (Google is default home.) Type a search phrase, press Enter. List of results displays. Swiping screen scrolls as expected. Here's what I *don't* want: "Try installing <insert name of favorite obscure 3rd-party utility here>." Already uninstalled and reinstalled, and problem is still 100% repeatable. This is a Firefox issue, and what I'd like is for Firefox to be fixed, not to have to install some 3rd-party workaround. A Firefox patch, an update, a new version - I don't care which. But Firefox is clearly *not* compatible with touchscreen laptops running Win8 right now. As much as I LOATHE IE - and I do - I'll have to use that for now because at least it works with the brand-new, month-old hardware I have. I'm a longtime Firefox loyalist so my disappointment is deeper than it might otherwise be.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0; Touch; .NET4.0E; .NET4.0C; Tablet PC 2.0; .NET CLR 3.5.30729; .NET CLR 2.0.50727; .NET CLR 3.0.30729; McAfee; MAARJS)

More Information

cor-el
  • Top 10 Contributor
  • Moderator
11983 solutions 111347 answers

Does this only happen if you search via the Google.com website or also with searching via the search bar on the Navigation Toolbar and the search bar on the about:home page?


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

Does this only happen if you search via the Google.com website or also with searching via the search bar on the Navigation Toolbar and the search bar on the about:home page? ---- Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ---- Create a new profile as a test to check if your current profile is causing the problems. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox
4characters 0 solutions 2 answers

I have the same issue and tried the safe mode and it was no help. I, too, have an Acer Aspire with Windows 8. And it is not a profile issue. This is definitely a problem with Firefox. I tested a few of the sites this happens on using Firefox, Chrome and IE - Firefox was the only browser this happened with.

I have the same issue and tried the safe mode and it was no help. I, too, have an Acer Aspire with Windows 8. And it is not a profile issue. This is definitely a problem with Firefox. I tested a few of the sites this happens on using Firefox, Chrome and IE - Firefox was the only browser this happened with.
jscher2000
  • Top 10 Contributor
2976 solutions 27680 answers

This seems to be related to how pages intercept touch actions in their scripts. A past thread offered various workarounds but no solution: how do I enable touchscreen scrolling on googles website).

A bug report has been filed. Since the work on a fix is going to take a while, starting in Firefox 24, scripts will not have permission to modify touch events.

Tips on the bug tracking system: If forum members can contribute to the development, please feel free to pitch in. Otherwise, it's generally not helpful to add comments to bugs (unless there is a call for test cases), but you can register on the Bugzilla site and "vote" for them to be fixed. See:

As a short-term workaround, you could try blocking sites from using touch events as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste touch and pause while the list is filtered

(3) Double-click dom.w3c_touch_events.enabled and set it to 0 (zero) which disables use by scripts, then exit and restart Firefox.

Does this restore default behavior on problem sites?

There also is a dom.w3c_touch_events.expose preference, which may or may not be relevant for this issue.

This seems to be related to how pages intercept touch actions in their scripts. A past thread offered various workarounds but no solution: [https://support.mozilla.org/en-US/questions/947337 how do I enable touchscreen scrolling on googles website]). A bug report has been filed. Since the work on a fix is going to take a while, starting in Firefox 24, scripts will not have permission to modify touch events. * [https://bugzilla.mozilla.org/show_bug.cgi?id=736048 736048 – Some sites won't touch-scroll using a touch-screen] (open) * [https://bugzilla.mozilla.org/show_bug.cgi?id=888304 888304 – Content touch-events on Firefox-desktop should be disabled until we can support them properly] (disabled starting in Firefox 24) Tips on the bug tracking system: If forum members can contribute to the development, please feel free to pitch in. Otherwise, it's generally not helpful to add comments to bugs (unless there is a call for test cases), but you can register on the Bugzilla site and "vote" for them to be fixed. See: * [https://bugzilla.mozilla.org/page.cgi?id=etiquette.html Bugzilla Etiquette] * [https://bugzilla.mozilla.org/page.cgi?id=voting.html Voting] As a short-term workaround, you could try blocking sites from using touch events as follows: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the filter box, type or paste '''touch''' and pause while the list is filtered (3) Double-click '''dom.w3c_touch_events.enabled''' and set it to 0 (zero) which disables use by scripts, then exit and restart Firefox. Does this restore default behavior on problem sites? There also is a '''dom.w3c_touch_events.expose''' preference, which may or may not be relevant for this issue.
4characters 0 solutions 2 answers

If it was an issue with the website then why wouldn't this problem be the same regardless of browsers used?

If it was an issue with the website then why wouldn't this problem be the same regardless of browsers used?
jscher2000
  • Top 10 Contributor
2976 solutions 27680 answers

Hi 4characters, some sites intercept/modify touch actions in a way that Firefox cannot currently handle. That is why you do not see the problem on all sites. As noted above, you can disable sites from customizing touch actions so they all behave as expected.

Hi 4characters, some sites intercept/modify touch actions in a way that Firefox cannot currently handle. That is why you do not see the problem on all sites. As noted above, you can disable sites from customizing touch actions so they all behave as expected.