X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why does Firefox 21.0 display "TypeError: this.handleDownloadEvent is not a function" when I use S3 Fox Organizer 0.7 to download a file from Amazon S3?

Posted

I'm still able to download files from S3, but I have to click the OK button on this annoying alert for each file downloaded. I imagine you must have (once again) changed something about your APIs. The last time you did so, it completely broke S3Fox, but I was able to provide the developer with the API details necessary to update his tool (to version 0.7).

If you provide the technical details for this problem as well, I'd be happy to forward them to the developer.

Chosen solution

there's a version 0.8 of this extension available - can you check if you get the same error with that one?

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Apple Connect Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • iPhoto6

Application

  • Firefox 21.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:21.0) Gecko/20100101 Firefox/21.0
  • Support URL: http://support.mozilla.org/1/firefox/21.0/Darwin/en-US/

Extensions

  • Firebug 1.11.4 (firebug@software.joehewitt.com)
  • FoxyProxy Standard 4.2 (foxyproxy@eric.h.jung)
  • PDF Viewer 0.8.1 (uriloader@pdf.js)
  • S3 Firefox Organizer(S3Fox) 0.7 ({7CEA821D-3DAB-4238-B424-BF7324531750})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 116
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • numAcceleratedWindows: 3
  • numTotalWindows: 3
  • webglRenderer: Intel Inc. -- Intel HD Graphics 3000 OpenGL Engine
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.disk_cache_ssl: False
  • browser.history_expire_days.mirror: 180
  • browser.link.open_newwindow: 2
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.startup.homepage: about:blank
  • browser.startup.homepage_override.buildID: 20130511120803
  • browser.startup.homepage_override.mstone: 21.0
  • browser.tabs.warnOnClose: False
  • dom.disable_open_during_load: False
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • gfx.blacklist.webgl.msaa: 4
  • network.cookie.prefsMigrated: True
  • network.dns.disablePrefetch: True
  • network.protocol-handler.external.aliph: True
  • network.protocol-handler.warn-external.aliph: False
  • places.database.lastMaintenance: 1370269623
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • places.last_vacuum: 1303499096
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.cpd.offlineApps: True
  • privacy.cpd.sessions: False
  • privacy.cpd.siteSettings: True
  • privacy.item.offlineApps: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: Yes
  • Accessibility: No
philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

Chosen Solution

there's a version 0.8 of this extension available - can you check if you get the same error with that one?

Helpful Reply

Hi phillipp,

That did indeed fix the problem. I had to look around a bit to find S3Fox 0.8, however. The latest download from the developer's site is apparently still 0.7. However, I was able to download 0.8 from a page on the Mozilla site that seemed to suggest that this was a Thunderbird(?) add-on:

https://addons.mozilla.org/en-US/thunderbird/addon/amazon-s3-organizers3fox/eula/190250?src=version-history

It's difficult for me to imagine how useful this tool would be in that context, but I was able to install the amazon_s3_organizers3fox-0.8-fx.xpi file I downloaded into Firefox using its Add-ons Manager, and that removed the problem.

THANKS!

- Chris