X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I stop google opening as an encrypted url

Posted

In the past I have used http://www.google.co.nz as my home page. Once firefox has opened but I want to go to a different site I just edit the start line and change it to whatever I need eg www.fred.co.nz. Now my home page opens to https://www.google.co.nz - when edited it changes to https://www.fred.co.nz which doesn't exist. I could edit out the "s" as well but like everything that is changing on the internet it always seems to require extra keystrokes or mouse clicks and I am getting annoyed with it. Why can't I still have http://www etc as my home page. In other words how do I STOP https: being inserted into my home page as the default ? Quite happy in Options to have the choice to make either available and who knows maybe in the future I might want to change to encrypted (but I doubt it).

Chosen solution

This can be caused by having autofill in the location bar enabled and if you have visited pages on that website via a secure https connection in the past. You can set the Boolean pref browser.urlbar.autoFill to false on the about:config page to disalbe auto-fill.


You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the affected files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • Google Update
  • GEPlugin
  • 5.1.20125.0
  • VLC media player Web Plugin 2.0.2
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

Chosen Solution

This can be caused by having autofill in the location bar enabled and if you have visited pages on that website via a secure https connection in the past. You can set the Boolean pref browser.urlbar.autoFill to false on the about:config page to disalbe auto-fill.


You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the affected files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

Question owner

Clearing history solved it for me. I turned urlbar.autofill to false but it still overwrote my home page.