X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I disable the "some plugins are out of date" message

Posted

I am running firefox 3.6.3 on a powerpc mac laptop. There are no more upgrades to either firefox or any of the plugins it is using. It's a powerpc and the current updates of the plugins all require an intel based mac. I constantly get the message "some plugins used by this page are out of date" message above the screen, or Firefox disables plugins because it says they are a security risk. I don't care. This is an old computer that would work fine if Firefox would just stop trying to upgrade either itself or its plugins, or try to warn me about something that can't be upgraded and that I don't care about. MAC rule number one: The user is in charge. How do I fix this annoying and PC like feature?

In the future if Firefox is going to continue to have this "feature" it should keep track of what kind of computer it is running on and what what updates can and can not run on the computer it is running on, or give the user the option of turning off not only the messages but the whole plugin update function.

Mac OX 10.5.8 running on a 1.5 GHZ Power PC G4

Additional System Details

Installed Plug-ins

  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • Shockwave Flash 10.0 r32
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

iamjayakumars
  • Top 10 Contributor
415 solutions 4924 answers

Type about:addons in the Address bar > Plugins

Choose which one you want for the plugin "Always Active/Never Active"

Firefox stopped supporting Firefox 3.6

Update your firefox to Firefox 16.

Firefox needs MAC OS X 10.6 or later for latest version

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24397 answers

Firefox 3.6.28 was the last version of Firefox for PPC Macs, not the 3.6.3 version you now have.

For older Macs that aren't supported in the Firefox 4+ versions, try TenFourFox for PowerPC's running Mac 10.4.11 & 10.5.8 .
http://www.floodgap.com/software/tenfourfox/
http://tenfourfox.blogspot.com/
https://code.google.com/p/tenfourfox/wiki/PluginsNoLongerSupported
http://code.google.com/p/tenfourfox/wiki/AAATheFAQ

Question owner

I'm not sure what you mean Address bar > Plugins

Helpful Reply

In addition, the whole issue of forcing an update is crap. There are other programs that may be using those same plugins, and a user may many times not want to update a plugin due to compatibility issues with other apps. To constantly see this message is annoying, and I even tried to get google chrome at one point I was so annoyed. General rule, when you've got a stable system, don't screw with it.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Helpful Reply

Quote: I'm not sure what you mean Address bar > Plugins

What is meant in to open the "Tools > Add-ons > Plugins" window (the about:addons page doesn't exist in Firefox 3.6.x)

You can inspect and modify some prefs on the about:config page to suppress the plugin reminder.

  • set the plugins.hide_infobar_for_missing_plugin pref to true
  • set the plugins.hide_infobar_for_outdated_plugin pref to true

Question owner

Hi

I'm on a mac, so what your talking about doesn't exist in that form. However in the user/library/application support/firefox there is a prefs.js file that contains some user pref data, but not the specific ones you mention. I see other files that relate to addons, but no contain a popup preference.

Any other thoughts?

Thanks

Alan

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Prefs that have the default value do not show up in the prefs.js file.
You need to change (toggle) them on the about:config page.

Type about:config in the location (address) bar and press the "Enter" key to open the about:config page, just like you open a website by typing the URL in the location bar.

  • If you see a warning message then you can confirm that you want to access the about:config page.
  • use the Search bar at the top of the about:config page to locate preferences more easily
  • preferences that have been modified and do not have the default value show as bold (user set)
  • preferences that are user set (bold) can be reset to the default value via the right-click context menu
  • preferences can be changed via the right-click context menu: Modify (String or Integer) or Toggle (Boolean) or by double-clicking the line with the pref
  • preferences can be created via the right-click context menu: New -> String, Integer, Boolean