Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Is there a way to set "Google By Name" as the default search engine? I have tried changing keyword.URL but still it doesn't work.

  • 11 replies
  • 2 have this problem
  • 414 views
  • Last reply by supertod

more options

I have changed (had to add the string so maybe the preference has changed?) keyword.URL to http://www.google.com/search?ie=UTF-8&sourceid=navclient&gfns=1&q=, but when I try to enter "youtube", it still tries to load http://youtube/, not http://youtube.com. Whereas, on my desktop firefox entering youtube would take me to youtube.

Is it possible to get this working?

Chosen solution

Note that keyword.URL is no longer used in Firefox 22, so you can no longer use this to set the search engine used by the location bar. The search engine selected in the search bar will now be used.

  • Bug 738818 - consolidate Firefox search preferences

(please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)

Read this answer in context 👍 1

All Replies (11)

more options

Did you modify any of the "fixup" preferences?

There was a similar thread a while ago. It's marked solved, but I don't think we got to the bottom of what caused the problem. URL fixup not working

more options

Mine are set to:

  • browser.fixup.alternate.prefix = www.
  • browser.fixup.alternate.suffix = .com

The person asking that question appears to have their problem fixed by updating to v20, I'm on 21.0a1 and it doesn't appear to work.

Also, typing "you tube" on android takes me to a google search, but on desktop it takes me straight to youtube, so I'm not sure it's using browse by name.

EDIT: Apologies, I meant to type 24.0a1, not 21.0a1

Modified by supertod

more options

Historically, Firefox always submitted a multi-word search ("you tube") to Google but tried a single-word search ("youtube") as a domain name before resorting to search. However, it doesn't seem as predictable any more...

more options

This article lists a couple of different keyword.URL strings for Google which may give different results... http://kb.mozillazine.org/Keyword.URL

more options

Ok so I tried changing it to Bing and it stuck with Google. Looking at the addons page I realised Google search was enabled, so I disabled that. Now it has no predictions and the search function doesn't work at all, it says the address isn't valid.

more options

What URL did you use for Bing? This thread has some example URLs you could try: search engines...

more options

I used http://bing.com/results.aspx?q= with no luck.

more options

The Bing URL works for me. I'm searching from the Awesomebar in Firefox Mobile 21.0 (released version). Not sure why yours isn't working. What is 21.0a1?

more options

One thing you can try is to remove the search program you are having trouble with, then getting a fresh program.

more options

Chosen Solution

Note that keyword.URL is no longer used in Firefox 22, so you can no longer use this to set the search engine used by the location bar. The search engine selected in the search bar will now be used.

  • Bug 738818 - consolidate Firefox search preferences

(please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)

more options

I had a read through the comments and right at the bottom I found this beauty http://mycroftproject.com/search-engines.html?name=Google+%28Browse+by+Name%29.

I just installed it and it works, thanks guys! Keep up the good work.