X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Firefox disabled my adobe flash player

Posted

Firefox just out of nowhere decides to disable the flash plug-in without asking me. And everytime I go to a site that uses flash, I have to see this message (see link below.)

https://support.mozilla.org/en-US/kb/why-do-i-have-click-activate-plugins

So how do I reactivate the flash plugin without updating it? The reason I do not update it, is because when I update it, I get a constant pop-up error message. And when I uninstall my flash altogether, the constant error pop-up messages stop, but now I get the "you don't have it installed" message. And when I download an outdated version

So no matter what I do, I have problems with this. I don't want to have to keep clicking the "always activate plugin for this site" button, for every site I visit on the world wide web, because that is out-of-this-world annoying.

I'm getting really irritated by firefox, and their bull. I will not update because you can't keep up.

Firefox just out of nowhere decides to disable the flash plug-in without asking me. And everytime I go to a site that uses flash, I have to see this message (see link below.) https://support.mozilla.org/en-US/kb/why-do-i-have-click-activate-plugins So how do I reactivate the flash plugin without updating it? The reason I do not update it, is because when I update it, I get a constant pop-up error message. And when I uninstall my flash altogether, the constant error pop-up messages stop, but now I get the "you don't have it installed" message. And when I download an outdated version So no matter what I do, I have problems with this. I don't want to have to keep clicking the "always activate plugin for this site" button, for every site I visit on the world wide web, because that is out-of-this-world annoying. I'm getting really irritated by firefox, and their bull. I will not update because you can't keep up.

Additional System Details

Installed Plug-ins

  • Google Update
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • 5.1.20125.0
  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • Windows Activation Technologies Plugin for Mozilla
  • iTunes Detector Plug-in
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.1.629
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1248 solutions 8227 answers

Please do the following:

Update to Firefox 21 Update Firefox to the latest version

Update to Flash 11.7 https://www.mozilla.org/en-US/plugincheck/

Please do the following: Update to Firefox 21 [[Update Firefox to the latest version]] Update to Flash 11.7 https://www.mozilla.org/en-US/plugincheck/

Helpful Reply

NO! CAN YOU READ!? I said want to reactivate adobe flash without updating. You are of zero help. Quit wasting my time by telling me exactly what I refuse to do. I told you what happens when I do that.

'''NO!''' CAN YOU READ!? I said want to reactivate adobe flash '''without''' updating. You are of zero help. Quit wasting my time by telling me exactly what I refuse to do. I told you what happens when I do that.
Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1248 solutions 8227 answers

Why don't you want to update? Staying with known out of date versions leaves you with unstable and very insecure versions of both Firefox and Flash and you will just get more and more problems as you continue to use them. This dialog is there to protect you since you are using an old version of Flash.

Why don't you want to update? Staying with known out of date versions leaves you with unstable and very insecure versions of both Firefox and Flash and you will just get more and more problems as you continue to use them. This dialog is there to protect you since you are using an old version of Flash.

Helpful Reply

I told you what happens when I update. It won't play any video, and it keeps giving me an error message, that won't go away. It keeps popping up, even when I close it. That was a much bigger problem, and a huge headache. This problem does not exist on any of the other browsers that I have. So it's 100% a firefox problem, not a flash problem.

I told you what happens when I update. It won't play any video, and it keeps giving me an error message, that won't go away. It keeps popping up, even when I close it. That was a much bigger problem, and a huge headache. This problem does not exist on any of the other browsers that I have. So it's 100% a firefox problem, not a flash problem.
Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1248 solutions 8227 answers

It could be a flash problem, as the flash player that is used by Firefox is different than the one used by IE, and different than the one used by Chrome, so you can't rule it out just because it is not happening in other browsers.

As I said, update Firefox, then update Flash. If you get an error message, please give me the exact message, and we can fix that. It's better to have a fixed, up to date version of Firefox and flash then use something insecure and old.

It could be a flash problem, as the flash player that is used by Firefox is different than the one used by IE, and different than the one used by Chrome, so you can't rule it out just because it is not happening in other browsers. As I said, update Firefox, then update Flash. If you get an error message, please give me the exact message, and we can fix that. It's better to have a fixed, up to date version of Firefox and flash then use something insecure and old.

Question owner

Fine give me the solution, then I will update.

Fine give me the solution, then I will update.
Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1248 solutions 8227 answers

Updating IS the solution. You will only see this dialog because you are running an ancient, out of date and insecure version of Flash. Updating Firefox and Flash will make that warning go away.

Updating IS the solution. You will only see this dialog because you are running an ancient, out of date and insecure version of Flash. Updating Firefox and Flash will make that warning go away.

Question owner

I did, but I can't watch any video when I do. I just get error messages. Which is worse than the message.

I did, but I can't watch any video when I do. I just get error messages. Which is worse than the message.
Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1248 solutions 8227 answers

If you'd like to give me the exact error message you are seeing we can work with that to get Flash 11.7 working ;)

If you'd like to give me the exact error message you are seeing we can work with that to get Flash 11.7 working ;)

Question owner

The one that keeps popping up, even when you X it out

The one that keeps popping up, even when you X it out
Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1248 solutions 8227 answers

That means nothing to me. can you please give me the exact text, or take a screenshot of it? How do I create a screenshot of my problem?

That means nothing to me. can you please give me the exact text, or take a screenshot of it? [[How do I create a screenshot of my problem?]]
cor-el
  • Top 10 Contributor
  • Moderator
12532 solutions 115578 answers

You can check for problems with current Flash plugin versions and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)
  • disable hardware acceleration in the Flash plugin
You can check for problems with current Flash plugin versions and try these: *disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed *disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) *disable hardware acceleration in the Flash plugin *http://kb.mozillazine.org/Flash#Troubleshooting
StansSongs 0 solutions 1 answers

Deleted.

Deleted.

Modified by StansSongs

LiamKnuj 0 solutions 3 answers

Flash is a pain in the ass. It is all about stuff ads at you. I am sick of the constant updates, I never want to use Flash again. Steve Jobs was right about it. It needs to be killed. You kill it by not using it.

Tell me how to block all flash content. Every bit of it. I never want to see it again.

Flash is a pain in the ass. It is all about stuff ads at you. I am sick of the constant updates, I never want to use Flash again. Steve Jobs was right about it. It needs to be killed. You kill it by not using it. Tell me how to block all flash content. Every bit of it. I never want to see it again.
the-edmeister
  • Top 10 Contributor
  • Moderator
3984 solutions 29980 answers
Flashblock - https://addons.mozilla.org/en-US/firefox/addon/flashblock/
Bobbye 0 solutions 4 answers

I'd like to pass this Java and Flash info on to Firefox users: 1. To stop Java auto-updates:

 a) Open Control Panel
 b) Click on Java
 c) Click on the Update tab
 d) Uncheck "Check for updates automatically"
 e) Warning will display> click on 'do no check'
 f)  Click on Apply> OK

NOTE 1: You will need Java to get some content, so it's best to have it. But there are frequent security updates and you should have the latest for best security. Stopping the auto-updates puts the responsibility for system security in your hands.

Java is finally overwriting the previous older version, but if you have other older versions, they should be removed as they as vulnerabilities.

2. To enable Flash/AdBlock Plus: If you use AdBlock Plus, you may find that this is what is actually blocking Flash. When I want to see the Flash content on a page, I do the following:

 a) Open Firefox> Click on Tools> Click on AdBlock Plus
 b) Depending on what I want at that time, I check any one of the following:
  (1) Disable on 'the name of the site' only
  (2) Disable on 'the name of that particular page'

This allows you to have specific Flash control on content.


Many users don't realize that they do have some control over program actions. I personally don't allow ANY auto-updates except the antivirus program.

NOTE 2: If you do change a setting or a particular page or site, you may want to revert back to the block when you're through.

'''I'd like to pass this Java and Flash info on to Firefox users: ''' 1. '''To stop Java auto-updates:''' a) Open Control Panel b) Click on Java c) Click on the Update tab d) Uncheck "Check for updates automatically" e) Warning will display> click on 'do no check' f) Click on Apply> OK NOTE 1: You will need Java to get some content, so it's best to have it. But there are frequent security updates and you should have the latest for best security. Stopping the auto-updates puts the responsibility for system security in your hands. Java is finally overwriting the previous older version, but if you have other older versions, they should be removed as they as vulnerabilities. 2. '''To enable Flash/AdBlock Plus''': If you use AdBlock Plus, you may find that this is what is actually blocking Flash. When I want to see the Flash content on a page, I do the following: a) Open Firefox> Click on Tools> Click on AdBlock Plus b) Depending on what I want at that time, I check any one of the following: (1) Disable on 'the name of the site' only (2) Disable on 'the name of that particular page' This allows you to have specific Flash control on content. ------------------------------------------ Many users don't realize that they do have some control over program actions. I personally don't allow ANY auto-updates except the antivirus program. NOTE 2: If you do change a setting or a particular page or site, you may want to revert back to the block when you're through.
gongang 0 solutions 4 answers

I have this problem too, Firefox force me to update flash player, but google Chrome or Safari can play fine with no update.

I have this problem too, Firefox force me to update flash player, but google Chrome or Safari can play fine with no update.

Modified by gongang

cor-el
  • Top 10 Contributor
  • Moderator
12532 solutions 115578 answers

Google Chrome comes with its own Flash plugin and GC updates every time that Flash needs an update.
You may not notice this if GC is set to update automatically.

Google Chrome comes with its own Flash plugin and GC updates every time that Flash needs an update.<br /> You may not notice this if GC is set to update automatically.
msjs 1 solutions 12 answers

I too want to activate for all sites and not update but for a different reason. There ARE NO UPDATES on Linux so even if I want to I can't!

I too want to activate for all sites and not update but for a different reason. There ARE NO UPDATES on Linux so even if I want to I can't!
Bobbye 0 solutions 4 answers

Some of you are not reading the comment I left well enough:

It was meant to address stopping auto-updates on Flash and Java only> this is separate from whatever OS you're using.

And it coupled the use of the add on AdBlock Plus as part of or the culprit in some of the blocking. This addresses the possibility that IF you have this add on with whatever browser you're using, that can be responsible for some of the blocking. I referred to Firefox, but if you can use this add on with other browsers, it would do the same thing.

Since I first posted this, it appears that the Shockwave Flash v11.7.700.224 is now allowed in Firefox. But again, please note that the use of AdBlock Plus on the browser may still make a difference in blocking some Flash.

Just keep in mind that multiple things can be contributing to these blocks from pop-up blockers, ad blockers to settings in the browser itself. I guess it depends on how much use we have as to how big the annoyance it!


Some users prefer to allow automatic updating so they don't have to bother checking for updates. This goes for everything from OS to software programs to add ons and plug ins. My preference to not to allow any auto updates except for the antivirus program. This is a personal preference based on how much control you want to put on the system.

Some of you are not reading the comment I left well enough: It was meant to address stopping auto-updates on Flash and Java only> this is separate from whatever OS you're using. And it coupled the use of the add on '''''AdBlock Plus '''''as part of or the culprit in some of the blocking. This addresses the possibility that IF you have this add on with whatever browser you're using, that can be responsible for some of the blocking. I referred to Firefox, but if you can use this add on with other browsers, it would do the same thing. Since I first posted this, it appears that the Shockwave Flash v11.7.700.224 is now allowed in Firefox. But again, please note that the use of AdBlock Plus on the browser may still make a difference in blocking some Flash. Just keep in mind that multiple things can be contributing to these blocks from pop-up blockers, ad blockers to settings in the browser itself. I guess it depends on how much use we have as to how big the annoyance it! ------------------------------------------- Some users prefer to allow automatic updating so they don't have to bother checking for updates. This goes for everything from OS to software programs to add ons and plug ins. ''My preference'' to ''not ''to allow any auto updates '''except for the antivirus program.''' This is a personal preference based on how much control you want to put on the system.