Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Have started seeing diamonds with question marks on FireFox (and Chrome); changed encoding, made no difference.

  • 44 replies
  • 8 have this problem
  • 6001 views
  • Last reply by cor-el

more options

Both FireFox and Google Chrome (but not Internet Explorer) have been showing black diamonds with question marks in them for some time. It's not an encoding issue, as changing character encoding doesn't work. I don't know what caused it, as it all of a sudden started out of the blue. My network.http. in about:config are all default. I've tried scanning for malware, including in safe mode with the internet disconnected. Nothing has made a difference. Please help me, as this problem is incredibly hard to Google and I have no idea what to do.

All Replies (4)

more options

Hi kadona, okay, so how far can you get with the various menus: can you get down to View > Character Encoding > Western... or is it grayed out somewhere along the way? Do other menus work normally?

more options

Other menus seem to work fine as you will see from all the above times I have followed the links given. And as I said 'Character encoding' is greyed out. It doesn't open at all...so I do not see 'Western'.

more options

Hi kadona, I can't think of a good reason for Character Encoding to be grayed out on a web page. (It will be grayed out when viewing an image, since images do not have any character encoding.)

Since you already used the Reset feature to bypass most old settings, you could try the following:

  • Manually disable all plugins except Shockwave Flash and all extensions, using the Add-ons page (Ctrl+Shift+a to open), then restart Firefox and test again
  • Refresh Firefox's program files with a "clean reinstall"

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org/en-US/firefox/all/ (choose the desired language) and save the setup file to your desktop or other handy location.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Rename the Firefox program folder (you could delete it, but this way if you want to scrounge any files from it, such as an obscure extension installed in a shared folder, you still have it handy):

    C:\Program Files (x86)\Mozilla Firefox

    For example, to:

    C:\Program Files (x86)\Bad Mozilla Firefox

  4. Now, go ahead and reinstall Firefox:
    • Double-click the downloaded installation file and go through the steps of the installation wizard.
    • Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.
more options

Is this happening with a PDF file?

A normal URL would have the Character Encoding enabled, so that would suggest that you have a special page (document) open that doesn't support encoding.

  1. 1
  2. 2
  3. 3