X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Have started seeing diamonds with question marks on FireFox (and Chrome); changed encoding, made no difference.

Posted

Both FireFox and Google Chrome (but not Internet Explorer) have been showing black diamonds with question marks in them for some time. It's not an encoding issue, as changing character encoding doesn't work. I don't know what caused it, as it all of a sudden started out of the blue. My network.http. in about:config are all default. I've tried scanning for malware, including in safe mode with the internet disconnected. Nothing has made a difference. Please help me, as this problem is incredibly hard to Google and I have no idea what to do.

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.7 r700
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.4"
  • 5.1.20125.0
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • Shockwave Flash 11.2 r202
  • DivX Plus Web Player version 2.2.0.52
  • DivX VOD Helper Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • iTunes Detector Plug-in
  • Unity Player 2.6.1f3
  • Motive Plugin for Mozilla Browsers
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Adobe Shockwave for Director Netscape plug-in, version 11.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

Can you spot a pattern as to which fonts are involved? Sometimes font files become corrupted or browsers substitute other similarly named fonts.

The FontInfo extension adds a right-click context menu item to see what font Firefox actually is using for a selection of text: https://addons.mozilla.org/firefox/ad.../fontinfo/. That might help in isolating the problem.

ideato
  • Top 25 Contributor
617 solutions 4264 answers

Hello FedUpFrustrated

See cor-el's reply : https://support.mozilla.org/en-US/questions/930473#answer-346039

thank you

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Can you post a link to a web page where you see these diamonds and possibly attach a screenshot?

Which encoding settings did you try?

A diamond with a '?' usually indicates that a character is missing in the font that is used on a website or the wrong encoding is used. You can also get the '?' on websites that use an 8 bit encoding like ISO-8859-1 or an encoding like Windows-1252.

Question owner

Screen shot: http://postimg.org/image/gynyypb77/

As for encodings, I've tried switching from Unicode(UTF-8) to Western(ISO-8859-1) and and to every one with Western, Japanese and Korean in its name out of desperation.

Modified by cor-el

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

The server sends the page in your link as Unicode (UTF-8) and that works for me.

This can be a problem with the font that is used to display the text.

You can use this extension to see which fonts are used for text that is selected (right-click: "Show fonts in selection").

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Firefox/Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"

Modified by cor-el

jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

The more I look at your image, the more broken it looks. You can see parts of HTML tags where they should not be visible, such as the /span> in the top bar and after the date (in red); the drop-down that has /option>; and in the video descriptions where you see strong or href=.

Something is corrupting the page, maybe an extension, or proxy/filter service, or security software?

To rule out an extension, you could try Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

kadona 0 solutions 20 answers

A website I visited through Firefox shows interminable little black diamond-shaped diagrams with a white question mark inside. Using IA and Chrome they do not appear on that website. They do not seem to appear on other websites through Firefox. Is it the fault of the visited website or does Firefox have a bug. I'm no good with complicated answers such as I have seen here.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Hi kadona

Can you post a link to a publicly accessible page that doesn't require authentication (signing on)?

Did you check which encoding is used (Firefox > Web Developer > Encoding)?

You usually see the diamonds if there is a wrong encoding used like UTF-8 instead of Western encoding that doesn't include the character.

Also make sure that the default encoding is Western (ISO-8859-1)

  • Tools > Options > Content : Fonts & Colors > Advanced > Default Character Encoding
kadona 0 solutions 20 answers

I'm sorry, but I cannot understand a word of what you have said. It is like a foreign language :) But thank you for trying. I have only seen these things on the same website of which I am a member. -never anywhere else. I use Firefox a lot. But when I accessed that website through two other browsers, just to see, the black diamonds did not appear - only through firefox. I do not experience this phenomenon anywhere else when I use firefox.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Did you try to go to "Firefox menu button > Web Developer > Character Encoding" or "View > Character Encoding" if the menu bar is shown?

Which encoding is mentioned in Tools > Page Info > General?

  • Press the F10 key or tap the Alt key to bring up the hidden "Menu Bar" temporarily.
jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

Hi kadona, do you think a volunteer would see the same problem visiting a page that doesn't require a login? If so, you could post the URL.

kadona 0 solutions 20 answers

I went in again as a member, using Firefox as I had done previously, and there were no black diamonds. Bit of a mystery! I was about to post the url for you to look at but decided to take another look first. And they were not there!

Modified by kadona

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Sounds like a problem with cache corruption that fixed it self (data may have expired).

kadona 0 solutions 20 answers

"Did you try to go to "Firefox menu button > Web Developer > Character Encoding" or "View > Character Encoding" if the menu bar is shown?

Which encoding is mentioned in Tools > Page Info > General?

   Press the F10 key or tap the Alt key to bring up the hidden "Menu Bar" temporarily. "

I got on to 'tools', found Web Developer, but there was no 'Character Encoding' or the alternative there at all.

kadona 0 solutions 20 answers

I saw it again through Firefox - from the same website, but not the same page as before.

he Council of Islamic Organizations of Greater Chicago supports the idea.

�I think it will open up doors,� said Janaan Hashim, a spokeswoman for the group representing more than 400,000 Muslim Americans in the Chicago area. �Language is a man-made limitation. I think what God cares about is how we fulfill our purpose in life.�

The nation�s largest Catholic civil rights group says Catholics won't get behind the proposal.

�Bishop Martinus �Tiny� Muskens can pray to �Allah� all he wants, but only addlepated Catholics will follow his lead,� Bill Donohue, president of the Catholic League for Religious and Civil Rights, said in a statement. �It is not a good sign when members of the Catholic hierarchy indulge in a fawning exchange with Muslims, or those of any other religion.�

Thiis is the link:

http://z10.invisionfree.com/Ignis_Ardens/index.php?showtopic=12912

jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

Hi kadona, the diamonds are characters that are not compatible with UTF-8 (Unicode) encoding. You can get those characters to appear by switching to ISO-8859-1 encoding.

Hard to explain, but easy to do.

View menu > Character Encoding > Western (ISO-8859-1)

If you use the compact two-column menu (orange Firefox button), you can tap the Alt key or press the F10 key to reveal the classic menu bar with the View menu.

kadona 0 solutions 20 answers

I wish I knew what you mean. For the life of me I cannot find the 'encoding' word anywhere in tools. I see the web Developer there, but it leads nowhere. I don't know what you mean by the 'compact two-column menu' etc. or the orange firefox button.

When I click on Firefox it displays the google search page...there is no orange button. I pressed each of the keys you say to press, but nothing happens.

I'm totally illiterate with regard to these matters. Sorry to be so dumb!

jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

Hi kadona, Firefox on Windows has a choice of two different menu systems.

  • If you have the classic menu bar -- File, Edit, View, History, etc. -- look on the View menu for "Character Encoding".
  • If you do not have that bar, tap the Alt key or press the F10 key to display that menu bar.
jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

Hi kadona, if you can't get the menu bar to appear, make sure you are not using Full Screen mode. The F11 key switches between Full Screen and Normal views.

kadona 0 solutions 20 answers

AH! That's what I needed to know. Yes, I have the 'View' button. The encoding that is bulletted is Unicode (UTF-8). So would you say that is OK? .....that it cannot be anything wrong on my computer? That it must be something wrong with the website where it appeared?