X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I get PDF listed in "Options">"applications"? I want to stop FF pdf reader and use Tracker pdf viewer.

Posted

I use FF 21.0 on a desktop ruinning Windows 7-64.

I want to stop the FF pdf viewer and use my Tracker pdf viewer, like i did before FF added pdf viewing. I tried going to options>applications but there is no listed pdf viewing line other than one line for Tracker. I believe I need a line that mentions pdf files in the left column and then a listing in the right column allowing me to use Tracker (hopefully as a plugin).

I'm lost at this point and wish I had the older FF that didn't have pdf viewing built in.

Help please.

Chosen solution

Files always need to be downloaded if you want to open them.
Some are saved in the disk cache (e.g. Flash) and others in the temp folder (the ones past to other external programs and some plugins).

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.7 r700
  • GEPlugin
  • PDF-XChange Viewer Netscape Gecko Plugin
  • 5.1.20125.0
  • VLC media player Web Plugin 2.0.2

Application

  • Firefox 21.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
  • Support URL: http://support.mozilla.org/1/firefox/21.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Flash Video Downloader - Youtube Downloader 3.8.7 (artur.dubovoy@gmail.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Microsoft .NET Framework Assistant 1.2.1 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • Norton Toolbar 2013.3.5.1 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)
  • Norton Vulnerability Protection 11.3.0.9 - 5 ({BBDA0591-3099-440a-AA10-41764D9DB4DB}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 4200
  • adapterDescription2:
  • adapterDeviceID: 0x9710
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 368
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 4-19-2011
  • driverDate2:
  • driverVersion: 8.850.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 4200)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 880640
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.history_expire_days.mirror: 20
  • browser.history_expire_days_min: 30
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.search.param.yahoo-fr: chr-greentree_ff&type=302398
  • browser.search.useDBForOrder: False
  • browser.startup.homepage: http://www.google.com/
  • browser.startup.homepage_override.buildID: 20130511120803
  • browser.startup.homepage_override.mstone: 21.0
  • browser.urlbar.default.behavior: 1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • general.useragent.extra.microsoftdotnet: ( .NET CLR 3.5.30729; .NET4.0C)
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.cookieBehavior: 1
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1369628439
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • places.last_vacuum: 1303784574
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.clearOnShutdown.cookies: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

There has been a change in where Firefox searches for plugins and the plugins folder in the Firefox program folder is no longer scanned for plugins, so Firefox won't find them anymore if they are installed in the plugins folder instead of the "browser\plugins" folder that Firefox now scans.

You can set the plugins.load_appdir_plugins pref to true on the about:config page to make Firefox scan the "<install>/plugins/" directory for plugins like the WMP plugin (np-mswmp.dll).

You can alternatively move plugins from "<install directory>\plugins\" to "<install directory>\browser\plugins\" to make Firefox find them again.


You can change the action for Portable Document Format (PDF) from Preview in Firefox to use another application like the Adobe Reader or set to Always Ask in "Firefox > Options/Preferences > Applications".

You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer.

You can check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default via the right-click context menu.

See also:

Question owner

This sounds interesting but it doesn't say anything about how I can add PDF in the left column where file types are listed. My list is rather short and doesn't change even when I delete "mimetypws.rdf" and then reboot to re-create that file.

Without pdf in the left column I cannot even try to associate it with Adobe, Tracker, or whatever.

This started when FF added its own pdf viewer that causes my pdf files to have the top of them distorted.

Help

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24387 answers

See this support article.
https://support.mozilla.org/en-US/kb/disable-built-pdf-viewer-and-use-another-viewer

Question owner

This is no help to me.

The link tells me how to access "Portable Document Format (PDF)" in the left column. I have stated that "Portable Document Format (PDF)" does NOT exist in my available list. If it did, I'd probably be able to solve my problem.

Thanks

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Try to delete the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder

Helpful Reply

Yes, I have already done this and the new file created is also lacking the "Portable Document Format (PDF)" entry.

I can't believe it is so difficult, I must be missing something here.

Thanks.

jscher2000
  • Top 10 Contributor
2347 solutions 20809 answers

I'm not sure why it isn't populating. Do you have a PDF reader application installed as an external application?

If you would consider some manual file surgery, you could try adding a couple of lines to that mimeTypes.rdf file. If it gets hopelessly messed up, you can again delete it and have Firefox generate a new one.

If you open mimeTypes.rdf in a text editor (preferably something smarter than Notepad because Notepad cannot understand the line breaks), and search for PDF, you can see whether you have these. (Note: on the first one, you would add the middle line to your existing list and not create a duplicate list of mimetypes.)

<RDF:Seq RDF:about="urn:mimetypes:root">
 <RDF:li RDF:resource="urn:mimetype:application/pdf"/>
</RDF:Seq>
<RDF:Description RDF:about="urn:mimetype:handler:application/pdf"
  NC:handleInternal="true"
  NC:alwaysAsk="false" />
<RDF:Description RDF:about="urn:mimetype:application/pdf"
  NC:value="application/pdf">
 <NC:handlerProp RDF:resource="urn:mimetype:handler:application/pdf"/>
</RDF:Description>

Question owner

New info:

I have set "pdfjs.disabled pref to true" and now the FF pdf viewer does not operate (as far as I can tell so far).

My Tracker pdf viewer does work (good) but all pdf files I select are also downloaded (bad) before I see them.

Is there a way to have FF show me the pdf files opened, but not downloaded to my computer?

Thanks

jscher2000
  • Top 10 Contributor
2347 solutions 20809 answers

Hi fungusEYE, you wrote:

My Tracker pdf viewer does work (good) but all pdf files I select are also downloaded (bad) before I see them.

PDF files will always be downloaded to the cache or a temp folder even when viewed in the browser. Is that what you meant, or is the PDF launching externally?

Helpful Reply

Hmmm... I guess I'm getting tired. What you say is correct.

I am used to clicking on a pdf file that is in a page that FF is showing me and being able to choose to download only or view. This magically changed with me getting rid of FF's built in pdf viewer.

I wouldn't mind the FF pdf viewer but it does a poor job of displaying the pdf files, especially the upper edge where some on the image is missing.

I have figured out where FF saves the downloaded pdf files, which is important. So, I guess I'll deal with this for a while until an upgrade to FF will allow me to use the FF viewer.

Thank you!!!!

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Chosen Solution

Files always need to be downloaded if you want to open them.
Some are saved in the disk cache (e.g. Flash) and others in the temp folder (the ones past to other external programs and some plugins).

Question owner

Thanks everyone, I'll see how FF works for me now.

fungy