X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Keyboard shortcuts NOT working in 21.0

Posted

The Mac Keyboard commands (shortcuts) do NOT work on Firefox tabs now that I've updated to 21.0...

⌘f ⌘p ⌘s ⌘w do NOT work on Tabs in any regular and consistent manner now.

Sometimes if I open a tab, and it won't close with ⌘w, if I use a link in that tab it will then work from the new page... When I've multiple tabs open, original tabs won't close, tabs that move on using links will close...

To print, I have to go up and use the menu... This is NOT good...

Thanks for your help.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Version 3.19.1.13088
  • Google Talk Plugin Video Accelerator version:0.1.44.28
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • 5.1.10411.0
  • Facebook Video Calling by Skype
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.

Application

  • Firefox 21.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:21.0) Gecko/20100101 Firefox/21.0
  • Support URL: http://support.mozilla.org/1/firefox/21.0/Darwin/en-US/

Extensions

  • Adblock Plus 2.2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • AddThis 3.5.9 ({3e0e7d2a-070f-4a47-b019-91fe5385ba79})
  • CouponsHelper 1.1.8 ({239cc760-75a9-4276-b1fc-c0ceb963f373})
  • DownloadHelper 4.9.14 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • Element Hiding Helper for Adblock Plus 1.2.3 (elemhidehelper@adblockplus.org)
  • FireFTP 2.0.14 ({a7c6cf7f-112c-4500-a7ea-39801a327e5f})
  • FlashGot 1.5.5.4 ({19503e42-ca3c-4c27-b1e2-9cdb2170ee34})
  • Pocket 3.0.1 (isreaditlater@ideashower.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 126
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: Intel Inc. -- Intel HD Graphics 3000 OpenGL Engine
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130511120803
  • browser.startup.homepage_override.mstone: 21.0
  • browser.tabs.autoHide: True
  • browser.tabs.onTop: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • gfx.blacklist.webgl.msaa: 4
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1369480983
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3015 answers

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

Helpful Reply

It is possible that a plugin that is used on the web page of this tab has focus.
If a plugin has focus then the keyboard shortcuts won't work unless you click with the mouse elsewhere to remove the focus from the plugin object.

Question owner

It seems that the problem lies with the particular website I was visiting, alternet.org... Perhpas it is this "focus" cor-el speaks of... I've never had that problem with alternet.org before I upgraded to 21.0 though... Whatever focus is, it does NOT enhance my browsing experience.

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

Helpful Reply

If a plugin has focus then that means that the plugin is supposed to process and handle keyboard presses and not Firefox and in such a case you can't use shortcuts to control Firefox.

Did you try to click elsewhere on the page or in the user Firefox interface to see if that makes keyboard shortcuts work?

Question owner

Thank you for your consideration cor-el...

Clicking elsewhere on the page did nothing... Navigating to another alternet.org page did nothing... Only navigating to other websites allowed keyboard commands to work.

I don't have this problem with Safari (ugh!) or Chrome (ick!) and I want to continue to use Firefox...

I did NOT have this problem until just this week when I got 21.0 because YouTube suggested that my browser couldn't handle some of the HTML 5.0 video formats...

I have added NO plugins since I don't know when... And I don't know enough to understand some of what you folks are telling me. I'm sorry... Perhaps I should just drop it... Maybe it'll be fixed in the next update?

Thank you again for your consideration.

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

Did you try Safe Mode?

Question owner

Thank you all... I am NOT having trouble with the website today... I cannot duplicate the issue I was having with alternet.org any longer and so figure it has to do with their website.

I cannot say that this problem was "solved" because it rather "dissolved" seemingly on its own...

Thank you for your consideration.

Consider this closed for now, OK?

ryanov 0 solutions 2 answers

Mine is still doing this, or started doing it recently. Also alternet.org, also Firefox 21.

ryanov 0 solutions 2 answers

BTW: Chrome does it too! Weird!

jericobarker 0 solutions 1 answers

I have a PC not mac but still need some help.


Hello, I was using firefox 20 but unfortunately for me, it went update by itself. I gave it a try, but hell NO ! NO GODDAMNED SHORT CUTS with every single update you make you make it worse. FIREFOX used to be my favourite browser because of the flexibility it has, now, too many glitches and bugs. Well, I un-installed that crappy version of yours and returned even to older one. I use a lot of plugins and add-ons and everything went just fine. But I guess it took some kind of configuration file or settings from the 21 crappy version and now, no matter what version I install, there are no GOD DAMNED SHORTCUTS .. AND STOP WITH EVERYDAY UPDATES it is annoying and most of all, you don't make any significant changes, except make things even worst.

I dont have any shortcuts at any page.. HEEEEEEEEEEELP ! I NEED THE SHORTCUTS and I hope the developers to monitor their support forum and give an answer to that. !

Modified by jericobarker

bobrowton 0 solutions 1 answers

I have same issue, although only with the Alternet site so far, in both Firefox and Google Chrome. I found that if I disable my ad blocker then the functionality is restored. Oh, I'm running Windows XP.