X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

how to get rid off yahoo search?

Posted

when i search something from google search (in a webpage) it goes to the yahoo search website and show the results!

1.) there is no extension on add-ons, anything to do with search or yahoo 2.) i have tried reset the keyword.url from configuration 3.) i also tried to remove yahoo search engine from searchbar (didn't help)

This article didn't help either (same as above though): https://support.mozilla.org/en-US/kb/remove-toolbar-has-taken-over-your-firefox-search?esab=a&as=aaq

And i have avast and malware-program and those doesn't find anything.

No help. Everytime i search something in google, it goes to the yahoo search webpage! how to get rid of this yahoo rubbish?

I have no idea how it came. Maybe something to do with vlc codec pack? "Myfreecodec" that i tried to use when trying to play some mp4-file... i think i haven't installed anything else lately... And i always uncheck the "add this one on your browser..."

Modified by mreni

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Google Update
  • VLC media player Web Plugin 2.0.6
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • 5.1.20125.0
  • Shockwave Flash 11.5 r502
  • Bitdefender QuickScan Web Netscape Plugin
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 21.0
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
  • Support URL: http://support.mozilla.org/1/firefox/21.0/WINNT/en-US/

Extensions

  • Adblock Edge 2.0.4 ({fe272bd1-5f76-4ea4-8501-a05d35d823fc})
  • Adblock Plus 2.2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • avast! Online Security 8.0.1489 (wrc@avast.com)
  • Bitdefender QuickScan 0.9.9.119 ({e001c731-5e37-4538-a5cb-8168736a2360})
  • Ghostery 2.9.5 (firefox@ghostery.com)
  • NO Google Analytics 0.5 (jid1-JcGokIiQyjoBAQ@jetpack)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16433
  • driverDate: 8-21-2012
  • driverDate2:
  • driverVersion: 9.17.10.2843
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 4
  • numTotalWindows: 4
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.autostart: True
  • browser.search.param.yahoo-fr: chr-greentree_ff&ilc=12&type=888596
  • browser.startup.homepage: about:home
  • browser.startup.homepage_override.buildID: 20130511120803
  • browser.startup.homepage_override.mstone: 21.0
  • browser.urlbar.autocomplete.enabled: False
  • browser.zoom.full: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1369489192
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
Jafar Muhammed 11 solutions 72 answers

Try to use the SearchReset extension to reset some preferences to the default values.

https://addons.mozilla.org/en-US/firefox/addon/searchreset/

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3016 answers

Please go to your control panel and remove it from there.

vikay 0 solutions 2 answers

IN FRENCH : J'ai trouvé un truc qui fonctionne enfin. Sur Mac, mais cela doit être la même logique sous d'autres OS. Localiser le fameux fichier yahoo.xml qui se cache dans une bibliothèque "searchplugins"... et NE PAS SEULEMENT LE SUPPRIMER (il reviendrait), mais après sa suppression, y créer un dossier vide qui porte le même nom. Le fichier ne sera alors plus actif, et plus recréé !

IN +/- US : Locate the file yahoo.xml' in a "searchplugins" in your Library folder. Put it in the trash AND create, at the same place, an empty folder with the same name. It works on Mac... and certainly with other OS !

Lemon Pie 0 solutions 1 answers

Helpful Reply

Where in my control panel can I find this and uninstall it? I do not see it in programs. Thanks. (I have the same problem and it is making me crazy)

cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96741 answers

Hi lemonpie

Could you please start a new thread for your question instead of posting in an existing thread?

Then you can provide more information like your operating system and installed extensions and installed plugins.

In case of crashes also please add some recent crash IDs that you can find on the about:crashes page and that start with a "bp-" prefix


Did you try the SearchReset extension?

If you do not keep changes after a restart or otherwise have problems with preferences, see:

GingerH 0 solutions 10 answers

It's not showing up in my programs so that won't work!

jscher2000
  • Top 10 Contributor
2361 solutions 20908 answers

Hi GingerH, could you describe your issue in more detail? Where does Yahoo appear that you don't want it to appear? Some possibilities:

  • Search bar goes to Yahoo for results: there is an icon at the left side to change to a different search engine. This is browser global and also affects the address bar.
  • Address bar goes to Yahoo for results: please see above. However, one gotcha with the address bar is that when your search is only for a single word, Firefox will first look it up as a possible webserver name (e.g., intranet, thanksgiving, mozilla.org, anything with no spaces). Your ISP may intercept this lookup and send you to search results on its own choice of sites.
  • New tab page: normally Firefox displays 9 thumbnails of frequently visited sites. Has this page changed to something related to Yahoo?
  • Home page: Has this page changed to something related to Yahoo?

You may have an unwanted extension that is changing your search preferences or other pages. Try disabling ALL nonessential or unrecognized extensions on the Add-ons page. Either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if in doubt, disable.

Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

GingerH 0 solutions 10 answers

Thanks jscher2000, I finally did resolve it on my own. It was in fact a hijack & I caught it & removed it. But thanks for getting back to me... ~G~