X
Tap here to go to the mobile version of the site.

Support Forum

Cannot download apps, it shows gibberish on the page.

Posted

After the latest update I cannot download apps from some locations. Whenever I click on the download button it acts as though it will download then up pops a page of gibberish (it looks like code). I haven't changed anything and all my downloads work just fine in IE and Chrome, so I know it's a Firefox problem.

After the latest update I cannot download apps from some locations. Whenever I click on the download button it acts as though it will download then up pops a page of gibberish (it looks like code). I haven't changed anything and all my downloads work just fine in IE and Chrome, so I know it's a Firefox problem.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Amazon MP3 Downloader Plugin 1.0.17
  • NPWLPG
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17418 solutions 157376 answers

I also get a download dialog if I click the Download button with the link that jscher2000 provided (hadn't tested this before) and the file is send as text/plain, so maybe Firefox is doing some content sniffing after all.

You can try to delete the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
I also get a download dialog if I click the Download button with the link that jscher2000 provided (hadn't tested this before) and the file is send as text/plain, so maybe Firefox is doing some content sniffing after all. You can try to delete the mimeTypes.rdf file in the Firefox profile folder to reset all file actions. *http://kb.mozillazine.org/mimeTypes.rdf *http://kb.mozillazine.org/File_types_and_download_actions#Resetting_download_actions Clear the cache and the cookies from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > Cookies: "Show Cookies" Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

Thank you for your suggestions, however it's all just a bit too complicated for me! I'm not savvy enough to do all that you suggested so I guess I'll just have to live with it. Thanks!

Thank you for your suggestions, however it's all just a bit too complicated for me! I'm not savvy enough to do all that you suggested so I guess I'll just have to live with it. Thanks!

Question owner

Well I made a mistake! When I used the Alt and left click it downloaded the .exe file and I assumed it was correct. When I went back and clicked on the exe file the famous gibberish file reared it's ugly head. Soooo, the bottom line is nothing has fixed this and I'm back where I started! Oh well....thanks....jennye

Well I made a mistake! When I used the Alt and left click it downloaded the .exe file and I assumed it was correct. When I went back and clicked on the exe file the famous gibberish file reared it's ugly head. Soooo, the bottom line is nothing has fixed this and I'm back where I started! Oh well....thanks....jennye
jscher2000
  • Top 10 Contributor
8639 solutions 70667 answers

I'm curious about the sequence of events. By default, when you click the download button on the main page, CNET displays a thank you page, then there is a brief delay, then you get a dialog to Save/Cancel the download. Are you going straight from the main page to gibberish?

Does it help if you turn on the redirection warning feature to prevent the automatic loading, and then try the link that says "Your download will begin in a moment. If it doesn't, restart the download."

To turn on the redirection warning:

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, check the box for "Warn me when websites try to redirect or reload the page"

I'm not sure whether the "restart the download" link will serve the file any better. Do you notice any difference?

I'm curious about the sequence of events. By default, when you click the download button on the main page, CNET displays a thank you page, then there is a brief delay, then you get a dialog to Save/Cancel the download. Are you going straight from the main page to gibberish? Does it help if you turn on the redirection warning feature to prevent the automatic loading, and then try the link that says "Your download will begin in a moment. If it doesn't, restart the download." To turn on the redirection warning: orange Firefox button (or Tools menu) > Options > Advanced On the "General" mini-tab, check the box for "Warn me when websites try to redirect or reload the page" I'm not sure whether the "restart the download" link will serve the file any better. Do you notice any difference?
cor-el
  • Top 10 Contributor
  • Moderator
17418 solutions 157376 answers

Where are you clicking this .exe file?

If you do that on the download page then you are downloading this file once again and that makes Firefox display the file.

If you have downloaded and saved to file to your computer then you should run it via Windows Explorer by double-clicking the file.

Where are you clicking this .exe file? If you do that on the download page then you are downloading this file once again and that makes Firefox display the file. If you have downloaded and saved to file to your computer then you should run it via Windows Explorer by double-clicking the file.

Question owner

I click on the green download button and it redirects me to the page that says thank you, your download should start, then after a few seconds it jumps to the gibberish page. I clicked on the restart download button and got the gibberish. I tried your redirect thing and that didn't work either.

I click on the tools button at the top and click on downloads then double click on the file I just downloaded and the result is the same.

If I go to the downloads folder on my hard drive it does the same thing. No matter what the hell I do, it shows gibberish after the initial Thank You page!

I click on the green download button and it redirects me to the page that says thank you, your download should start, then after a few seconds it jumps to the gibberish page. I clicked on the restart download button and got the gibberish. I tried your redirect thing and that didn't work either. I click on the tools button at the top and click on downloads then double click on the file I just downloaded and the result is the same. If I go to the downloads folder on my hard drive it does the same thing. No matter what the hell I do, it shows gibberish after the initial Thank You page!
cor-el
  • Top 10 Contributor
  • Moderator
17418 solutions 157376 answers

You can try these steps to reset the download actions:

Open the Troubleshooting Information page:

  • Firefox > Help > Troubleshooting Information

Find "Profile Directory" and click "Show Folder" to open the Firefox profile folder in Windows Explorer.

Close Firefox.

Find the mimeTypes.rdf file in the Firefox program folder that you have opened in Windows Explorer. Rename the file to mimeTypes.rdf.sav (i.e. append .sav to the current file name). Start Firefox and check if it has had any effect.

See also:

You can try these steps to reset the download actions: Open the Troubleshooting Information page: *Firefox > Help > Troubleshooting Information Find "Profile Directory" and click "Show Folder" to open the Firefox profile folder in Windows Explorer. Close Firefox. Find the <b>mimeTypes.rdf</b> file in the Firefox program folder that you have opened in Windows Explorer. Rename the file to <b>mimeTypes.rdf.sav</b> (i.e. append .sav to the current file name). Start Firefox and check if it has had any effect. See also: *http://kb.mozillazine.org/File_types_and_download_actions#Resetting_download_actions
jscher2000
  • Top 10 Contributor
8639 solutions 70667 answers

Okay, this is a kludgey workaround, but until someone has a better idea...

First, turn on the redirect warning per the above message. This should prevent auto-loading of gibberish.

Then, on that download page, open Firefox's web console by pressing Ctrl+Shift+k.

This opens the developer tools pane at the bottom of the page or in a pop-up, depending on how yours is set up. Next to the caret (">"), paste this code and press Enter to run it (it's all one long line).

var url = document.querySelector("meta[http-equiv='Refresh'][content*='fileName']").getAttribute("content").split("URL=")[1]; var dnew = document.createElement("div"); dnew.setAttribute("style", "position:fixed; top:0; z-index:500; background:#ccc; padding:3em; width:100%"); dnew.innerHTML = "<p style=\"text-align:center;\"><a href=" + url + ">Right-click and Save Link As</a></p>"; document.body.appendChild(dnew);

This should yield the new link shown in the attached image.


If you download from CNET frequently, you could save this code to a button on the Bookmarks Toolbar. Not sure it's worth listing the steps. Let me know if that would be helpful.

Okay, this is a kludgey workaround, but until someone has a better idea... First, turn on the redirect warning per the above message. This should prevent auto-loading of gibberish. Then, on that download page, open Firefox's web console by pressing Ctrl+Shift+k. This opens the developer tools pane at the bottom of the page or in a pop-up, depending on how yours is set up. Next to the caret (">"), paste this code and press Enter to run it (it's all one long line). var url = document.querySelector("meta[http-equiv='Refresh'][content*='fileName']").getAttribute("content").split("URL=")[1]; var dnew = document.createElement("div"); dnew.setAttribute("style", "position:fixed; top:0; z-index:500; background:#ccc; padding:3em; width:100%"); dnew.innerHTML = "&lt;p style=\"text-align:center;\">&lt;a href=" + url + ">Right-click and Save Link As&lt;/a>&lt;/p>"; document.body.appendChild(dnew); This should yield the new link shown in the attached image. ---- If you download from CNET frequently, you could save this code to a button on the Bookmarks Toolbar. Not sure it's worth listing the steps. Let me know if that would be helpful.

Question owner

I changed the name of the file to the .sav on the end as you suggested. Then I reopened Firefox and when I did it put back in the previous file. I now have two files:

mimeTypes.rdf

mimeTypes.sav

I deleted the one and whenever I reopen Firefox, it puts it back in! I've had enough.....

I changed the name of the file to the .sav on the end as you suggested. Then I reopened Firefox and when I did it put back in the previous file. I now have two files: mimeTypes.rdf mimeTypes.sav I deleted the one and whenever I reopen Firefox, it puts it back in! I've had enough.....
jscher2000
  • Top 10 Contributor
8639 solutions 70667 answers

Firefox needs a mimeTypes.rdf. The point of renaming the old one was to force Firefox to generate a fresh one.

Firefox needs a mimeTypes.rdf. The point of renaming the old one was to force Firefox to generate a fresh one.
cor-el
  • Top 10 Contributor
  • Moderator
17418 solutions 157376 answers

Did renaming this file have any effect on downloading files from the CNET site?

Did renaming this file have any effect on downloading files from the CNET site?

Question owner

No it didn't. Firefox simply added the file as it was before. This is what I wrote last night:

I changed the name of the file to the .sav on the end as you suggested. Then I reopened Firefox and when I did it put back in the previous file. I now have two files:

mimeTypes.rdf

mimeTypes.sav

I deleted the one and whenever I reopen Firefox, it puts it back in! I've had enough.....

No it didn't. Firefox simply added the file as it was before. This is what I wrote last night: I changed the name of the file to the .sav on the end as you suggested. Then I reopened Firefox and when I did it put back in the previous file. I now have two files: mimeTypes.rdf mimeTypes.sav I deleted the one and whenever I reopen Firefox, it puts it back in! I've had enough.....

Question owner

After renaming and reopening Firefox, it still produced gibberish.

After renaming and reopening Firefox, it still produced gibberish.