Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

There is a problem with some div class=xx

  • 14 replies
  • 3 have this problem
  • 3 views
  • Last reply by Kylon0

more options

My problem is

i m making a website in xhtml 1.1 tested on safari, opera, chrome, dragon, ie10.

i added a div class=box in a page and a sprymenu in an other page.

when you open the site with firefox there is some space at the end of the page

so for ex.

all the other browsers:

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
header

content

footer

end
:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

firefox:

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
header

content

footer





end
:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::.


i tried to delete the space with the css with no luck

Modified by cor-el

All Replies (14)

more options

Can you post a link to a page demonstrating this problem? (It doesn't have to contain your actual content, of course.) Otherwise, it's probably impossible to guess the source of the problem. (If I had to guess, I'd start by investigating floats and clearing, and any use of positioning.)

(Also, I'm not sure you pasted into your post, but this page has a horizontal scrollbar, which is unusual. If you need to post HTML, I suggest creating a new page on http://pastebin.com/ and linking to it in your post.)

more options

http://pastebin.com/BXYxGyvT

i enabled overflow : auto, so yes, when you add too many text threre will be a scrollbar

anyway only firefox has this problem

more options

Does the problem occur if you disable JavaScript here?

orange Firefox button (or Tools menu) > Options > Content

If so, then we just need the CSS file to replicate the issue.

If the problem disappears without JavaScript, then we also need to see the script file.

more options

i cannot find this option i m using nightly 24

http://pastebin.com/jN2Bssin

more options

The support article shows the Content tab up to Firefox 22. I assume ?!) the Enable JavaScript checkbox is still there:

https://support.mozilla.org/kb/settings-fonts-languages-pop-ups-javascript

more options

nope

my nightly only has "block poup-up windows"

there is no "load images automatically" and "enable java" option

maybe they will delete them in firefox 23

more options

Hi Kylon0, you wrote:

nope
my nightly only has "block poup-up windows"
there is no "load images automatically" and "enable java" option
maybe they will delete them in firefox 23

Oh crap, yes, it's been removed on purpose. (Bug #851702)

You'll have to use about:config for this.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste java and pause while the list is filtered

(3) Double-click javascript.enabled to flip its value from true to false.

Leave this tab open so you can easily switch back.

The reason this checkbox was removed was that users could too easily create problems for themselves by disabling JavaScript. However, I think this movement to simplification is becoming annoying to advanced users so hopefully someone will create an add-on for advanced users that seamlessly restores the old controls. (I can hope!)

For future reference, the preferences corresponding to the checkboxes in the Advanced JavaScript Settings dialog (and Fx21 default settings) are:

Move or resize popup windows (checked):
  dom.disable_window_move_resize (false)
Raise or lower windows (unchecked):
  dom.disable_window_flip (true)
Disable or replace context menus (checked):
  dom.event.contextmenu.enabled (true)
more options

yea, i know about these settings

anyway, no the problem is still there

i think that mozilla does not read the code correctly

more options

Using position:relative and bottom:nnnpx to position the text divs (#news and #copyright) doesn't make sense without the images, so I am not able to see what you're seeing in a real page. Can you post a link to a demo page that links in the images?

more options

Firefox appears to be reserving space at the bottom of the document for the two elements that have the combination of position:relative and bottom. That is consistent with the documentation:

relative
Lay out all elements as though the element were not positioned, and then adjust the element's position, without changing layout (and thus leaving a gap for the element where it would have been had it not been positioned).
https://developer.mozilla.org/en-US/docs/Web/CSS/position

more options

umm but all the browsers are ok with it if i delete relative i need to reorder the page

more options

It seems much easier to use background images instead of placing the images inline and positioning content over them.

more options

i can do it for the footer but for ex. if you need a sprymenu you need relative to move the div and you have the same result(some space at the end of the page)

i don t understand why only mozilla has this problem