X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Why do I get a empty pop-up tab when I use firefox?

Posted

When ever I start firefox, a few seconds later, another tab will open up on it's own and it is empty. I continually have to close it and then a few seconds later, it opens again. What ever the page is, it has a statement saying firefox has prevented this window from opening etc....with an allow exception. It does seem to be a pop-up but my pop-up blocker is on. I did uninstall firefox and re-installed it. Is it a setting on a certain website or is it in Mozilla? Thanks.....Jason

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • iTunes Detector Plug-in
  • WildTangent Games App V2 Presence Detector
  • 5.1.20125.0
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6635 answers

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Thank you.

Question owner

Wouldn't uninstalling it and re-installing fix it? That was what I did. I noticed explorer, and google chrome are doing it too. There must be a setting I am missing either in the virus protection or the computer setting or security.

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.


Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

SJF2 0 solutions 7 answers

Just for reference as this thread is a few months old... When you uninstall Firefox, some settings, files and even add-ons can remain behind, and they are not in the folder where Firefox was installed. When you install Firefox again, those settings can come into play just as they did before. In your case, just doing a "Reset Firefox" procedure will, most likely, yield a different result as it should "unhook" the new install from the old stuff. If you want to uninstall and reinstall, doing a "Reset" before you uninstall can help your new install to be a clean one. In any case, a "Reset" is always the safest way to have Firefox permanently return to the cleanest state that it can. The Reset function tries very hard to keep your bookmarks, etc. and it is usually successful at doing that - I've never lost them. For testing purposes, restarting Firefox in Safe Mode (without clicking "Reset") should provide the same "Clean" environment. Now, having said all that, if you have a virus or malware you can throw all that out the window as it probably won't help. Scan as suggested, reboot and then proceed with whatever troubleshooting you think is necessary. Hope this helps...

EDIT: One last thought... What is your default Home Page. That page COULD be spawning your popups. Change the "Settings" to use "about:home" for a test.

Modified by SJF2