X
Tap here to go to the mobile version of the site.

Support Forum

All answers so far don't help. Now I get Firefox stopped working everytime I close

Posted

So far nothing works! I am fed up with Firefox & ready to change! It gives me the same message everytime I close Firefox! Its just not worth it & I don't see Mozilla support doing anything about the new version that sucks!

I am certainly NOT going to update to the new version 21! I hate the newer versions of Firefox! I never had a problem with it until I updated to the latest version!!!

So far nothing works! I am fed up with Firefox & ready to change! It gives me the same message everytime I close Firefox! Its just not worth it & I don't see Mozilla support doing anything about the new version that sucks! I am certainly NOT going to update to the new version 21! I hate the newer versions of Firefox! I never had a problem with it until I updated to the latest version!!!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • RealArcade_NPAPI_Plugin
  • NPWLPG

Application

  • Firefox 20.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

Extensions

  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Photobucket Uploader 1.3.3 (pbupload@photobucket.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) G45/G43 Express Chipset
  • adapterDescription2:
  • adapterDeviceID: 0x2e22
  • adapterDeviceID2:
  • adapterDrivers: igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'8.1500.1000.2202']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 8-14-2008
  • driverDate2:
  • driverVersion: 7.15.10.1545
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'8.1500.1000.1855']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'8.1500.1000.1855']
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.blockautorefresh: True
  • accessibility.browsewithcaret: True
  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1024
  • browser.cache.disk.smart_size.first_run: False
  • browser.display.background_color: #C0C0C0
  • browser.display.use_document_fonts: 0
  • browser.history_expire_days.mirror: 180
  • browser.history_expire_days_min: 1
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.search.suggest.enabled: False
  • browser.startup.homepage: http://www.msn.com/
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • browser.tabs.loadInBackground: False
  • browser.tabs.onTop: False
  • dom.disable_window_move_resize: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • font.default.x-western: sans-serif
  • font.language.group: x-western
  • font.minimum-size.x-central-euro: 12
  • font.minimum-size.x-western: 17
  • font.name.sans-serif.x-western: Century Gothic
  • font.name.serif.x-central-euro: Courier New
  • font.name.serif.x-western: MS Serif
  • font.size.fixed.x-western: 17
  • font.size.variable.ar: 12
  • font.size.variable.x-baltic: 12
  • font.size.variable.x-central-euro: 12
  • font.size.variable.x-western: 18
  • keyword.URL: http://mystart.incredimail.com/?loc=ff_address_bar_fs&search=
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1367978593
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 79594
  • places.history.expiration.transient_optimal_database_size: 127349882
  • places.last_vacuum: 1317852741
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.clearOnShutdown.formdata: False
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.clearOnShutdown.sessions: False
  • privacy.cpd.cookies: False
  • privacy.donottrackheader.enabled: True
  • privacy.item.history: False
  • privacy.item.offlineApps: True
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • security.default_personal_cert: Select Automatically
  • security.disable_button.openDeviceManager: False
  • security.OCSP.disable_button.managecrl: False
  • security.OCSP.enabled: 0
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
Andrew
  • Moderator
324 solutions 4090 answers

Perhaps updating to the latest version may fix your issue instead. Otherwise you can try this:

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Perhaps updating to the latest version may fix your issue instead. Otherwise you can try this: Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * You can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. ''Once you get the pop-up, just select "'Start in Safe Mode"'' '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.
cor-el
  • Top 10 Contributor
  • Moderator
17673 solutions 159870 answers

In case you are using "Clear history when Firefox closes" try not to clear the Cookies if you currently do this.

  • Make sure that Firefox closes properly and that there isn't a hanging Firefox or plugin-container process left in the Task Manager.
  • Use "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: "Firefox > Quit Firefox"; Linux: "Firefox/File > Quit") to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar.

See also:

In case you are using "Clear history when Firefox closes" try not to clear the Cookies if you currently do this. *Tools > Options > Privacy > Firefox will: "Use custom settings for history": [X] "Clear history when Firefox closes" > Settings *https://support.mozilla.org/kb/Clear+Recent+History *Make sure that Firefox closes properly and that there isn't a hanging Firefox or plugin-container process left in the Task Manager. *Use "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: "Firefox > Quit Firefox"; Linux: "Firefox/File > Quit") to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar. See also: *"Hang at exit": http://kb.mozillazine.org/Firefox_hangs *"Firefox hangs when you quit it": https://support.mozilla.org/kb/Firefox+hangs