X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

How come watching youtube clips and other videos is like watching a slideshow?

Posted

When I watch youtube clips and other videos or film clips on Firefox it feels like I'm watching a slideshow made of stills that isn't synchronized with the sound at all. The clip usually freezes several times while watching it. The timer stops and then continues several seconds later.

When I watch youtube clips and other videos or film clips on Firefox it feels like I'm watching a slideshow made of stills that isn't synchronized with the sound at all. The clip usually freezes several times while watching it. The timer stops and then continues several seconds later.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Google Update
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122
  • Shockwave Flash 11.6 r602
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • 5.1.20125.0
  • VLC media player Web Plugin 2.0.0
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

Andrew
  • Moderator
326 solutions 4110 answers

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * You can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. ''Once you get the pop-up, just select "'Start in Safe Mode"'' '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.
cor-el
  • Top 10 Contributor
  • Moderator
17851 solutions 161559 answers

You can check for problems with current Flash plugin versions and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)
  • disable hardware acceleration in the Flash plugin
You can check for problems with current Flash plugin versions and try these: *disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed *disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) *disable hardware acceleration in the Flash plugin *http://kb.mozillazine.org/Flash#Troubleshooting
semnc 0 solutions 11 answers

Have you tried opening the task manager and seeing what process is utilizing the resources. I have the same issue (not just on YouTube) and found that in some cases Firefox's plugin-container.exe is utilizing up to 99% of the CPU capability. It seems to be associated with the Adobe flash player. The same web page on Chrome runs fine. I have posted a question about this twice, but have received no response.

Have you tried opening the task manager and seeing what process is utilizing the resources. I have the same issue (not just on YouTube) and found that in some cases Firefox's plugin-container.exe is utilizing up to 99% of the CPU capability. It seems to be associated with the Adobe flash player. The same web page on Chrome runs fine. I have posted a question about this twice, but have received no response.
alan_r 127 solutions 1451 answers

Removing the older of the two Shockwave Flash plug-ins that you have, just might help.

Removing the older of the two Shockwave Flash plug-ins that you have, just might help.

Question owner

semnc: You have exactly the same problem as me. I have to use either Explorer or Chrome to watch moving pictures. I checked the task manager and noticed the same thing about Firefox's plugin-container.exe.

semnc: You have exactly the same problem as me. I have to use either Explorer or Chrome to watch moving pictures. I checked the task manager and noticed the same thing about Firefox's plugin-container.exe.

Modified by Lapanyman

semnc 0 solutions 11 answers

This is not a new issue. I found several references to it including YouTube videos on how to remove plugin-container.exe in multiple languages, but this shuts down the viewing. It is not crippling every time it is used, but it consistently shuts down some pages completely (for example: http://www.washingtonpost.com/blogs/innovations/wp/2013/05/07/the-shot-heard-round-the-maker-world/?wpisrc=nl_tech_b). What I cannot understand is why I can find no acknowledgement of the issue by Mozilla or recommendations. There seems to be a moderator monitoring this forum. Maybe they will notice.

This is not a new issue. I found several references to it including YouTube videos on how to remove plugin-container.exe in multiple languages, but this shuts down the viewing. It is not crippling every time it is used, but it consistently shuts down some pages completely (for example: http://www.washingtonpost.com/blogs/innovations/wp/2013/05/07/the-shot-heard-round-the-maker-world/?wpisrc=nl_tech_b). What I cannot understand is why I can find no acknowledgement of the issue by Mozilla or recommendations. There seems to be a moderator monitoring this forum. Maybe they will notice.
semnc 0 solutions 11 answers

Thank you alan_r, but I only have the latest 11.7.700.169 installed. I did have the old version on the system and removed it with no help.

Thank you alan_r, but I only have the latest 11.7.700.169 installed. I did have the old version on the system and removed it with no help.

Modified by semnc

Question owner

I also only have the 11.7.700.169 version installed. I have removed all the older versions.

I also only have the 11.7.700.169 version installed. I have removed all the older versions.
user633449 1539 solutions 10745 answers

Has anyone tried disabling Flash protected mode? http://forums.adobe.com/message/4468493

Along with Hardware acceleration: Turning off hardware acceleration in firefox, and in Flash: http://forums.adobe.com/thread/891337

Has anyone tried disabling Flash protected mode? http://forums.adobe.com/message/4468493 Along with Hardware acceleration: [[Upgrade your graphics drivers to use hardware acceleration and WebGL#w_turning-off-hardware-acceleration|Turning off hardware acceleration]] in firefox, and in Flash: http://forums.adobe.com/thread/891337
semnc 0 solutions 11 answers

I have tried the hardware acceleration thing, but not the protect mode. Has anyone at Mozilla tried the link provided? Please understand that ONLY Firefox has this problem. Thanks

I have tried the hardware acceleration thing, but not the protect mode. Has anyone at Mozilla tried the link provided? Please understand that ONLY Firefox has this problem. Thanks
user633449 1539 solutions 10745 answers

Yes, disabling protected mode is something that has to be done by alot of users, Adobe introduced it in Flash 11.3 for Firefox sometime ago, and it's been trouble ever since.

Yes, disabling protected mode is something that has to be done by alot of users, Adobe introduced it in Flash 11.3 for Firefox sometime ago, and it's been trouble ever since.
semnc 0 solutions 11 answers

OK, Protect=0 did not help. Still pulling 99% CPU for that link. Thanks

OK, Protect=0 did not help. Still pulling 99% CPU for that link. Thanks

Modified by semnc

Helpful Reply

I have also tried the same things as semnc and the problems still continue.

I have also tried the same things as semnc and the problems still continue.
semnc 0 solutions 11 answers

I have another discovery. It may help whomever is ultimately going to solve this. Here is another link which crashes the browser. http://www.washingtonpost.com/blogs/innovations/wp/2013/05/10/the-ways-of-silicon-valley/?wpisrc=nl_tech_b The United Health Care and Bank of America Adds are common.

I have another discovery. It may help whomever is ultimately going to solve this. Here is another link which crashes the browser. http://www.washingtonpost.com/blogs/innovations/wp/2013/05/10/the-ways-of-silicon-valley/?wpisrc=nl_tech_b The United Health Care and Bank of America Adds are common.
Andrew
  • Moderator
326 solutions 4110 answers

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Upgrade your graphics drivers to use hardware acceleration and WebGL

Did this fix your problems? Please report back to us!

Thank you.

Hello, Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: *Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. *In the Firefox options window click the ''Advanced'' tab, then select "General". *In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. *Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Did this fix your problems? Please report back to us! Thank you.
semnc 0 solutions 11 answers

freer56, Thanks, but we have already done that. It made no difference.

freer56, Thanks, but we have already done that. It made no difference.

Helpful Reply

freer56, Thanks, I have also tried that but unfortunately it didn't do any difference.

freer56, Thanks, I have also tried that but unfortunately it didn't do any difference.
palatino 0 solutions 8 answers

"What I cannot understand is why I can find no acknowledgement of the issue by Mozilla or recommendations. There seems to be a moderator monitoring this forum. Maybe they will notice. "

>> I cannot agree more. It is plain as day from the number and consistency of the trouble reports that there is a major F#&*Up with the way Firefox handles video, and no matter how many times users report the issues, nobody at Firefox/Mozilla will admit it is a Firefox problem. Mozilla engineers are obviously not fixing it, and they are pretending not to hear when we keep repeating the same problem reports over and over.

"What I cannot understand is why I can find no acknowledgement of the issue by Mozilla or recommendations. There seems to be a moderator monitoring this forum. Maybe they will notice. " >> I cannot agree more. It is plain as day from the number and consistency of the trouble reports that there is a major F#&*Up with the way Firefox handles video, and no matter how many times users report the issues, nobody at Firefox/Mozilla will admit it is a Firefox problem. Mozilla engineers are obviously not fixing it, and they are pretending not to hear when we keep repeating the same problem reports over and over.