X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox automatically appends .com if no domain is given

Posted

On the address bar, when I just type a word, it searches for the word in Google as expected. Let's say I have a local domain, accessible in vpn, say, 'mysite' takes me to 10.10.x.x.

On desktop, when I type, 'mysite', it takes me to the site. On mobile, it searches for the word 'mysite'. I would be okay with this though. But when I try 'http://mysite', it converts it to 'http://mysite.com' which is not my site and I do not intend to visit.

Would someone help me turning this feature off or some work around?

Thanks!

Chosen solution

hello _senthilkumar, it should be possible to change that. enter about:config into the location bar & search for the preference named browser.fixup.alternate.enabled (it should be enough to just enter 'fix' into the search bar). toggle the value of this preference to false.

Read this answer in context 3

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

Chosen Solution

hello _senthilkumar, it should be possible to change that. enter about:config into the location bar & search for the preference named browser.fixup.alternate.enabled (it should be enough to just enter 'fix' into the search bar). toggle the value of this preference to false.

Question owner

Hello phillip! Thanks for the tip! Works like a charm!

Thanks!

emartini 0 solutions 1 answers

Hi, I've the same problem but not solved by your solution... It seem to be a DNS résolution problem (windows 2003 server AD)... I test an Android DNS resolution tool with : - mysite.mydomain.pri : OK @IP xxx.xxx.xxx.xxx - mysite : KO (SERVFAIL)

If I do an nslookup on my windows PC : - mysite : OK return myserver.mydomain @IP xxx.xxx.xxx.xxx

Any idea...