X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

plugin container crash

Posted

Not only does Flash crash (every version since v9), but Microsoft Silverlight hangs the plugin container as well. Something's clearly not right with the design of this.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • 5.1.20125.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

iamjayakumars
  • Top 10 Contributor
411 solutions 4868 answers

Please upgrade your Firefox to latest version and give a try

Firefox Orange Button > Help > About Firefox

Download Mozilla Firefox

the-edmeister
  • Top 10 Contributor
  • Moderator
3193 solutions 24375 answers

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash ID's to help us learn more about your crash.

  1. Enter about:crashes in the address bar (that's where you enter your website URL) and press Enter. You should now see a list of submitted crash reports.
  2. Copy the 5 most recent crash ID's that you see in the crash report window and paste them into your response here.

Thank you for your cooperation!

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

doodle1952point5 0 solutions 1 answers

You mean like this? Plugincontainer doesn't actually crash it just uses 99% of CPU.

546c2994-a82b-4ea4-b841-b7eeb90375da 6/4/2013 16:36 
7185603b-ecbd-4874-a07d-802a7caa9d24 6/4/2013 16:27 
0de560bf-9bd8-4eca-be32-fb399b70088b 6/4/2013 15:29 
47b1d461-8128-4bd7-b95f-0bf6d1a937ab 6/4/2013 12:25 
04f584e9-d1a7-4892-88b7-482111fd647c 5/29/2013 14:34 
d6c5f4b5-6740-4cdd-83fb-bae1e72e7835 5/20/2013 16:38 
3d78e408-43c5-4f7c-8361-4cb0d88c4a57 5/20/2013 16:16 

Modified by cor-el

Phicles4 0 solutions 1 answers
c849b1f7-2407-4f47-aa6f-27e7a9e0e3bf 7/25/2013 9:57 PM
8e97b0cd-e7ee-4793-9dca-9a9bfbbaa143 7/25/2013 9:57 PM
8c938cc6-ff28-4745-8514-40e38f09590c 7/25/2013 9:57 PM
96135336-c90a-481c-9a42-fde5c22e4f35 7/25/2013 9:57 PM
6ea1f122-43ad-4ed8-b277-7c0c78d9ed4a 7/25/2013 9:57 PM

Modified by cor-el

Waka_Flocka_Flame
  • Top 25 Contributor
528 solutions 5041 answers

Recent crashes (and Hangs) of certain multimedia contents (this includes Youtube videos, certain flash games and other applications) in conjunction with Firefox are most probably caused by a recent Flash update and/or a malfunctioning browser plugin such as Real Player.

In order to remedy the problem, please perform the steps mentioned in these Knowledge Base articles:

Other, more technical information about these issues can be found under these Links:


Please tell us if this helped!

Dan in St. Louis 0 solutions 8 answers
bp-c41350b3-efba-4cef-b5d9-c6ee22130908 9/8/2013 12:37 PM
bp-6219c84b-9943-4c39-95cf-d6de02130830 8/29/2013 8:33 PM
bp-bb0eaf2f-8214-4100-8a59-adf542130828 8/28/2013 3:44 PM
bp-eb922c5a-1cf7-42b3-9065-3d64a2130826 8/25/2013 8:22 PM
bp-74cdbd99-96a6-429f-8ae1-a0cb42130824 8/24/2013 9:38 AM

Yes, "plugin container" crashes often.

Modified by cor-el

jscher2000
  • Top 10 Contributor
2344 solutions 20793 answers

Hi dlandiss, based on the latest crash data, I recommend disabling the Flash Player plugin's protected mode. See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox? Note the specific folder path for 32-bit vs. 64-bit Windows (both folders exist on 64-bit Windows, but Firefox only uses the Flash plugin in the SysWOW64 path).

Dan in St. Louis 0 solutions 8 answers

Thank you, jscher. I have done that and will keep watching.

--Dan in St. Louis

Dan in St. Louis 0 solutions 8 answers

jscher, I made the change you proposed and Firefox still crashes:

bp-fed4de28-9239-4110-a697-6491d2130909 9/9/2013 7:47 AM
bp-c41350b3-efba-4cef-b5d9-c6ee22130908 9/8/2013 12:37 PM
bp-6219c84b-9943-4c39-95cf-d6de02130830 8/29/2013 8:33 PM
bp-bb0eaf2f-8214-4100-8a59-adf542130828 8/28/2013 3:44 PM
bp-eb922c5a-1cf7-42b3-9065-3d64a2130826 8/25/2013 8:22 PM
bp-74cdbd99-96a6-429f-8ae1-a0cb42130824 8/24/2013 9:38 AM
bp-673d02b9-c972-47ec-b306-a1c0a2130812 8/12/2013 2:42 PM

--Dan in St. Louis

Modified by cor-el

jscher2000
  • Top 10 Contributor
2344 solutions 20793 answers

Hi Dan, your latest crash unfortunately has incomplete data so I'm not able to interpret it ("no crashing thread identified; corrupt dump"). While I hope you don't have more crashes, please do post the next ID you get if it has more information.

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Helpful Reply

Try to disable hardware acceleration in Firefox.

Jim.OBrien 0 solutions 5 answers
bp-c96c4966-124d-4b63-aa05-73a4c2131001 10/1/2013 4:58 AM
bp-17086050-8b1d-461f-b2d9-f8e462131001 10/1/2013 4:57 AM
bp-43058949-7830-4ee5-86ce-449642131001 9/30/2013 11:37 PM
bp-c2019ab1-8501-45b1-88e9-4f02f2130930 9/30/2013 1:24 PM
bp-4515565b-e701-4048-9eea-a3e122130930 9/30/2013 5:28 AM

Modified by cor-el

Dan in St. Louis 0 solutions 8 answers

It just won't quit. There have been several crashes that are not logged here -- at least 4 in the past 2 days. Often there is also a warning that a script stopped running.

Report ID                             	Date Submitted
bp-22963ba0-6389-45b3-bcc9-6c7a22131005 10/5/2013 9:05 AM
bp-73f71da9-cda0-4e3e-ab6d-25f632131002 10/2/2013 10:07 AM
bp-fed4de28-9239-4110-a697-6491d2130909 9/9/2013 7:47 AM
bp-c41350b3-efba-4cef-b5d9-c6ee22130908 9/8/2013 12:37 PM
bp-6219c84b-9943-4c39-95cf-d6de02130830 8/29/2013 8:33 PM
bp-bb0eaf2f-8214-4100-8a59-adf542130828 8/28/2013 3:44 PM
bp-eb922c5a-1cf7-42b3-9065-3d64a2130826 8/25/2013 8:22 PM
bp-74cdbd99-96a6-429f-8ae1-a0cb42130824 8/24/2013 9:38 AM
bp-673d02b9-c972-47ec-b306-a1c0a2130812 8/12/2013 2:42 PM
cc264d75-92ee-4009-a88d-5212883d9bb3 7/22/2013 9:27 PM

Modified by cor-el

jscher2000
  • Top 10 Contributor
2344 solutions 20793 answers

Hi dlandiss, is Oct. 5th your latest? In looking at some other crash reports that have the same signature on Firefox 24+Windows 7, one frequent commonality is the Skype extension. Could you try disabling it and see whether that makes any difference? You can do that on the Add-ons page here:

orange Firefox button (or Tools menu) > Add-ons > in the left column click Extensions

You may want to disable other extensions you don't mind living without for 48 hours to see whether you have a problem running just the essential ones.

Dan in St. Louis 0 solutions 8 answers

October 5 is only the most recent crash that was recorded. FF has crashed at least 4 times in the past 2 days.

I have now disabled The Skype extension, and all plug-ins except Java and Flash. Unfortunately Flash freezes often and I get the "Shockwave Flash stopped running" error message.

Thank you for your help, I hope we can narrow down the possible causes.

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Does it help if you set the Flash and Java plugin to "Ask to activate" to prevent them from starting automatically?

Dan in St. Louis 0 solutions 8 answers

Unfortunately that choice does not seem to be available for the Flash and Java plugins -- just "always activate" or "never activate."

Thanks---

Dan in St. Louis

Dyvik Chenna 7 solutions 96 answers

Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" Thank you.

Dan in St. Louis 0 solutions 8 answers

dyvik1001, on September 10 (a few messages above in this thread) I was advised to turn that off, so I did. I found no difference in crash rate.

Thank you.

--Dan in St. Louis

jscher2000
  • Top 10 Contributor
2344 solutions 20793 answers

Hi Dan, before you get that third choice, you need to change a preference in the about:config preference editor.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box that appears above the list, type or paste click and pause while the list is filtered

(3) Double-click the plugins.click_to_play preference to switch it from false to true