X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

My browser keeps saying adobe has crashed. The errors have become more frequent now.

Posted

My browser freezes then I get the error about adobe crashing. This has been happening for a few months now. I've uninstalled and reinstalled firefox and adobe multiple times. I tried making a new profile for firefox also, but nothing has helped. This past week I have also been getting errors about the shockwave plugin crashing. I've tried malware removal, antivirus removal, but it's all coming back clean. I'm not sure what to do anymore.

Chosen solution

That is so true and so sad. I wish all these companies would just own up, admit they need to work on things and solve this problem. I also just read on Adobe's website last night, that apparently they've been hacked in to. I wonder if that has anything to do with th current issues (even though it appears to have been going on for quite a long time now)? I just wish this would get fixed. I shouldn't need 3 browsers on one computer (and a new computer, at that).

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122
  • npsitesafety
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • Catalina Savings Printer
  • DivX Plus Web Player version 2.2.2.14
  • CouponNetwork Coupon Activator
  • Amazon MP3 Downloader Plugin 1.0.17
  • Coupons, Inc. Coupon Printer Plugin
  • DivX VOD Helper Plug-in
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • NPWLPG

Application

  • Firefox 20.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

Extensions

  • Coupon Savings 1.0 (hnjmnohghdqpqc@znrsgjnsjnzwwka.bd)
  • RealDownloader 1.3.1 ({DAC3F861-B30D-40dd-9166-F4E75327FAC7})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • AVG SafeGuard toolbar 14.2.0.1 (avg@toolbar) (Inactive)
  • DivX Plus Web Player HTML5 <video> 2.1.2.172 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0046
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'8.1500.1000.2202']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 2-20-2010
  • driverDate2:
  • driverVersion: 8.15.10.2086
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics)
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.dont_prompt_on_enter: True
  • browser.startup.homepage: http://new.ipfw.edu/|https://www.facebook.com/
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1367381761
  • places.history.expiration.transient_current_max_pages: 102076
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No

Helpful Reply

I've tried those I need another solution please.

Amit Kumar Thakur 83 solutions 863 answers

Recent crashes of certain multimedia contents (this includes Youtube videos, certain flash games and other applications) in conjunction with Firefox are most probably caused by a recent Flash 11.3 update and/or a malfunctioning Real Player browser plugin.

In order to remedy the problem, please perform the steps mentioned in these Knowledge Base articles:

Flash Plugin - Keep it up to date and troubleshoot problems

Adobe Flash plugin has crashed - Prevent it from happening again

Flash 11.3 doesn't load video in Firefox

Other, more technical information about these issues can be found under these Links:

http://forums.adobe.com/thread/1018071?tstart=0

http://blogs.adobe.com/asset/2012/06/inside-flash-player-protected-mode-for-firefox.html


Please tell us if this helped!

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

You can check for problems with current Flash plugin versions and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in Flash 11.3 and later
  • disable hardware acceleration in the Flash plugin

Question owner

You gave me some of the same links, which I said didn't help me. But I'll try the other suggestions.

p19581aaa 0 solutions 10 answers

The problems (for me) started with the latest Firefox update. I have done everything recommended at the Firefox website. My respect for Mozilla has fallen to the level of Microsoft.

Wesley Branton
  • Top 25 Contributor
178 solutions 2062 answers

Try disabling this plugin:
Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122


If the above doesn't work, try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • Open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Please report back soon.

p19581aaa 0 solutions 10 answers

huh? Can you point me somewhere to start looking for these things? thanks

jscher2000
  • Top 10 Contributor
2345 solutions 20793 answers

Hi p19581aaa, this is some standard guidance that addresses the most common issues with Flash in Firefox. I'm sure I'm repeating some of the above, but just in case:

(1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them.

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista/7/8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

p19581aaa 0 solutions 10 answers

Yesterday I changed from viewing Adobe pdfs in Firefox to using the actual pdf. Ever since then, the videos started streaming just fine. Perhaps you should pass this solution on to Firefox developers. They can't blame Adobe because videos stream just fine in I.E.

p19581aaa 0 solutions 10 answers

Scratch that. Now it's not working. I obviously don't know what the heck is going on... but somehow I don't think I should have to to use someone's product.

jscher2000
  • Top 10 Contributor
2345 solutions 20793 answers

Hi p19581aaa, what have you tried so far?

For what it's worth, Internet Explorer uses a different Flash Player: IE doesn't support the "Netscape style" plugins used by other browsers; it requires an ActiveX control.

p19581aaa 0 solutions 10 answers

Now it's working again (aaaagh!) I have only re-loaded/upgraded the Adobe product several times. Most of your instructions are Greek to me; ie. (1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them. How do I do that? I'm not a geek (nor do I want to be). I want a product that works. If Netscape style plug ins don't work on Firefox, why do they use them? Everything was fine until the recent upgrade by Firefox. They clearly released the upgrade before it was ready. I hope they're working on this and not expecting users to go through all the machinations listed in the above blog posts. The vast majority of people will not bother

Modified by p19581aaa

p19581aaa 0 solutions 10 answers

I get the message that Shockwave is disabled (which I have done to stop the problems that have been coming from it) and then the video starts to play! What in the world...???

jscher2000
  • Top 10 Contributor
2345 solutions 20793 answers

Hi p19581aaa, Netscape style plugins do work in Firefox, it's IE they don't work in.

The point of this -- "Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them." -- is that some people install add-ons or external software to download videos that play in the Flash player. If you haven't installed that kind of product, this step does not apply to you.

p19581aaa 0 solutions 10 answers

Under Firefox/Add-ons I see over a dozen add-ons, plug-ins, whatever they are called. One of those is Shockwave Flash. I'm under the impression Firefox and it are not compatible. Is that correct or is there another problem? I currently have it disable and sometimes videos and ads run and sometimes they don't.

jscher2000
  • Top 10 Contributor
2345 solutions 20793 answers

Hi p19581aaa, the Shockwave Flash plugin usually runs smoothly and without problems in Firefox. On some systems, it is necessary to disable certain features of the plugin (such as hardware acceleration and protected mode) as described in earlier in this thread, and some add-ons may conflict with Flash.

intr0uble 0 solutions 3 answers

The problem is not the Shockwave Flash plugin, is the Adobe Acrobat plugin, which isn't compatible to the latest version of Firefox. http://helpx.adobe.com/acrobat/kb/compatible-web-browsers-pdfmaker-applications.html Compatible only with: 3.6 4 and 5.0.1 (10.1 only) 6 (10.1.1 only), ESR 10.1.x and 11.0.x

It means we can either downgrade Firefox or install the ESR ((Extended Support Release) ) version of it: http://www.mozilla.org/en-US/firefox/organizations/all.html

jscher2000
  • Top 10 Contributor
2345 solutions 20793 answers

Hi intr0uble, I've never heard of the Adobe Acrobat plugin crashing. What operating system and version are you running, and do you have a paid version of Acrobat or the free Reader?

On Windows XP, 7, and 8, you can run Adobe X or XI versions, and the latest update works fine with the current version of Firefox. On Windows Vista, Adobe does not support the XI version, so you would use Acrobat/Reader X and the latest update of that works fine (but Mozilla's plugin checker will report you do not have the latest Adobe Acrobat plugin).

lynspottery 0 solutions 26 answers

I do not have realplayer installed, now what?