X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox won't load when using desktop/start menu icons but loads when starting off links in emails

Posted

When I try to start Firefox by the start menu, desktop or any other icon Firefox opens but then freezes and won't respond at all.

If I go to an email and then click on a link than Firefox will open and then load as normal and I can then go about using Firefox.

This has only be happening for the last few days and I have tried all the trouble shots and nothing has changed.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • Shockwave Flash 11.6 r602
  • McAfee MSC FF plugin DLL
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • McAfee MSS+ NPAPI Plugin
  • 5.1.20125.0
  • SiteAdvisor
  • NPWLPG

Application

  • Firefox 20.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

Extensions

  • Java Console 6.0.33 ({CAFEEFAC-0016-0000-0033-ABCDEFFEDCBA})
  • Java Console 6.0.35 ({CAFEEFAC-0016-0000-0035-ABCDEFFEDCBA})
  • Java Console 6.0.37 ({CAFEEFAC-0016-0000-0037-ABCDEFFEDCBA})
  • McAfee ScriptScan for Firefox 15.1.0 ({D19CA586-DD6C-4a0a-96F8-14644F340D60})
  • McAfee SiteAdvisor 3.6.0 ({4ED1F68A-5463-4931-9384-8FFF5ED91D92})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GT 330M
  • adapterDescription2:
  • adapterDeviceID: 0x0a29
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'257.21']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 4-27-2010
  • driverDate2:
  • driverVersion: 8.16.11.8986
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'182.65']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'182.65']
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.autostart: True
  • browser.startup.homepage: www.bigpond.com
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • browser.urlbar.autocomplete.enabled: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • keyword.URL: http://au.search.yahoo.com/search?fr=mcafee&p=
  • network.cookie.cookieBehavior: 0
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.clearOnShutdown.cookies: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_submit_insecure: False
  • security.warn_submit_insecure.show_once: False
  • security.warn_viewing_mixed: False
  • security.warn_viewing_mixed.show_once: False

Misc

  • User JS: Yes
  • Accessibility: No
finitarry 157 solutions 2175 answers

If you start Firefox in Firefox safe mode, does the problem still happen? It could be an extension causing the problem if there is no hanging in safe mode.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Looks that you are running Firefox in Private Browsing mode and that doesn't seem to be working.

If you click an external link then a normal window opens that works.


Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy > Cookies > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"

If you do not keep changes after a restart then see:

You can also check the command line in the desktop shortcut for the presence of the -private flag.

Modified by cor-el

Question owner

Hi, I have tried both of these responses to see if it helps but unfortunately there has been no change.

As I said it has only been in the last few days and I have even tried using the beta and Aurora versions of Firefox and it continues to happen with those as well.

If I leave the window that I open off the email link I can use the desktop/start menu icon to start a new windows but they will close as soon as I close the window started off the email link.

Modified by KypDurron

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

Question owner

Hi, just tried the above to see if that helped, even did a few uninstall/reinstall attempts even with beta/Aurora and still no changes ='[ I find it strange that it is only since the newer versions (last update really) that I have had issues with Firefox and I would have thought that I would have been able to use the Beta or Aurora versions??

finitarry 157 solutions 2175 answers

How did you get 2 Shockwave Flash plugins to be installed? You might want to remove the older one. Why do you have 3 different Java Console extensions installed? Maybe just keep the most recent one? Could your McAfee software be interfering with Firefox?

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

See also:

finitarry 157 solutions 2175 answers

I had forgotten about that. When I was using Windows XP with Firefox 3.6.*, with Java installed, I never had any Java console extensions appearing in the extensions list in Firefox. I had changed a few settings for java from the Control Panel, but I cannot now remember exactly which ones.

Question owner

Hi, I had a go with what was suggested above but unfortunately no change.

I have looked in the extensions listed in the add-on menu and there is only a Java deployment toolkit and a Java platform plug in but I can't see any Java console extensions listed in extensions. I try and look for one in the search bar but the one listed won't install and tells me there is a download error and that Java doesn't support Firefox anymore?

Also there is only one Shockwave plug in showing on the menu.

Modified by KypDurron

kstinn 0 solutions 1 answers

I Have this problem too. won't even start when dbl click the .exe file directly either. but a link in another app or email works fine. I have tried all the stuff here and uninstalled and reinstalled countless times. Using new profile, disabling Norton firewall and antivirus for the installs, only thing that worked was going back to v3.6. and a real early thunderbird too (it was also crashing on starting) Was fine for about three weeks then updated them, The went in stages not all at once and was fine till the newest group of versions. then went back to crashing. this time backgrading did not work. I installed the newest versions Firefox & Thunderbird many more times and by accident found that fresh after a install could open TB first and click a link in a email and FF started ok. but still will not start from desktop or windows explorer It is ridiculous to have to open another app to click on a link you don't want to get to where you do want. What is the difference in the links.

ks

also would not start in safe mode or a completely new install. V.17.0 is the FF thats installed now and at least works as long as I don't try to open it from desktop or windows explorer, more than a little nervous about going to v.20.

Modified by kstinn