X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox print garbage some arabic text.internet explorer print fine .i have windows xp with firefox 20.0.

Posted

Firefox print garbage some arabic text.internet explorer print fine .i have windows xp with firefox 20.0.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.68 Safari/537.22

More Information

iamjayakumars
  • Top 10 Contributor
416 solutions 4931 answers

Helpful Reply

Check in print preview...

Could you provide the link of that

cor-el
  • Top 10 Contributor
  • Moderator
10777 solutions 97000 answers

Is this on a normal web page or with displaying content like a PDF file?

Question owner

It is normal website page ... anything i print in arabic via firefox it not printing correctly , sum sentenses coming in one line .... thanks in advance ..

Question owner

@ iamjayakumars ... its normal Page i can print normal from internet Explorer ... failed to print from firefox .

Question owner

This is Example..

Question owner

Check Attached Page its in arabic but cant print Properly

iamjayakumars
  • Top 10 Contributor
416 solutions 4931 answers

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

cor-el
  • Top 10 Contributor
  • Moderator
10777 solutions 97000 answers

This can be a problem with the font that is used to display the text.

You can use this extension to see which fonts are used for text that is selected (right-click context menu: Show fonts in selection).

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"

Question owner

Tried Firefox Safe Mode . still issue not solved ...

Question owner

I uncheck ([ ] "Allow pages to choose their own fonts) this option but still problem not solved ...