Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

sync failure with "Unknown error" in bottom bar and "<h2>Client sent a bad request</h2>" in sync log

  • 2 replies
  • 7 have this problem
  • 412 views
  • Last reply by James

more options

For about two days all my devices have been failing to sync, with "Unknown error" in the bottom bar, and errors like this in the sync logs:

1366935522699	Sync.Tracker.History	DEBUG	Saving changed IDs to history
1366935524160	Sync.Collection	DEBUG	mesg: POST success 200 https://phx-sync500.services.mozilla.com/1.1/zackw/storage/history
1366935524160	Sync.Collection	DEBUG	POST success 200 https://phx-sync500.services.mozilla.com/1.1/zackw/storage/history
1366935524544	Sync.Engine.History	INFO	Uploading 100 - 200 out of 643 records
1366935524547	Sync.Collection	DEBUG	POST Length: 53358
1366935525789	Sync.Collection	DEBUG	mesg: POST success 200 https://phx-sync500.services.mozilla.com/1.1/zackw/storage/history
1366935525789	Sync.Collection	DEBUG	POST success 200 https://phx-sync500.services.mozilla.com/1.1/zackw/storage/history
1366935525981	Sync.Engine.History	INFO	Uploading 200 - 300 out of 643 records
1366935525985	Sync.Collection	DEBUG	POST Length: 48900
1366935527259	Sync.Collection	DEBUG	mesg: POST success 200 https://phx-sync500.services.mozilla.com/1.1/zackw/storage/history
1366935527259	Sync.Collection	DEBUG	POST success 200 https://phx-sync500.services.mozilla.com/1.1/zackw/storage/history
1366935527654	Sync.Engine.History	INFO	Uploading 300 - 400 out of 643 records
1366935527657	Sync.Collection	DEBUG	POST Length: 47409
1366935527786	Sync.Collection	DEBUG	mesg: POST fail 400 https://phx-sync500.services.mozilla.com/1.1/zackw/storage/history
1366935527786	Sync.Collection	DEBUG	POST fail 400 https://phx-sync500.services.mozilla.com/1.1/zackw/storage/history
1366935527786	Sync.Engine.History	DEBUG	Uploading records failed: <h2>Client sent a bad request.</h2>

1366935527795	Sync.Status	DEBUG	Status for engine history: error.engine.reason.record_upload_fail
1366935527795	Sync.Status	DEBUG	Status.service: success.status_ok => error.sync.failed_partial
1366935527795	Sync.ErrorHandler	DEBUG	history failed: <h2>Client sent a bad request.</h2>
 No traceback available
1366935527795	Sync.Synchronizer	INFO	Sync completed at 2013-04-25 20:18:47 after 14.18 secs.
1366935527795	Sync.SyncScheduler	DEBUG	Next sync in 600000 ms.
1366935527796	Sync.ErrorHandler	DEBUG	Some engines did not sync correctly.

Modified by cor-el

All Replies (2)

more options

You can check for problems with the places.sqlite database file in the Firefox profile folder.


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

more options

They are having sync server issues for the past few days.

https://services.mozilla.com/status/

https://twitter.com/mozservices
Mozilla Services ‏@mozservices 26m

Sorry folks, we're still experiencing some intermittent server/hardware issues with sync. We really do appreciate your patience!