X
Tap here to go to the mobile version of the site.

Support Forum

Shockwave Flash plugin can use nearly 100% of CPU to play video; MacBook gets hot & slows down.

Posted

MacBook Pro 8,2 with OS X 10.6.8 4GB RAM 2GH Core i7 Firefox 20.0 Shockwave Flash 11.7.700.169 Hardware acceleration enabled. Flash player plugin often starts at 40% to 60% of CPU but sometimes slowly builds up to where Activity Monitor is showing close to or even over 100% of CPU effort. Processors heat up and fans run at over 4,000 RPM. Video begins to drop frames and may eventually stop. Only solution (but not good) seems to be to either kill (force-quit) the Shockwave process or quit/reopen Firefox. I suspect there may be other things using the Shockwave process elsewhere on the web page and/or on other tabs that I can't find. (Running Shockwave player in Safari seems to use much less CPU effort. Even when I play two full HD videos at the same time, it only uses 60% to 80% of CPU in Safari.) Is there another video player that I can use in place of Shockwave Flash?

MacBook Pro 8,2 with OS X 10.6.8 4GB RAM 2GH Core i7 Firefox 20.0 Shockwave Flash 11.7.700.169 Hardware acceleration enabled. Flash player plugin often starts at 40% to 60% of CPU but sometimes slowly builds up to where Activity Monitor is showing close to or even over 100% of CPU effort. Processors heat up and fans run at over 4,000 RPM. Video begins to drop frames and may eventually stop. Only solution (but not good) seems to be to either kill (force-quit) the Shockwave process or quit/reopen Firefox. I suspect there may be other things using the Shockwave process elsewhere on the web page and/or on other tabs that I can't find. (Running Shockwave player in Safari seems to use much less CPU effort. Even when I play two full HD videos at the same time, it only uses 60% to 80% of CPU in Safari.) Is there another video player that I can use in place of Shockwave Flash?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 10.1.6
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • DivX VOD Helper Plug-in
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • iPhoto6
  • RealPlayer Plugin

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

iamjayakumars 475 solutions 5840 answers

Check your plugins are uptodated!

Remove the unwanted plugins

Check your plugins are uptodated! *https://www.mozilla.org/en-US/plugincheck/ Remove the unwanted plugins

Question owner

Thank you for the prompt reply and thanks for the suggestions, iam...

All of my plugins were already up to date, but I have disabled a couple which are not used.

A quick test for the problem shows it is still there, but seems improved. It will take some time to know for sure as I will have to try to recreate the same or similar conditions.

I think the best thing is to try to be sure there is only one Shockwave Flash process running at any time. Closing unneeded tabs/windows is probably the way to go.

P.S. I will soon be posting another question about a problem viewing video on the CNN.COM site.

Thank you for the prompt reply and thanks for the suggestions, iam... All of my plugins were already up to date, but I have disabled a couple which are not used. A quick test for the problem shows it is still there, but seems improved. It will take some time to know for sure as I will have to try to recreate the same or similar conditions. I think the best thing is to try to be sure there is only one Shockwave Flash process running at any time. Closing unneeded tabs/windows is probably the way to go. P.S. I will soon be posting another question about a problem viewing video on the CNN.COM site.
no1uno 0 solutions 10 answers

I have the same issue, it's an unpleasant experience. I'm continually having to go into 'add-ons' to disable the Shockwave Flash. It's now pissing me off to the point of having to consider an alternative browser.

The issue - huge processor cycles and overheating - occurs on websites displaying (unwanted) Flash ads. Is there a way of customising Firefox to prevent/disable these unwanted Flash ads? Or other remedies?

I have the same issue, it's an unpleasant experience. I'm continually having to go into 'add-ons' to disable the Shockwave Flash. It's now pissing me off to the point of having to consider an alternative browser. The issue - huge processor cycles and overheating - occurs on websites displaying (unwanted) Flash ads. Is there a way of customising Firefox to prevent/disable these unwanted Flash ads? Or other remedies?
shifuimam 2 solutions 20 answers

Get AdBlock+ to disable flash ads. It includes a handy utility called FlashBlock. When enabled, this turns any flash element on a page into a placeholder, and you have to click on it to enable flash for that element. That should help a lot with your overheating issues when browsing the Internet.

Get AdBlock+ to disable flash ads. It includes a handy utility called FlashBlock. When enabled, this turns any flash element on a page into a placeholder, and you have to click on it to enable flash for that element. That should help a lot with your overheating issues when browsing the Internet.
no1uno 0 solutions 10 answers

Thank you shifuimam. Have downloaded AdBlock+ and am looking forward to the benefits!

Thank you shifuimam. Have downloaded AdBlock+ and am looking forward to the benefits!