Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My scrollwheel isn't working on some pages, yet pages in other tabs scroll just fine. It's not a focus issue.

  • 3 replies
  • 4 have this problem
  • 919 views
  • Last reply by cor-el

more options

It's weird—for the past few days my Firefox has been very erratic in acknowledging the use of my scrollwheel. Some pages work just fine. Other pages refuse to scroll at all, or only scroll if I have my mouse cursor positioned in some (seemingly random) spot.

I experienced a similar problem when I had the buggy Facebook Messenger windows app installed, and killing that seemed to fix my troubles. Now, I can't place the blame on any background apps like that, and I've just restarted, and I haven't installed any new addons, either.

Thoughts? Thanks!

All Replies (3)

more options

If a plugin or other scrollable area has focus then you may not a able to scroll.

Can you post a link?


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.

In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • the default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • the default toolbar layout is used (localstore-safe.rdf)
  • the Javascript JIT compiler is disabled
  • hardware acceleration is disabled
  • plugins are not affected
  • preferences are not affected
more options

Must be an addon. One that's absolutely refusing to scroll is Gmail, and when I opened FF in safe mode, Gmail scrolled again. Back in regular mode, Gmail is not scrolling.

more options

If it works in Safe Mode or with all extensions (Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: "Firefox > Quit Firefox"; Linux: "Firefox/File > Quit")

Try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"