Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

How do I stop Firefox from signing me out of my ISP when I close it?

  • 18 replies
  • 1 has this problem
  • 448 views
  • Last reply by sfkessler

more options

Firefox signs me out of my ISP when I close it. I have tried resetting it and changing the "clear recent history" tool to not clear active logins.

All Replies (18)

more options

Websites remembering you and automatically log you on is stored in a cookie.

You need to keep the cookies as well, so maybe trey to add an allow exception and make sure not to clear the cookies via Clear Recent History or otherwise.

In case you are using "Clear history when Firefox closes":

  • do not clear Cookies
  • do not clear Site Preferences

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.

Clearing cookies will remove all specified (selected) cookies including cookies that have an allow exception and cookies from plugins.


You can inspect and manage the permissions for all domains on the about:permissions page.

Do not use Clear Recent History to clear the "Site Preferences" and the "Cookies" as this doesn't take exceptions into account, but removes all specified data.

more options

The clear history settings were correct. This happens only on my laptop and started with the last Firefox update, 20.0.1. My desktop works fine.

more options

If you right-click a page on the site > View Page Info > Permissions tab

Is Set Cookies set to Allow?

more options

Yes it is. I verified that I set the clear on exit variables to not clear cookies or active logins

Modified by sfkessler

more options

Are you clearing any data when you close Firefox?

more options

Yes. I have set it to clear Browsing, Download, Form& Search, and the cache.

more options

Does it have any effect if you do not use Clear Recent History and remove the check-mark?

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history": [] Clear history when Firefox closes
more options

No and now my desktop is doing the same thing

more options

Do you have security software (firewall, anti-virus) that may be blocking cookies?

Check the date and time in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

more options

Yes and I just added my ISP home page to the trusted list

more options

Does anyone else have this issue?

more options

Just to clarify, when you say your ISP, do you mean the Yahoo! site?

Yahoo seems to do some security checks that you can fail if your connection has changed in some manner since the cookie was set or last validated, and they require you to log in again. In the past, people have worked around this by changing their connection setting to No Proxy here:

orange Firefox button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button

If you use any kind of anonymizing software or service that might change the IP address you use to connect to Yahoo, this might also be a factor. (Note that Firefox's private browsing feature doesn't do that.)

Modified by jscher2000

more options

I changed the setting. I will watch it for a day before I will know if it solves the problem. The first time, it did work but I have had it work a single time before.

Thanks

more options

This seems to have worked on one computer but not the other. I will keep monitoring

more options

We are back to ground zero. It is signing me out on both computers. Could it be my ISP?

more options

It could be your ISP if your IP address changes frequently.

You might also check whether you run any external cleaning software that removes cookies (some security suites, privacy software, and cleaning utilities can do that).

more options

I am not running any external cleaning software on a daily basis so it may be the ISP

Thanks

more options

The problem cleared up for a while but came back after a firefox crash.

I have not heard anything for a month. The problem still exists even after the update to version 21.

Modified by sfkessler