X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox cache settings no longer working

Posted

Firefox cache settings that were working are no longer working, in Windows XP (x86) and Windows 7 (64).

By this I meant that I had set the cache to a ram-drive, but that is no longer being used, the cache is being written to disk instead in what is apparently the new default location, and my customized cache settings are ignored.

I've tried resetting Firefox to default and then re-applying them, but the problem still exists.

This is for FF 19+, but not sure when the problem first occurred - perhaps an earlier version too.

Is it no longer possible to re-direct the cache directory? How do you do it?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Google Update
  • 5.1.20125.0
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • PDF-XChange Viewer Netscape Gecko Plugin
  • DjVu browser plugin
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

Amit Kumar Thakur 83 solutions 863 answers

have you upgraded firefox and checked it. goto help->about firefox and update it.

Report us back . Thanks.

Helpful Reply

Yes I have upgraded Firefox - I suspect that was the cause of the problem.

I know it occurs in the most up to date version, 20, and also 19, but not sure when the problem first occurred as I've only just noticed it.

Amit Kumar Thakur 83 solutions 863 answers

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Question owner

I am using the default theme and the problem still exists in safe mode.

I have also just upgraded to the a new version 20.0.1, and the problem exists there too.

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96860 answers

Does the specified cache location exist (i.e. you can open the folder in Firefox via the location bar)?

What does the about:cache page show for the disk cache?

Question owner

Yes the cache location exists; the about:cache shows the offline cache directory is set to the default one for Windows, i.e. overriding my own settings.

I suspect it is to do with the multi-cache directory scheme used in FF these days.

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96860 answers

The browsing cache is not the "Offline cache device", but the "Disk cache device".

The latter will be missing if you use "Clear history when Firefox closes" to clear the cache because that will make Firefox use only the memory cache.

Question owner

Yes apparently I did have "Clear history when Firefox closes" set.

I've turned it off now and can see the correct settings in about:cache, and can also see the cache directories created where I expect them to be.

However I've noticed that icons in the jumpListCache and thumbnails are still being written to the default windows location. (As an aside, even though I had had clear history set, there were over 32,000 items in the jumpListCache directory).

Question owner

I suppose I could disable thumbnail capture as given here: https://support.mozilla.org/en-US/questions/941770?esab=a&s=profile+thumbnails&r=3&as=s

... not sure that I want to do that though. I may just live with it.

The jumpListCache issue is apparently a known bug: https://support.mozilla.org/en-US/questions/933376

Thanks to all who responded.

Helpful Reply

For jumpListCache , I found that setting browser.taskbar.lists.enabled to false prevents their capture:

http://forum.palemoon.org/viewtopic.php?f=13&t=1985&start=10

jimsrply 0 solutions 2 answers

Hi nuwon,

Just found your entry about preventing capture in the jumpListCache by toggling Browser.taskbar.lists YES it worked on my version 9.01 Are there any side effects ? How did you find it?

Thanks Jim.

Question owner

Hi Jim, I have not noticed any side effects. I found the info by searching the Palemoon forum as I use the Palemoon browser ( a spin-off of Firefox) for its 64-bit version on Windows.

nuwon

jimsrply 0 solutions 2 answers

I was wondering why there was a link to Palemoon forum. I've not heard about the Palemove browser, how long has it been around?

Thanks again in helping me remove more unwanted files from my SSD.

Cheers Jim