X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Synchronization Failed. Error is Firefox service initialization failed.

Posted

Synchronization Failed. Error is Firefox service initialization failed.

Synchronization Failed. Error is Firefox service initialization failed.
I have been having this issue for quite some time with Firefox. I am using the Nightly build (23.0a1) and have been using for more than 2 years. Synchronization was working fine till a few weeks ago. Synchronization of XMarks on Chrome Dev works fine and no problem. It's only with Firefox. Things I've tried but no success:

1) I deleted my profile off of xmarks and created a new one and tried syncing again. No success.
2) deleted firefox, deleted the profile folder under AppData. Reinstalled everything fresh, and still no success.

My log file shows the following... Not sure what to check. Anyone help me? Thanks!

[2013-04-06 08:54:19] Failed to initialize ["lmsvc", "@mozilla.org/browser/livemark-service;2", (void 0)]: error is ({})
[2013-04-06 08:54:19] Host browser is FF14+, use private DB
[2013-04-06 08:54:19] Created nid_map table
[2013-04-06 08:55:12] Starting modal auth(true, undefined)
[2013-04-06 08:55:19] Could not load login iframe: {}
[2013-04-06 08:55:31] Finished modal auth with result 0
[2013-04-06 08:55:31] Entered OnTransitionPageShow()
[2013-04-06 08:55:31] ------ Xmarks/4.1.3 (/Places) starting status with sync.xmarks.com ------
[2013-04-06 08:55:31] Failed to initialize ["lmsvc", "@mozilla.org/browser/livemark-service;2", (void 0)]: error is ({})
[2013-04-06 08:55:31] Host browser is FF14+, use private DB
[2013-04-06 08:55:31] Entered Status...
[2013-04-06 08:55:31] >>> POST http://sync.xmarks.com/sync/bookmarks...
[2013-04-06 08:55:31] >>> Body is: {}
[2013-04-06 08:55:32] >>> Callback ({username:"dmadapps", status:0, toprev:1, isreset:true})
[2013-04-06 08:55:32] Success: Account verified.
[2013-04-06 08:55:32] gCanSyncPasswords is true
[2013-04-06 08:55:32] ------ Xmarks/4.1.3 (/Places) starting getProfileNames with login.xmarks.com ------
[2013-04-06 08:55:32] >>> POST http://login.xmarks.com/user/profiles...
[2013-04-06 08:55:32] >>> Body is: {"log":{"mid":"hf6uh7gn","serp":0,"ssEnabled":false,"sbsEnabled":true}}
[2013-04-06 08:55:32] >>> Callback ({status:0, profiles:{}})
[2013-04-06 08:55:32] Success: Operation successful
[2013-04-06 08:55:32] Calling wizard.advance()
[2013-04-06 08:55:40] ------ Xmarks/4.1.3 (/Places) starting initial sync with sync.xmarks.com ------
[2013-04-06 08:55:40] Failed to initialize ["lmsvc", "@mozilla.org/browser/livemark-service;2", (void 0)]: error is ({})
[2013-04-06 08:55:40] Host browser is FF14+, use private DB
[2013-04-06 08:55:40] Entered Status...
[2013-04-06 08:55:40] >>> POST http://sync.xmarks.com/sync/bookmarks...
[2013-04-06 08:55:40] >>> Body is: {}
[2013-04-06 08:55:41] >>> Callback ({username:"dmadapps", status:0, toprev:1, isreset:true})
[2013-04-06 08:55:41] Returned error: Firefox service initialization failed(6)
[2013-04-06 08:55:41] Will retry at Sat Apr 06 2013 09:10:44 GMT-0500 (Central Standard Time)

Modified by cor-el

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Google Update
  • Picasa plugin
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Nitro PDF plugin for Firefox and Chrome
  • Torrent Stream Plug-in Version 2.0.8.1, Copyright (c) 2012 Innovative Digital Technologies
  • 5.1.20125.0
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • NPWLPG
  • Dragon NaturallySpeaking Rich Internet Application Support - Plugin
  • DivX VOD Helper Plug-in
  • The Hulu Desktop Plugin allows Hulu.com to integrate with the Hulu Desktop application.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130406 Firefox/23.0

More Information

patrickmc
  • Administrator
  • Moderator
23 solutions 174 answers

Helpful Reply

Hello dvargas2000,

I see you've also posted at the Xmarks page. Hopefully they can also offer some assistance.

In looking at some older threads for this issue on the Xmarks support site it suggested updating to the latest version of Xmarks. The download is listed below:

http://download.xmarks.com/download

Let me know if you still require assistance. Patrick

jfchandler 0 solutions 35 answers

I'm running the latest version of Xmarks, 4.1.3. And I just uninstalled and reinstalled the add-on in Firefox (Aurora 22.0a2), and still am getting the same error message as the OP post here. The problem for me began on April 6. Before that, never had any problem like this.

patrickmc
  • Administrator
  • Moderator
23 solutions 174 answers

Hello Jfchandler,

Can you give Xmarks a try on Beta and Release versions of Firefox to see if you're encountering the same issue?

There may have been something introduced in the Nightly/Aurora builds that is causing Xmarks to break. There are similar posts on the Xmarks dev site, so they should be aware and look into a fix for this issue.

Thanks, Patrick

Modified by patrickmc

cboerger 0 solutions 1 answers

Returned error: Firefox service initialization failed(6)

I see this with the Nightly and Stable releases from the Xmarks log.

jfchandler 0 solutions 35 answers

Helpful Reply

Re Patrick's suggestion above, I was able to get Xmarks working again on both my Win 7 laptop and desktop today by uninstalling my Aurora browser completely and then installing the regular release version of Firefox, 20.0.1.

When I uninstalled Aurora, it asked me if I wanted to keep my customizations and personal data, and even though it meant a bit more restoration work later, I decided to try erasing all my Aurora settings and data and starting fresh. (But before doing so, I backed up all my bookmarks by exporting to an html file and my add-on settings via Firefox Sync.

After that, I installed and started with a clean slate version of regular Firefox, and proceeded to then reinstall my various add-ons and import my saved bookmarks from the html file. As soon as I re-installed Xmarks and re-logged into my Xmarks account, the automatic syncing process went fine and no more error messages or failures.

I had been using Aurora for months prior with Xmarks and never had any syncing problem until the first week of April. And at that point, the syncing function broke on both my laptop and desktop, which were both running the daily updated versions of Aurora. So I'm believing that something was changed in Aurora that caused this problem.

retrovertigo 0 solutions 4 answers

Hi patrickmc,

I am having the same issue and my Sync fails as well "Can't connect to server". Not sure if both are using similat infrastucture? I can send you a postbin wth my Sync error log if that would help.

paulinfo 0 solutions 1 answers

Hi all I'm aslso getting sync error on xmarks. I have uninstall the xmarks ext thn redownload it but I'm still gettting the error


Paul