X
Tap here to go to the mobile version of the site.

Support Forum

How do I get rid of Ask.com as address bar search?

Posted

Hi - I need to use Firefox because an online course only works with it. However, I will never use it for anything else unless I can get rid of Ask.com as my default address bar search. I have been through the support files and have tried everything. There is no Ask toolbar. There is no chromewebapp.sqlite file or user.js file (may be wrong on spelling as I'm doing this from memory). I reset keyword.url and changed it to http://www.google.com/search?q=. I reset that other file (something about stone...again, I'm doing this from memory!). I reset Firefox. I completely uninstalled Firefox and reinstalled it.

I believe this is connected to Norton Safe Search. However, the Norton Toolbar is disabled and Safe Search is disabled. I did want to be able to use the Norton Toolbar and never had this problem with it in the past.

Can you help or should I just go back to using Chrome?

Hi - I need to use Firefox because an online course only works with it. However, I will never use it for anything else unless I can get rid of Ask.com as my default address bar search. I have been through the support files and have tried everything. There is no Ask toolbar. There is no chromewebapp.sqlite file or user.js file (may be wrong on spelling as I'm doing this from memory). I reset keyword.url and changed it to http://www.google.com/search?q=. I reset that other file (something about stone...again, I'm doing this from memory!). I reset Firefox. I completely uninstalled Firefox and reinstalled it. I believe this is connected to Norton Safe Search. However, the Norton Toolbar is disabled and Safe Search is disabled. I did want to be able to use the Norton Toolbar and never had this problem with it in the past. Can you help or should I just go back to using Chrome?

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.6 r602
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • Google Update
  • 5.1.20125.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • Amazon MP3 Downloader Plugin 1.0.17
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • Picasa plugin
  • NPWLPG
  • Musicnotes Viewer plugin 1.19.0 For more information visit www.musicnotes.com
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • np-mswmp

Application

  • Firefox 20.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Norton Toolbar 2012.5.12.5 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)
  • Norton Vulnerability Protection 11.3.0.9 - 4 ({BBDA0591-3099-440a-AA10-41764D9DB4DB}) (Inactive)
  • RealPlayer Browser Record Plugin 15.0.4 ({97E22097-9A2F-45b1-8DAF-36AD648C7EF4}) (Inactive)
  • Skype Click to Call 6.6.0.11664 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0116
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.1.7601.17789
  • driverDate: 3-25-2011
  • driverDate2:
  • driverVersion: 8.15.10.2342
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130326150557
  • browser.startup.homepage_override.mstone: 20.0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0
  • gfx.direct3d.prefer_10_1: True
  • keyword.URL: http://www.google.com/search?q=
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
7855 solutions 64043 answers

For address bar search issues, keyword.URL and disabling any bad extensions are the two key action items.

For keyword.URL:

  • Make sure keyword.enabled is true
  • To get the default secure Google search, you can right-click reset the keyword.URL preference and choose Reset, or run this add-on: SearchReset

If those haven't worked, could you check whether your connection is running through some kind of proxy?

You can check your proxy setting here:

(WIN) orange Firefox button (or Tools menu) > Options > Advanced
(MAC) Firefox > Preferences > Advanced
(LINUX) Edit > Preferences > Advanced

On the Network mini-tab, click the Settings button. Choose "No Proxy" and OK out. You might need to restart Firefox before this takes effect.

For address bar search issues, keyword.URL and disabling any bad extensions are the two key action items. For keyword.URL: * Make sure keyword.enabled is true * To get the default secure Google search, you can right-click reset the keyword.URL preference and choose Reset, or run this add-on: [https://addons.mozilla.org/en-US/firefox/addon/searchreset/ SearchReset] If those haven't worked, could you check whether your connection is running through some kind of proxy? You can check your proxy setting here: (WIN) orange Firefox button (or Tools menu) > Options > Advanced<br> (MAC) Firefox > Preferences > Advanced<br> (LINUX) Edit > Preferences > Advanced On the Network mini-tab, click the Settings button. Choose "No Proxy" and OK out. You might need to restart Firefox before this takes effect.

Question owner

Thank you for taking the time to answer my question. Unfortunately, Ask.com is still holding me hostage. I had tried the keyword.url fixes before. Changing the proxy setting did not work, either.

Thank you for taking the time to answer my question. Unfortunately, Ask.com is still holding me hostage. I had tried the keyword.url fixes before. Changing the proxy setting did not work, either.
jscher2000
  • Top 10 Contributor
7855 solutions 64043 answers

Did you try this? It's from Norton's support page:

Q. Can I disable or enable Norton Safe Search?

A. Yes. You can disable or enable Norton Safe Search manually via the Norton Toolbar menu. To disable or enable Norton Safe Search, click on the Norton logo on the Norton Toolbar and select disable/enable Norton Safe Search from the drop-down menu.

Q. Does disabling Norton Safe Search leave me open to online threats?

A.No. You get the full protection offered by Norton Safe Web regardless of whether or not you disable Norton Safe Search. If you do disable Norton Safe Search, Norton Safe Web (the client component) will continue to annotate searches on Google, Yahoo! or bing.com. Norton Safe Search utilizes the same site safety ratings as Norton Safe Web—it just provides a customized search experience.

Did you try this? It's from Norton's support page: '''Q'''. Can I disable or enable Norton Safe Search? '''A'''. Yes. You can disable or enable Norton Safe Search manually via the Norton Toolbar menu. To disable or enable Norton Safe Search, click on the Norton logo on the Norton Toolbar and select disable/enable Norton Safe Search from the drop-down menu. '''Q'''. Does disabling Norton Safe Search leave me open to online threats? '''A'''.No. You get the full protection offered by Norton Safe Web regardless of whether or not you disable Norton Safe Search. If you do disable Norton Safe Search, Norton Safe Web (the client component) will continue to annotate searches on Google, Yahoo! or bing.com. Norton Safe Search utilizes the same site safety ratings as Norton Safe Web—it just provides a customized search experience.

Question owner

Thank you again, but that was one of the first things I checked. I do not know how to completely eliminate the Norton Toolbar, however. Even a complete uninstall/reinstall of Firefox did not change that.

Thank you again, but that was one of the first things I checked. I do not know how to completely eliminate the Norton Toolbar, however. Even a complete uninstall/reinstall of Firefox did not change that.
moats 0 solutions 4 answers

Uninstalling/reinstalling firefox is not sufficient to wipe out profile configurations

for that you'll need to create a new profile:


create a fresh profile, make the settings changes desired, and compare to your current profile

http://kb.mozillazine.org/Category:Profiles

Assuming you use windows (I don't):

http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows


If the problem is not present in a fresh profile migrate your settings to the new profile.

If the problem persists you might have a nasty malware infection. Interweb search "free tech support", but I recommend BleepingComputer.com ;) having been a volunteer once upon a time. They'll help you remove whatever nasties they find in a methodical, easy to follow step by step format -- at zero cost to you (zero financial cost. Zero privacy commoditization which is what adware/web-ads do)

scan Aztec Code to register a new BleepingComputer account

Uninstalling/reinstalling firefox is not sufficient to wipe out profile configurations for that you'll need to create a new profile: create a fresh profile, make the settings changes desired, and compare to your current profile [http://kb.mozillazine.org/Category:Profiles http://kb.mozillazine.org/Category:Profiles] Assuming you use windows ([http://www.ubuntu.com/ubuntu/features I don't]): [http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows] If the problem is not present in a fresh profile migrate your settings to the new profile. If the problem persists you might have a nasty malware infection. Interweb search "free tech support", but I recommend [http://BleepingComputer.com BleepingComputer.com] ;) having been a volunteer once upon a time. They'll help you remove whatever nasties they find in a methodical, easy to follow step by step format -- at zero cost to you (zero financial cost. Zero privacy commoditization which is what adware/web-ads do) scan Aztec Code to register a new BleepingComputer account

Modified by moats

jscher2000
  • Top 10 Contributor
7855 solutions 64043 answers

Have you noticed any difference between single word and multi-word searches? For a single word, Firefox will try it as a domain, and your DNS provider can intercept that and return its own results page. For multiple words, if keyword.enabled=true, Firefox will send the query to the search provider specified by keyword.URL or, if that is blank, to Google.

If the problem only affects single word searches, the source of the problem is upstream, either in Windows or in your router, or at your ISP.

Have you noticed any difference between single word and multi-word searches? For a single word, Firefox will try it as a domain, and your DNS provider can intercept that and return its own results page. For multiple words, if keyword.enabled=true, Firefox will send the query to the search provider specified by keyword.URL or, if that is blank, to Google. If the problem only affects single word searches, the source of the problem is upstream, either in Windows or in your router, or at your ISP.
ambreesh 0 solutions 3 answers

You can try this:

Download Toolbar Cleaner (it's free) from http://toolbarcleaner.com/

Install it and CAREFULLY remove any Toolbar from browsers and delete entries in Windows startup profile.

I used Advance System Cleaner for cleaning of registry. I suggest you don't use/apply optimizations ASC offers.

You may uninstall both after the job is done.

You can try this: Download Toolbar Cleaner (it's free) from http://toolbarcleaner.com/ Install it and CAREFULLY remove any Toolbar from browsers and delete entries in Windows startup profile. I used Advance System Cleaner for cleaning of registry. I suggest you don't use/apply optimizations ASC offers. You may uninstall both after the job is done.

Modified by ambreesh

Question owner

Thanks, all, for the help. Toolbar Cleaner is nifty but had no effect. I'm not going to bother with a new profile.

It is only with single-word searches and I am not going to completely eliminate the Norton product from my computer, so it will have to stay as is.

Thanks, all, for the help. Toolbar Cleaner is nifty but had no effect. I'm not going to bother with a new profile. It is only with single-word searches and I am not going to completely eliminate the Norton product from my computer, so it will have to stay as is.
jscher2000
  • Top 10 Contributor
7855 solutions 64043 answers

If you find it to be unbearable in the future, two further thoughts:

  • Some ISPs will turn off the search results feature upon request (e.g., Optimum).
  • You could change your DNS servers to OpenDNS or Google DNS. These will return a normal 404 to Firefox so that Firefox can then try a keyword search.
If you find it to be unbearable in the future, two further thoughts: * Some ISPs will turn off the search results feature upon request (e.g., [http://www.optimum.net/dnsassist/optout Optimum]). * You could change your DNS servers to OpenDNS or Google DNS. These will return a normal 404 to Firefox so that Firefox can then try a keyword search.
EricFromAsk.com 1 solutions 21 answers

Hello fdrdfm - sorry to be seeing this a few days late, but I believe I can help. We've got a very simple removal utility which will clear this up for you, as well as simple steps to reset your Firefox default search provider. You'll find all of that in our Help Center:

http://help.ask.com/link/portal/30015/30018/Article/1/How-do-I-remove-the-Ask-com-Toolbar

If I can help with anything else, please feel free to get in touch with me via the Contact links in the Help Center.

Hello fdrdfm - sorry to be seeing this a few days late, but I believe I can help. We've got a very simple removal utility which will clear this up for you, as well as simple steps to reset your Firefox default search provider. You'll find all of that in our Help Center: http://help.ask.com/link/portal/30015/30018/Article/1/How-do-I-remove-the-Ask-com-Toolbar If I can help with anything else, please feel free to get in touch with me via the Contact links in the Help Center.
jscher2000
  • Top 10 Contributor
7855 solutions 64043 answers

Hi EricFromAsk.com, the original question says "There is no Ask toolbar."

The poster's problem is that instead of returning a 404 for a bad host name, the ISP is returning a page of Ask.com search results. Without changing DNS providers, it can be difficult to restore the intended behavior (divert 404 to a Google search).

Hi EricFromAsk.com, the original question says "There is no Ask toolbar." The poster's problem is that instead of returning a 404 for a bad host name, the ISP is returning a page of Ask.com search results. Without changing DNS providers, it can be difficult to restore the intended behavior (divert 404 to a Google search).
EricFromAsk.com 1 solutions 21 answers

It's not too likely an ISP is forcing any type of search provider; this is more likely a local browser setting in conjunction with Norton Safe Search, as mentioned in the original post. In that case, resetting Firefox's default search provider (as outlined in my article) will quickly and easily resolve it.

It's not too likely an ISP is forcing any type of search provider; this is more likely a local browser setting in conjunction with Norton Safe Search, as mentioned in the original post. In that case, resetting Firefox's default search provider (as outlined in my article) will quickly and easily resolve it.
cor-el
  • Top 10 Contributor
  • Moderator
16644 solutions 150411 answers

A good test for DNS hijacking by the ISP is to try different DNS servers.


Try to reset prefs on the about:config page that refer to ask.com.

  • Open the about:config page via the location bar and do a search for ask.com via the Search bar at the top of the about:config page.
  • Reset all ask.com related prefs that appear bold (user set) via the right-click context menu to their default values.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
A good test for DNS hijacking by the ISP is to try different DNS servers. *http://kb.mozillazine.org/Error_loading_websites#DNS ---- Try to reset prefs on the <b>about:config</b> page that refer to ask.com. *Open the <b>about:config</b> page via the location bar and do a search for <i>ask.com</i> via the Search bar at the top of the about:config page.<br /> *Reset all <i>ask.com</i> related prefs that appear bold (user set) via the right-click context menu to their default values. ---- Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
Digitaldiogenes 0 solutions 1 answers

Helpful Reply

I found this thread because I was having the same issue. What happened to me was Ask.com hijacked my Firefox during some kind of Java, or Flash update. I forgot to uncheck the box to make Ask my default search engine.

But I hate Ask.com. Everyone does. So I ignored it for a few weeks. Then I went about looking for the plugin to uninstall. There is no plugin.

The solution was laughably simple. In the search bar at the top right corner of the browser window, you will see the hated Ask logo. There is an arrow next to it that will drop down a menu of search engines. Pick your poison.

Because lets face it: Chrome is OK. But it's not Firefox. And Explorer just plain SUCKS.

I found this thread because I was having the same issue. What happened to me was Ask.com hijacked my Firefox during some kind of Java, or Flash update. I forgot to uncheck the box to make Ask my default search engine. But I hate Ask.com. Everyone does. So I ignored it for a few weeks. Then I went about looking for the plugin to uninstall. There is no plugin. The solution was laughably simple. In the search bar at the top right corner of the browser window, you will see the hated Ask logo. There is an arrow next to it that will drop down a menu of search engines. Pick your poison. Because lets face it: Chrome is OK. But it's not Firefox. And Explorer just plain SUCKS.
Cosma 0 solutions 1 answers

Hi, For anyone else out there that is still trying to get rid of the Ask bar: I use Mozilla, and, like digitaldiogenes, above, Ask hijacked Firefox during a Java update, though I was ultra-careful not to tick boxes, but there you go.

I tried the dropdown menu in the Ask searchbar to get my old search engine back; trouble was, it wasn't showing (I had Bing and Yahoo... but no Google). SO: there is a good tutorial on Youtube, right here, that takes you through what you need to do. http://www.youtube.com/watch?v=tSNe-n9MCEM

It was only after I'd followed these instructions to the letter that Google reappeared in the Ask searchbar dropdown menu, alongside Ask, Bing, Yahoo, Amazon (??). Once you have your engine back, you can then ask the Firefox search-engine manager to "remove" Ask - worked for me!

Good luck.

Hi, For anyone else out there that is still trying to get rid of the Ask bar: I use Mozilla, and, like digitaldiogenes, above, Ask hijacked Firefox during a Java update, though I was ultra-careful not to tick boxes, but there you go. I tried the dropdown menu in the Ask searchbar to get my old search engine back; trouble was, it wasn't showing (I had Bing and Yahoo... but no Google). SO: there is a good tutorial on Youtube, right here, that takes you through what you need to do. http://www.youtube.com/watch?v=tSNe-n9MCEM It was only after I'd followed these instructions to the letter that Google reappeared in the Ask searchbar dropdown menu, alongside Ask, Bing, Yahoo, Amazon (??). Once you have your engine back, you can then ask the Firefox search-engine manager to "remove" Ask - worked for me! Good luck.

Modified by Cosma

brigittaglg 0 solutions 1 answers

I tried everything but only one thing worked. I uninstalled Mozilla Firefox and installed it again. It was very quick and simple.

I tried everything but only one thing worked. I uninstalled Mozilla Firefox and installed it again. It was very quick and simple.
bobk57 0 solutions 3 answers

Dont' try anything that someone from ask.com says here in these forums. It won't work and will only make matters worse.

Dont' try anything that someone from ask.com says here in these forums. It won't work and will only make matters worse.
EricFromAsk.com 1 solutions 21 answers

Hi Bob - Fortunately, you're very wrong about that. I've personally helped a lot of people change browser settings and uninstall our toolbar. While millions of people use our search tools happily, we know they're not everyone's cup of tea.

As always, I'm available via the Ask Help Center if anyone would like to get in touch.

Hi Bob - Fortunately, you're very wrong about that. I've personally helped a lot of people change browser settings and uninstall our toolbar. While millions of people use our search tools happily, we know they're not everyone's cup of tea. As always, I'm available via the Ask [http://help.ask.com Help Center] if anyone would like to get in touch.
mad.creator 0 solutions 1 answers

So i was having the same problem, Ask tool bar would not uninstall. it was getting bothersome. so i went to uninstall programs, removed it there. Also went into extensions/addons and removed it there and still did not work. so i took advice from this site and clicked on the search icon in the upper right corner of the viewing screen, clicked "manage search engines". Now mozilla firefox is unresponsive, it does nothing. When you type something to search and hit enter, nothing happens, its unresponsive. -i would like to know why. never had any problems with ask but this seemed to be deeper than just a search engine. -i would like to get firefox up and running again, even a reinstall didnt have any effect.

So i was having the same problem, Ask tool bar would not uninstall. it was getting bothersome. so i went to uninstall programs, removed it there. Also went into extensions/addons and removed it there and still did not work. so i took advice from this site and clicked on the search icon in the upper right corner of the viewing screen, clicked "manage search engines". Now mozilla firefox is unresponsive, it does nothing. When you type something to search and hit enter, nothing happens, its unresponsive. -i would like to know why. never had any problems with ask but this seemed to be deeper than just a search engine. -i would like to get firefox up and running again, even a reinstall didnt have any effect.
schmingy 0 solutions 1 answers

Helpful Reply

fdrfdm,

i've had the same issue for some time, and only now realized how to fix it. i, too, have tried resetting the "keyword.URL", removing plug-ins, uninstalling, and re-installing, but if you're just looking to use Google as your default address bar search option, there seems to be a pretty simple quick fix.

1. in your firefox address bar, type "about:config" and hit enter. 2. on the page that loads, in the search field, type "keyword". 3. on the resulting hits, make sure the "keyword.enabled" is set to value "true". Otherwise, right click on it and select "Toggle". 4. right click "keyword.URL" and select "Modify". 5. enter value "https://www.google.com/#q=" and click OK.

that worked for me. hopefully, it works for you, too.

best, ori

fdrfdm, i've had the same issue for some time, and only now realized how to fix it. i, too, have tried resetting the "keyword.URL", removing plug-ins, uninstalling, and re-installing, but if you're just looking to use Google as your default address bar search option, there seems to be a pretty simple quick fix. 1. in your firefox address bar, type "about:config" and hit enter. 2. on the page that loads, in the search field, type "keyword". 3. on the resulting hits, make sure the "keyword.enabled" is set to value "true". Otherwise, right click on it and select "Toggle". 4. right click "keyword.URL" and select "Modify". 5. enter value "https://www.google.com/#q=" and click OK. that worked for me. hopefully, it works for you, too. best, ori