X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox consistently loads with "This is embarassing" message, but isn't crashing beforehand? How do i fix

Posted

My issue began yesterday and I can't seem to correct the problem. Every time I open firefox i'm met with the annoying restore message, (it's not usually annoying but because it happens every time I start firefox it's really starting to bother me) even if I close all my tabs before hand, close firefox and then quit the program entirely. I can understand this happening if say, I force quit when I had tabs open, but I'm not. And that too, was never an issue before.

I'm using Firefox 20.0 on my Mac, running 10.7.5 (Lion).

I've tried uninstalling/reinstalling firefox. I also deleted the sessionstore.bak and .js files. This fix worked initially, the first time I opened firefox, but hasn't worked subsequently.

Moreover, I'd rather not completely turn off the restore, if possible, because I may actually need to recover my data at some point.

I have three extensions on my browser: greasemonkey, tumblr savior and Adblock plus. I've had ABP on my browser since I bought my computer 2 years ago. Tumblr savior and greasemonkey I downloaded last night after this issue was already occuring.

Chosen solution

A possible cause can be that you are first closing all Firefox windows and then close the Firefox application.

Some have reported that closing Firefox (Firefox > Quit) while the browser window is still open works for them.

Read this answer in context 5

Additional System Details

Installed Plug-ins

  • Version 3.17.0.12440
  • Google Talk Plugin Video Accelerator version:0.1.44.24
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.4 r402

Application

  • Firefox 20.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0/Darwin/en-US/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Greasemonkey 1.8 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Tumblr Savior 0.4.5 (jid1-W5guVoyeUR0uBg@jetpack)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 126
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Intel Inc. -- Intel HD Graphics 3000 OpenGL Engine
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.dont_prompt_on_enter: True
  • browser.startup.homepage: about:home
  • browser.startup.homepage_override.buildID: 20130326150557
  • browser.startup.homepage_override.mstone: 20.0
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0
  • gfx.blacklist.webgl.msaa: 4
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1364735650
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash ID's to help us learn more about your crash.

  1. Enter about:crashes in the address bar (that's where you enter your website URL) and press Enter. You should now see a list of submitted crash reports.
  2. Copy the 5 most recent crash ID's that you see in the crash report window and paste them into your response here.

Thank you for your cooperation!

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

cor-el
  • Top 10 Contributor
  • Moderator
10759 solutions 96838 answers

Helpful Reply

Does it have any effect if you disable plugins as a test?

Did you try to quit the Firefox application with the tabs still open?


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

hello, this should be addressed in a later version of firefox. as a workaround in the meanwhile you could try this: enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named browser.sessionstore.resume_from_crash. double-click it and change its value to false.

cor-el
  • Top 10 Contributor
  • Moderator
10759 solutions 96838 answers

Chosen Solution

A possible cause can be that you are first closing all Firefox windows and then close the Firefox application.

Some have reported that closing Firefox (Firefox > Quit) while the browser window is still open works for them.