X
Tap here to go to the mobile version of the site.

Support Forum

URL fixup not working

Posted

I check the about:config and this option is enabled with appropriate prefix and suffix. let's just say everything is at default. however, when I type in "yahoo" , it gives me "http://yahoo/" instead of "www. yahoo.com"

this is a fresh new install FF19 on Android 4.2.2

I check the about:config and this option is enabled with appropriate prefix and suffix. let's just say everything is at default. however, when I type in "yahoo" , it gives me "http://yahoo/" instead of "www. yahoo.com" this is a fresh new install FF19 on Android 4.2.2

Chosen solution

A version 20 was just released. Could you test and see whether it works any better?

Note that the Quit item was removed from the menu in Android 4+: where did the Quit button go?

Read this answer in context 3

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Android; Mobile; rv:19.0) Gecko/19.0 Firefox/19.0

More Information

jscher2000
  • Top 10 Contributor
8637 solutions 70654 answers

If I enter yahoo, mine runs a Google search...

If I set keyword.enabled to false, then try yahoo, fixup works as expected.

In your about:config, do you have these (default values):

  • browser.fixup.alternate.prefix = www.
  • browser.fixup.alternate.suffix = .com

Edit: After posting, I noticed you said you do have those defaults.

Turning off the keyword service seriously reduces the usefulness of the awesome bar. There must be a way for these to coexist (as I think they do on the desktop version).

If I enter yahoo, mine runs a Google search... If I set keyword.enabled to false, then try yahoo, fixup works as expected. In your about:config, do you have these (default values): * browser.fixup.alternate.prefix = www. * browser.fixup.alternate.suffix = .com ''Edit: After posting, I noticed you said you do have those defaults.'' Turning off the keyword service seriously reduces the usefulness of the awesome bar. There must be a way for these to coexist (as I think they do on the desktop version).

Modified by jscher2000

Helpful Reply

yeah, I agree those features are very useful. But it doesn't seem like Android FF respects the settings at all. I turned off keyword.enabled, fixup still does not work. Or if I turned off fixup and enable keyword, still does not work. I keep getting the "http://yahoo/" url

yeah, I agree those features are very useful. But it doesn't seem like Android FF respects the settings at all. I turned off keyword.enabled, fixup still does not work. Or if I turned off fixup and enable keyword, still does not work. I keep getting the "http://yahoo/" url
jscher2000
  • Top 10 Contributor
8637 solutions 70654 answers

Chosen Solution

A version 20 was just released. Could you test and see whether it works any better?

Note that the Quit item was removed from the menu in Android 4+: where did the Quit button go?

A version 20 was just released. Could you test and see whether it works any better? Note that the Quit item was removed from the menu in Android 4+: [https://support.mozilla.org/en-US/questions/955185 where did the Quit button go?]

Question owner

thanks! the new version somehow fixed this :)

thanks! the new version somehow fixed this :)