X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Privacy settings constantly needed reset?

Posted

I have my Firefox setup to "never remember history" and "tell websites i do not want to be tracked," so when i close my browser it logs me out of email or anything else I'm logged into and clears everything. After some use when I exit the browser and come back later my email login will start to save when i do not want it to. I have tried several times to "reset Firefox" and it works temporarily but eventually reverts back to saving that information. I have also gone into the config page and set the security and privacy to level 2 (cannot find the link now on how I got that now).

Any other suggestions?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • 5.1.20125.0
  • Unity Player 4.0.0f7
  • iTunes Detector Plug-in
  • Yahoo Application State Plugin version 1.0.0.7
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

Andrew
  • Top 25 Contributor
  • Moderator
252 solutions 3020 answers

Helpful Reply

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

Please report back to see if this helped you!

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Helpful Reply

Do you have extensions or security software that deals with cookies?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

Feer56: Thank you for the suggestion and I will try that if all else fails.

Cor-el: I restarted in Safe Mode and in the Extensions Tab this is what was said: "you dont have any add-ons of this type installed"

In the appearance tab I was already on the default theme 19.0.2

I dont think I have any security software installed on my computer, I keep it pretty clean.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Can you clarify which privacy settings change and which prefs on the about:config page are affected?

Are that cookie settings? --- Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.


You can set the browser.sessionstore.privacy_level pref to 2 (never) or 1 (non-HTTPS) on the about:config page to disable saving cookies via session restore.

The browser.sessionstore.privacy_level_deferred pref is used when you do not reopen the previous session automatically via "Show my windows and tabs from last time" and uses the same values.

Question owner

Thanks for the help, it seems to under control for now, maybe the recent update helped as well?