X
Tap here to go to the mobile version of the site.

Support Forum

Ctrl+f is not working - FF 19.0.2

Posted

Hello. I had a look at similar topics, but couldn't find a solution. Apologies if this is a duplicate thread.

Basically, my problem is that Ctrl+f is not working in Firefox. The 'find' bar does not appear, and nothing at all happens. If I use Ctrl+g, the find bar appears. But it is still really bugging me that Ctrl+f wont work.

I am using Firefox 19.0.2 on Windows 7 - although this problem has persisted throughout the last few versions of FF. I have restarted FF in safe mode, but the same problem occurs. I have also renamed localstore.rdf in my profile folder (as I read that this might help diagnose the issue), but, again, the problem was the same.

Any suggestions are very welcome. Thanks in advance.

Hello. I had a look at similar topics, but couldn't find a solution. Apologies if this is a duplicate thread. Basically, my problem is that Ctrl+f is not working in Firefox. The 'find' bar does not appear, and nothing at all happens. If I use Ctrl+g, the find bar appears. But it is still really bugging me that Ctrl+f wont work. I am using Firefox 19.0.2 on Windows 7 - although this problem has persisted throughout the last few versions of FF. I have restarted FF in safe mode, but the same problem occurs. I have also renamed localstore.rdf in my profile folder (as I read that this might help diagnose the issue), but, again, the problem was the same. Any suggestions are very welcome. Thanks in advance.

Chosen solution

Thanks for the reply, John99.

I was thinking that safe mode disables plug-ins as well as extensions. Now that you informed me otherwise, I've fiddled around with my plug-ins, and getting rid of an out-of-date flash plug-in seems to have solved the issue!

Ctrl+f is working at the moment in any case. I will report back in due course to confirm whether the issue returns.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.448
  • Office Authorization plug-in for NPAPI browsers
  • np-mswmp

Application

  • Firefox 19.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0.2/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Autofill Forms 0.9.9.0 (autofillForms@blueimp.net)
  • British English Dictionary 1.19.1 (en-GB@dictionaries.addons.mozilla.org)
  • DownThemAll! 2.0.15 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Greasemonkey 1.8 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • gTranslate 0.9 ({aff87fa2-a58e-4edd-b852-0a20203c1e17})
  • Lazarus: Form Recovery 2.3 (lazarus@interclue.com)
  • NoScript 2.6.5.8 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Nuke Anything Enhanced 1.0.2 ({1ced4832-f06e-413f-aa14-9eb63ad40ace})
  • Places Maintenance 1.3 (places-maintenance@bonardo.net)
  • TinEye Reverse Image Search 1.1 (tineye@ideeinc.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • ColorZilla 2.8.1 ({6AC85730-7D0F-4de0-B3FA-21142DD85326}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0102
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.1.7601.17789
  • driverDate: 3-25-2011
  • driverDate2:
  • driverVersion: 8.15.10.2342
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 911360
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: http://www.bangor.ac.uk/
  • browser.startup.homepage_override.buildID: 20130307023931
  • browser.startup.homepage_override.mstone: 19.0.2
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0.2
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1364510180
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
John99
  • Top 25 Contributor
  • Moderator
695 solutions 9602 answers

Possibly some plugin is interfering with this. Safe mode disables extensions but not plugins.

I note from your system information aside you have the preference

Not sure why Ctrl + G gives you the findbar, but maybe it is because of some plugin that has use of the Ctrl+ F keyboard combination, or the Find is already active.

I will have to try changing the prefs myself, but I am having a break after posting this.It could just be because the find as you type is active.

Possibly some plugin is interfering with this. Safe mode disables extensions but not plugins. I note from your system information aside you have the preference * ''accessibility.typeaheadfind.flashBar: 0 '' * see http://kb.mozillazine.org/Accessibility.typeaheadfind.flashBar ** and http://kb.mozillazine.org/Accessibility.typeaheadfind Not sure why Ctrl + G gives you the findbar, but maybe it is because of some plugin that has use of the Ctrl+ F keyboard combination, or the Find is already active. * see [[Keyboard shortcuts - Perform common Firefox tasks quickly]]<br/> Ctrl+G is normally find again. I will have to try changing the prefs myself, but I am having a break after posting this.It could just be because the find as you type is active.
John99
  • Top 25 Contributor
  • Moderator
695 solutions 9602 answers

I jumped on accessibility.typeaheadfind.flashBar: 0 as a changed preference, but in fact that actually seems standard even in a clean profile so it seems that is a red herring.

I jumped on ''accessibility.typeaheadfind.flashBar: 0 '' as a changed preference, but in fact that actually seems standard even in a clean profile so it seems that is a red herring.

Chosen Solution

Thanks for the reply, John99.

I was thinking that safe mode disables plug-ins as well as extensions. Now that you informed me otherwise, I've fiddled around with my plug-ins, and getting rid of an out-of-date flash plug-in seems to have solved the issue!

Ctrl+f is working at the moment in any case. I will report back in due course to confirm whether the issue returns.

Thanks for the reply, John99. I was thinking that safe mode disables plug-ins as well as extensions. Now that you informed me otherwise, I've fiddled around with my plug-ins, and getting rid of an out-of-date flash plug-in seems to have solved the issue! Ctrl+f is working at the moment in any case. I will report back in due course to confirm whether the issue returns.
John99
  • Top 25 Contributor
  • Moderator
695 solutions 9602 answers

Glad to here hear! that.
Looking again it could have been Java that was old. Java is something that should be left disabled unless it is specifically required. It does not have a good record for security.

Glad to <s>here</s> hear! that. <br /> Looking again it could have been Java that was old. Java is something that should be left disabled unless it is specifically required. It does not have a good record for security.

Modified by John99

Helpful Reply

Hi again John. Thanks for the additional input.

Re. keeping java disabled: what's the best way to quickly disable and enable java as needed? Would I need to open the 'add-ons manager' each time, or would something like the 'NoScript' extension achieve this?

Hi again John. Thanks for the additional input. Re. keeping java disabled: what's the best way to quickly disable and enable java as needed? Would I need to open the 'add-ons manager' each time, or would something like the 'NoScript' extension achieve this?
John99
  • Top 25 Contributor
  • Moderator
695 solutions 9602 answers

Helpful Reply

You could use NoScript but the problem may be with reliably setting it up to do what you want.

I believe NoScript by default blocks Java, FlashPlayer and javascript, but then if you trust a site (Because you wish to have javascript, or even Flash enabled) would the default then be to allow all three.

Ordinarily Java is the one out of those three that is probably going to be least often needed, and the biggest security risk. I do not know what you do with Firefox but quite possibly you have only one or two tasks that need Java. (Javascript is the one commonly required)

You could use ''NoScript'' but the problem may be with reliably setting it up to do what you want. I believe NoScript by default blocks Java, FlashPlayer and javascript, but then if you ''trust'' a site (Because you wish to have javascript, or even Flash enabled) would the default then be to allow all three. Ordinarily Java is the one out of those three that is probably going to be least often needed, and the biggest security risk. I do not know what you do with Firefox but quite possibly you have only one or two tasks that need Java. (Javascript is the one commonly required)

Question owner

Hi again, John.

Yes, I think that's correct - NoScript has no easy way to allow flash without allowing java (for instance).

In any case, I have disabled the java plug-in altogether for the time being, and I'll see how I get on with that.

The original ctrl+f problem seems to be resolved, though I'm paranoid it will return.

Thanks again for the help.

Hi again, John. Yes, I think that's correct - NoScript has no easy way to allow flash without allowing java (for instance). In any case, I have disabled the java plug-in altogether for the time being, and I'll see how I get on with that. The original ctrl+f problem seems to be resolved, though I'm paranoid it will return. Thanks again for the help.
John99
  • Top 25 Contributor
  • Moderator
695 solutions 9602 answers

Glad to have helped.

Glad to have helped.

Question owner

Bad news: I'm afraid the ctrl+f problem has returned!

I've just tried disabling all add-ons and restarting in safe mode, but the find bar still wont come up with ctrl+f.

And I really thought we'd found the solution! :(

It's just occurred to me to check the ctrl+f functionality in another program. I tried it in MS Word 2010, and it's not working there either. So, I guess this is probably not a Firefox problem. There must be something on my system interfering with the keyboard shortcut.

Bad news: I'm afraid the ctrl+f problem has returned! I've just tried disabling all add-ons and restarting in safe mode, but the find bar still wont come up with ctrl+f. And I really thought we'd found the solution! :( It's just occurred to me to check the ctrl+f functionality in another program. I tried it in MS Word 2010, and it's not working there either. So, I guess this is probably not a Firefox problem. There must be something on my system interfering with the keyboard shortcut.
cor-el
  • Top 10 Contributor
  • Moderator
12382 solutions 114474 answers

It is possible that some of the status keys have the wrong state and Firefox sees them as still pressed.

Try to press all the status keys (Shift, Ctrl, Alt) a few times to see if that helps to recover from this.

It is possible that some of the status keys have the wrong state and Firefox sees them as still pressed. Try to press all the status keys (Shift, Ctrl, Alt) a few times to see if that helps to recover from this.