X
Tap here to go to the mobile version of the site.

Support Forum

Google search results redirect

Posted

when i perform an internet search using the firefox homepage or the search field in the upper right corner it used to give me results by google, now it is "http://www1.search-results.com/blahblahblah" i have reset the home page several times and i have been unable to find any other possible routes through menu options. i have also used IOBit advanced system care and IOBit malware fighter to scan for malware with no change either. i can, however, manually go to google.com and it will work from there but it seems like some rotten cookie or something that i can't identify has taken control over what firefox does.

when i perform an internet search using the firefox homepage or the search field in the upper right corner it used to give me results by google, now it is "http://www1.search-results.com/blahblahblah" i have reset the home page several times and i have been unable to find any other possible routes through menu options. i have also used IOBit advanced system care and IOBit malware fighter to scan for malware with no change either. i can, however, manually go to google.com and it will work from there but it seems like some rotten cookie or something that i can't identify has taken control over what firefox does.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
3016 solutions 13982 answers

Helpful Reply

hello, please install the search reset addon - it will revert the most common customizations those adware programs do in firefox back to the default: https://addons.mozilla.org/firefox/addon/searchreset/

hello, please install the search reset addon - it will revert the most common customizations those adware programs do in firefox back to the default: https://addons.mozilla.org/firefox/addon/searchreset/
cor-el
  • Top 10 Contributor
  • Moderator
12526 solutions 115508 answers

If you do not keep changes after a restart then see:

Do a malware check with some malware scanning programs on the Windows computer.
Please scan with all programs because each program detects different malware.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

If you do not keep changes after a restart then see: *http://kb.mozillazine.org/Preferences_not_saved Do a malware check with some malware scanning programs on the Windows computer.<br /> Please scan with all programs because each program detects different malware. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender: Home Page:<br>http://www.microsoft.com/windows/products/winfamily/defender/default.mspx *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *http://support.kaspersky.com/viruses/solutions?qid=208280684 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked
Giedrius_M 15 solutions 158 answers

Helpful Reply

This is likely due to some browser-settings protecting software, sometimes completely legitimate. First things first, go to control panel and uninstall ALL software that got installed around the same date search got hijacked. Reboot. Then you can either Reset Firefox preferences to troubleshoot and fix problems Or Do it manually without loosing other settings : Enter “about:config” in url bar. This will open settings page Type “Keyword.url” in the search box. Right click it & reset it. Type “browser.search.defaultengine” in the search box. Right click it & reset it. Type “browser.search.selectedengine” in the search box. Right click it & reset it. Search for ‘browser.newtab.url’. Right-click and reset. This will make sure that the search page won’t launch on each new tab.

For other browsers, which might be affected, instructions here

This is likely due to some browser-settings protecting software, sometimes completely legitimate. First things first, go to control panel and uninstall ALL software that got installed around the same date search got hijacked. Reboot. Then you can either [[Reset Firefox preferences to troubleshoot and fix problems]] Or Do it manually without loosing other settings : Enter “about:config” in url bar. This will open settings page Type “Keyword.url” in the search box. Right click it & reset it. Type “browser.search.defaultengine” in the search box. Right click it & reset it. Type “browser.search.selectedengine” in the search box. Right click it & reset it. Search for ‘browser.newtab.url’. Right-click and reset. This will make sure that the search page won’t launch on each new tab. For other browsers, which might be affected, [http://www.majauskas.com/how-to-manage-browser-search-providers instructions here]

Question owner

this worked. TYVM!!  :D that is the search reset app thingy. THAT worked

this worked. TYVM!! :D that is the search reset app thingy. THAT worked

Modified by Booger