X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox redirects me to webiq-cdn.appspot.com when I try to connect to support.oracle.com. Oracle says it's a Firefox issue.

Posted

My connection to support.oracle.com will not complete because I'm being redirected to webiq-cdn.appspot.com. I'm at a government site and webiq-cdn.appspot.com is blocked. I can connect to support.oracle.com with IE. I opened a support case with Oracle and they think it's a Firefox issue. This occurs with Firefox 19.0 on Windows and Firefox 19.0.2 on Solaris. I've cleared the cache and all cookies, but that did not help. I've searched on Google for anyone having the same problem, but I haven't found anything. I've looked on the mozilla troubleshooting site and haven't found anything that helps.

Chosen solution

Oracle's support site does pull scripts from those servers, but ordinarily this happens quietly in the background. If the script is blocked both for IE and for Firefox, the difference in behavior is curious. Maybe Firefox is allowing a much longer timeout, or doesn't understand the block the same way.

Are you allowed to install extensions? You could use the NoScript extension to permit the Oracle scripts but block the appspot scripts. Using NoScript involves something of a commitment, however, because by default no site is allowed to run scripts and you find yourself having to approve a lot of servers during your first few days of use. If you know you won't need it for a while, you can simply allow everything until you need to use Oracle support again.

https://addons.mozilla.org/en-US/firefox/addon/noscript/

If you can't use the extension or prefer another method, perhaps you can use the Windows hosts file to redirect the domain to localhost as a workaround.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • Adobe Shockwave for Director Netscape plug-in, version 12.0
  • 5.1.20125.0
  • Next Generation Java Plug-in 1.6.0_37 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • ActiveTouch General Plugin Container Version 105
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Citrix ICA Client Plugin (Win32)
  • np-mswmp
  • Office Plugin for Netscape Navigator

Application

  • Firefox 19.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • IDS_SS_NAME IDS_SS_VERSION ({D19CA586-DD6C-4a0a-96F8-14644F340D60}) (Inactive)
  • Java Console 6.0.34 ({CAFEEFAC-0016-0000-0034-ABCDEFFEDCBA}) (Inactive)
  • Java Console 6.0.35 ({CAFEEFAC-0016-0000-0035-ABCDEFFEDCBA}) (Inactive)
  • Java Console 6.0.37 ({CAFEEFAC-0016-0000-0037-ABCDEFFEDCBA}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA NVS 3100M
  • adapterDescription2:
  • adapterDeviceID: 0x0a6c
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.1.7601.17789
  • driverDate: 7-31-2010
  • driverDate2:
  • driverVersion: 8.17.12.5922
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA NVS 3100M)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130215130331
  • browser.startup.homepage_override.mstone: 19.0
  • extensions.lastAppVersion: 19.0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf,application/doc,application/xls,application/bat,application/ppt,application/mdb,application/mde,application/fdf,application/xfdf,application/lsl,application/lso,application/lss,application/iqy,application/rqy,application/xlk,application/pot,application/pps,application/dot,application/wbk,application/ps,application/eps,application/wch,application/wcm,application/wbi,application/wb1,application/wb3,application/rtf,application/wch,application/wcm,application/ad,application/adp
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.history: False
  • privacy.cpd.cookies: False
  • privacy.cpd.history: False
  • privacy.item.history: False
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
2365 solutions 20932 answers

Chosen Solution

Oracle's support site does pull scripts from those servers, but ordinarily this happens quietly in the background. If the script is blocked both for IE and for Firefox, the difference in behavior is curious. Maybe Firefox is allowing a much longer timeout, or doesn't understand the block the same way.

Are you allowed to install extensions? You could use the NoScript extension to permit the Oracle scripts but block the appspot scripts. Using NoScript involves something of a commitment, however, because by default no site is allowed to run scripts and you find yourself having to approve a lot of servers during your first few days of use. If you know you won't need it for a while, you can simply allow everything until you need to use Oracle support again.

https://addons.mozilla.org/en-US/firefox/addon/noscript/

If you can't use the extension or prefer another method, perhaps you can use the Windows hosts file to redirect the domain to localhost as a workaround.

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Hello pedrolevine, try to reload the webpage while bypassing the cache using one of the following steps:

  • Hold down the Shift key and click the Reload button with a left click.

OR

  • Press Ctrl + F5 or Ctrl + Shift + R (Windows and Linux)
  • Press Command + Shift + R (Mac)

Let us know if this solves the issues you are having.


thank you

Helpful Reply

Thanks to both of you for the quick replies.

Ideato -- Because the page never fully loads, the Reload button never appears. If I stop the site from continuing to try to load, only then does the Reload button appear. At that point, Shift + Reload produces this:

Error 403--Forbidden From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1: 10.4.4 403 Forbidden The server understood the request, but is refusing to fulfill it. Authorization will not help and the request SHOULD NOT be repeated. If the request method was not HEAD and the server wishes to make public why the request has not been fulfilled, it SHOULD describe the reason for the refusal in the entity. This status code is commonly used when the server does not wish to reveal exactly why the request has been refused, or when no other response is applicable.

The other key combos did not do anything.

jscher2000 -- I'm sure you're correct about Firefox allowing a much longer timeout than IE. If I leave the Oracle site alone and come back hours later, it is still trying to load. Is there a way that I can tell Firefox to time out sooner?

I'll check out the NoScript extension.

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96852 answers

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Helpful Reply

cor-el -- I rebooted a Windows box into Safe Mode, but that did not change the redirect to webiq.

Question owner

jscher2000 -- I tried NoScript and it did the job. It blocked the connection to webiq (or whatever webiq was trying to do) and allowed me to go through to the Oracle support site and see my Service Requests. Thanks for the advice!

Question owner

cor-el -- I tried booting a Windows box into Safe Mode, but that did not change the behavior when going to support.oracle.com.

jscher2000 -- I installed NoScript and that did the job! It blocks webiq (or whatever it was trying to do) and allows me to go through to the support site and see my service requests. Thanks for the advice!