X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

FF20 cannot read some unicodes

Posted

For example this website: https://www.feedsapi.org/index.php

Screenshot: http://take.ms/84IWc

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.6 r602
  • Microsoft Office for Mac SharePoint Browser Plug-in

Application

  • Firefox 20.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0/Darwin/en-US/

Extensions

  • 1Password 3.9.9 (onepassword@agilebits.com)
  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • BetterSearch 5.2 ({2bfc8624-5b8a-4060-b86a-e78ccbc38509})
  • Element Hiding Helper for Adblock Plus 1.2.3 (elemhidehelper@adblockplus.org)
  • feedly 10.2 (feedly@devhd)
  • Firebug 1.11.2 (firebug@software.joehewitt.com)
  • InstantFox 2.7.9 (searchy@searchy)
  • Pocket 3.0.1 (isreaditlater@ideashower.com)
  • Spamavert.com 1.2 ({8e9008b4-ec7c-4c2a-828e-007d5d2dad22})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Wiktionary and Google Translate 6.0 (googledictionary@toptip.ca)
  • Add-on Builder Helper 1.5 (jid0-t3eeRQgGANLCH9c50lPqcTDuNng@jetpack) (Inactive)
  • Add-on Compatibility Reporter 2.0 (compatibility@addons.mozilla.org) (Inactive)
  • ColorZilla 2.8.1 ({6AC85730-7D0F-4de0-B3FA-21142DD85326}) (Inactive)
  • Download Statusbar 0.9.10 ({D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}) (Inactive)
  • MeasureIt 0.4.10 ({75CEEE46-9B64-46f8-94BF-54012DE155F0}) (Inactive)
  • Test Pilot 1.2.2 (testpilot@labs.mozilla.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 126
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Intel Inc. -- Intel HD Graphics 3000 OpenGL Engine
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.autostart: False
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.enabled: False
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 1048576
  • browser.link.open_newwindow.restriction: 0
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.restore_on_demand: False
  • browser.startup.homepage_override.buildID: 20130313170052
  • browser.startup.homepage_override.mstone: 20.0
  • dom.mozApps.runUpdate: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0
  • font.internaluseonly.changed: True
  • gfx.blacklist.webgl.msaa: 4
  • keyword.URL: http://www.google.com/search?ie=UTF-8&oe=UTF-8&rls=org.mozilla:en-US:official&client=firefox-a&sourceid=navclient&gfns=1&q=
  • layers.acceleration.disabled: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1363687151
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.downloads: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
iamjayakumars
  • Top 10 Contributor
416 solutions 4930 answers

Sorry the webiste and screenshot not working.

You can check the order of the installed Languages.

  • Firefox > Preferences > Content > Languages


Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:


  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Does the font work on this page?

You can check the gfx.downloadable_fonts.enabled pref on the about:config page.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

clearing cache and cookies didn't help :(

Question owner

i can see all the font fine on the fontawesome page. I also checked the setting in the about:config. It's enabled.

It still didn't work with safe mode

Modified by iibpmii

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

The two sites use different locations for the CSS file that loads the font, so make sure that the file isn't blocked.

You can check the Net log in the "Web Developer > Web Console" (Ctrl+Shift+K) to see if the font-awesome.css file is loaded and the fontawesome-webfont.woff file as well.
You need to do a hard refresh (Ctrl+F5 or Ctrl+Shift+R) to bypass the cache.

See also:


Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

Question owner

Thanks for your reply.

Here is the error I got from the Web Console while the page is loading:

[17:36:40.746] downloadable font: download failed (font-family: "FontAwesome" style:normal weight:normal stretch:normal src index:1): bad URI or cross-site access not allowed source: https://commondatastorage.googleapis.com/feedsapivps/assets/css/font/fontawesome-webfont.woff @ https://commondatastorage.googleapis.com/feedsapivps/assets/css/font-awesome.css

So I guess that is why? But isn't it weird that I can see those icons fine on Chrome?

Modified by iibpmii

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

That is weird. I do not see anything in the HTTP response headers that would cause this.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.