X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Cannot access Delta airlines site on firefox. I can on internet explorer. I would rather use firefox.

Posted

I cannot access my Delta Airlines account with or without logging in. It always goes to "Choose a language and country" and it never accepts my choice. The page just freezes up. I can access this site on internet explorer but Firefox is my default browser. Any ideas why this is happening?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • iTunes Detector Plug-in
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Garmin Communicator Plug-In 4.0.4.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • VLC media player Web Plugin 2.0.0-rc
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634
  • 5.0.61118.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

Then try reloading the page. Does that help?