X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Drop down menus on certain websites (ie ESPN) are no longer working on Firefox but work with both Chrome and IE on same computer so I believe its Firefox issue.

Posted

I tried updating Firefox to 19 and then even the Beta 20 version. I have rebooted computer countless times. On the same computer, I can open IE and bring up ESPN and the drop down menus work fine so I know its not a computer issue and it must have something to do Firefox. I tried the "starting in safe mode" and disabling add ons because I saw those suggestions but that didnt work. I also tried unchecking the box about hardware acceleration because I saw that suggested also and needless to say that didnt work either. Can someone please please help me, its very frustrating.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • GEPlugin
  • Adobe Shockwave for Director Netscape plug-in, version 12.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • Google Update
  • 5.1.20125.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • LiveVDO plug-in
  • Best Buy pc app Detector Plug-in
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Virtual Earth 3D 4.00090316005 plugin for Mozilla
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96775 answers

The menu on the ESPN site is generated via JavaScript, so make sure that you aren't blocking JavaScript if the menus aren't working.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"
mhaugerud 0 solutions 2 answers

I am having this exact problem with Firefox 19 on a Windows 8 machine. I did not have the problem with Firefox on a Mac OS X machine.

I have tried all of the above suggestions, with no luck.

Also, I was having this problem in Chrome, but that was fixed from a touch option in the Chrome advanced about options. (I do not have a touch system - it was just a solution I found)

mhaugerud 0 solutions 2 answers

So, my issue is now fixed... I had a 120GB SSD that was almost out of space, and I upgraded to a 256GB SSD today; my issue with Firefox is now gone. Not sure what the issue was, but it is now gone with a HD hardware upgrade.