Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won't automatically open tabs from my previous session.

  • 12 replies
  • 29 have this problem
  • 9509 views
  • Last reply by totalkaos

more options

I have literally tried everything, from the general option menu to directly using about:config to fix this problem. It happens all the damn time, and after dicking with it, I can usually fix it, but this time, I cannot get firefox to restore tabs from my previous session. I have it set to restore my previous session in the general options menu, it warns me when I close multiple tabs, private browsing is disabled. I don't know what else to do. I've scoured this site and tried every solution I could find, but none of them are working. Firefox had frozen, so I had to ctrl/alt/del to close it, and when I restarted it, my session was gone forever. I've done this before and it's never dicked with the settings. I realize that there's a 'restore previous session' option in the history, but I want it to load automatically. It's getting really bothersome with the amount of times firefox has done this.

All Replies (12)

more options

Hello Otta, probably the problem is the sessionstore.js and sessionstore.bak files. Delete the sessionstore.js file and if exist sessionstore-##.js files with a number(sessionstore-1.js etc) and the sessionstore.bak in the Firefox Profile Folder.

if the above did not help, check it in Safe Mode, in Safe Mode window select "Start in Safe Mode" and see if this happen again, if not then see: Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

(If the problem does not happen in Safe Mode, it is most likely because of an extension or a theme in the current issue).


thank you

more options

Ok that is way to technical, how the heck to we find the firefox profile and find these files to delet? You state it as though we would have any idea where to look for those files? I'm going back to Safari if Firefox doesn't fix this, all of my work is gone 3 times so fare because the "restore previous session" is greyed out.

more options

Yep, the option to do so is greyed out as of about 1 week ago, I think it happened when I tried to use firefox sync but I really don't know, so irritating, gonna get rid of firefox

more options

I had the very same problem with Firefox 21.0 (on Mac). Neither deleting sessionstore.js etc, Safe Mode nor various settings suggested in other threads helped.

However, I found a "workaround" that does the trick for me (unless I forget about it and fall back into old habits :/ Old dogs, new tricks and such ;) )

Do NOT close the Firefox window by clicking on (x). Instead go to "Firefox"->"Quit Firefox" (pressing CMD+Q works, too). Next time you open Firefox, all open tabs will be restored.

Hope, this helps. I checked this a couple of times, even with reboots in between, and it worked just fine. Clicking (x) seems to make Firefox lose the tabs of the closed session. Hopefully, somebody can reproduce this behavior and fix it.

Edit: This works both ways: Either chose the "restore previous session"-setting in the preferences or otherwise use "History"->"restore previous session" (it won't be greyed out).

Modified by totalkaos

more options

In case you are using "Clear history when Firefox closes":

  • do not clear the Browsing History

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.

Clearing cookies will remove all specified (selected) cookies including cookies that have an allow exception and cookies from plugins.

more options

Nope, not the case. I did try all the obvious and not so obvious things.

"Clear history when Firefox closes" was unchecked. (I guess the thread starter made sure it was unchecked as well because he mentioned he had tried everything.) If it were checked the workaround mentioned above wouldn't work.

more options

Go to Tools

then Options


In privacy choose Remember History Then go to

General Tab

At the start up drop down menu when firefox starts select

show my windows and tabs from last time

That should fix things

IcUrPoint

more options

Please read the first posting:

"I have it set to restore my previous session in the general options menu, it warns me when I close multiple tabs, private browsing is disabled."

I tried every setting, too. Firefox loses the last session anyway – unless "closed" properly and not by clicking (x). This behavior is obviously something that can't be fixed by different settings or deleting sessionstore.js :(

more options

Can you at least restore the previous session via History > Restore Previous Session ?

more options

No, it's greyed out/not available if the browser is closed by clicking on (x). So neither restoring the tabs automatically nor manually works.

more options

If it works when you close Firefox via the menu entry and not by clicking the close X then you will have to use the menu entry.

Note that extensions and plugins can cause Firefox not to close properly by using the close X and possibly if there are still other Firefox windows open.

more options

I really did try everything: Clean install, no other windows are open, no plug-ins/extensions active, … This happens even in Safe Mode.

The "workaround" to close Firefox via the menu entry works, but still I wanna know why Firefox loses the tabs otherwise. This wasn't the case before (much older versions) and to me it's rather a bug than a feature. And others seem to experience the same problem.