X
Tap here to go to the mobile version of the site.

Support Forum

Content Encoding Error Message re invalid or unsupported form of compression

Posted

After installing the last update, when I would attempt to go to various websites, even google, I would get this message on some sites not all. I did not get on IE or chrome.

"Content Encoding Error The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.'


 This is what I did.

Open Firefox 1) in the address bar, type: about config 2) promise to be careful 3) type in the filter bar: encoding 4) double click on the value column of network.http.accept-encoding 5) change the 'string value' from "gzip, deflate" to "true" (I had to type that in.) I found that on another string that was closed that the moderator said not to do it or it could mess things up.

I do not know if issue was caused by last update as add or remove programs in control panel does not show Mozilla updates so I could not uninstall last udate. Only other thing I had done was reinstall Real Player Plus with Real downloader and Speed-bit accelerator as I was having trouble downloading flash videos from web pages mainly from Firefox. (Chrome in its wisdom playing god disabled the addon without even asking me so I could not use Chrome for downloads-they said something about not knowing publisher or certificate--"Real Networks"!!! maybe Google-Chrome does not want users of "You Tube which I think it owns to be able to download offf it with competitor or sort of competitor's applications.) I do not know that the Rel Player re-installation had anything to do with the Firefox error message-just contemporaneous in time as was the Firefox update that I only knew about as Firefox let me know I had to restart to finish installation of update.

 After ten minutes after making changes re config it seems to be operating OK
After installing the last update, when I would attempt to go to various websites, even google, I would get this message on some sites not all. I did not get on IE or chrome. "Content Encoding Error The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.' This is what I did. Open Firefox 1) in the address bar, type: about config 2) promise to be careful 3) type in the filter bar: encoding 4) double click on the value column of network.http.accept-encoding 5) change the 'string value' from "gzip, deflate" to "true" (I had to type that in.) I found that on another string that was closed that the moderator said not to do it or it could mess things up. I do not know if issue was caused by last update as add or remove programs in control panel does not show Mozilla updates so I could not uninstall last udate. Only other thing I had done was reinstall Real Player Plus with Real downloader and Speed-bit accelerator as I was having trouble downloading flash videos from web pages mainly from Firefox. (Chrome in its wisdom playing god disabled the addon without even asking me so I could not use Chrome for downloads-they said something about not knowing publisher or certificate--"Real Networks"!!! maybe Google-Chrome does not want users of "You Tube which I think it owns to be able to download offf it with competitor or sort of competitor's applications.) I do not know that the Rel Player re-installation had anything to do with the Firefox error message-just contemporaneous in time as was the Firefox update that I only knew about as Firefox let me know I had to restart to finish installation of update. After ten minutes after making changes re config it seems to be operating OK

Additional System Details

Installed Plug-ins

  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Shockwave Flash 11.6 r602
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In

Application

  • Firefox 19.0.2
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0.2/WINNT/en-US/

Extensions

  • Favicon Restorer 1.4 (faviconrestorer@masserog.it)
  • IE View 1.5.5 ({6e84150a-d526-41f1-a480-a67d3fed910d})
  • JavaScript Debugger 0.9.89 ({f13b157f-b174-47e7-a34d-4815ddfdfeb8})
  • Norton Vulnerability Protection 11.1.1.5 - 3 ({BBDA0591-3099-440a-AA10-41764D9DB4DB})
  • PlainOldFavorites 1.2.1 ({7E7165E2-0767-448c-852F-5FA8714F2C37})
  • RealDownloader 1.3.0 ({34712C68-7391-4c47-94F3-8F88D49AD632})
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • Unhide Passwords 1.2.7.0 ({2e17e2b2-b8d4-4a67-8d7b-fafa6cc9d1d0})
  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) (Inactive)
  • DownloadHelper 4.9.14 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d}) (Inactive)
  • DownThemAll! 2.0.15 ({DDC359D1-844A-42a7-9AA1-88A850A938A8}) (Inactive)
  • Image Zoom 0.4.6 ({1A2D0EC4-75F5-4c91-89C4-3656F6E44B68}) (Inactive)
  • mediaplayerconnectivity 0.9.4 ({84b24861-62f6-364b-eba5-2e5e2061d7e6}) (Inactive)
  • Microsoft .NET Framework Assistant 1.2.1 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • Norton Safe Web Lite Toolbar 1.2.0 ({203FB6B2-2E1E-4474-863B-4C483ECCE78E}) (Inactive)
  • OpenDownload 1.0.0 ({F0B6E3F9-ECD1-40b6-A25F-5C3FF68FB079}) (Inactive)
  • PDF Download 3.0.0.2 ({37E4D8EA-8BDA-4831-8EA1-89053939A250}) (Inactive)
  • PopupSound 0.1.6 ({dc0fa140-3db2-73ec-e852-912722c852fa}) (Inactive)
  • Save Link in Folder 1.5.12 ({7a46f9fe-4818-4837-ae4a-39c53978ae99}) (Inactive)
  • Screengrab 0.96.3 ({02450954-cdd9-410f-b1da-db804e18c671}) (Inactive)
  • Send Page By Email 0.6.3 ({06C43693-2C7F-4beb-BB52-EF92C6CA0C44}) (Inactive)
  • Session Manager 0.7.9.6 ({1280606b-2510-4fe0-97ef-9b5a22eafe30}) (Inactive)
  • Torntv 1.0 (torntv@torntv.com) (Inactive)
  • YouTube quality manager 1.2 (youtubequality@rzll) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 3200 Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x9610
  • adapterDeviceID2:
  • adapterDrivers: ati2dvag
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'10.6']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 3-18-2008
  • driverDate2:
  • driverVersion: 8.475.0.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'10.6']
  • numTotalWindows: 3
  • webglRendererMessage: [u'tryNewerDriver', u'10.6']
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 8192
  • browser.cache.disk.smart_size.enabled: False
  • browser.cache.disk.smart_size.first_run: False
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.history_expire_days.mirror: 30
  • browser.history_expire_days_min: 93
  • browser.link.open_newwindow: 2
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.search.useDBForOrder: True
  • browser.startup.homepage_override.buildID: 20130307023931
  • browser.startup.homepage_override.mstone: 19.0.2
  • browser.tabs.autoHide: True
  • browser.tabs.warnOnClose: False
  • dom.ipc.plugins.enabled.npietab2.dll: False
  • dom.ipc.plugins.timeoutSecs: -1
  • dom.max_chrome_script_run_time: 0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0.2
  • font.size.variable.x-western: 14
  • general.useragent.extra.microsoftdotnet: ( .NET CLR 3.5.30729)
  • gfx.blacklist.suggested-driver-version: 10.6
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • network.http.accept-encoding: true
  • places.database.lastMaintenance: 1362700083
  • places.history.expiration.transient_current_max_pages: 73779
  • places.history.expiration.transient_optimal_database_size: 118045408
  • places.last_vacuum: 1304138810
  • plugin.disable_full_page_plugin_for_types: audio/basic,audio/x-gsm,audio/x-m4b,audio/mid,audio/midi,audio/x-midi,audio/mpeg,audio/x-mpeg,video/x-mpeg,video/mpeg,audio/mp4,video/mp4,video/x-m4v,video/quicktime,image/tiff,audio/wav,audio/x-wav,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,application/pdf
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.downloads: False
  • privacy.clearOnShutdown.formdata: False
  • privacy.clearOnShutdown.history: False
  • privacy.clearOnShutdown.sessions: False
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.item.downloads: False
  • privacy.item.formdata: False
  • privacy.item.history: False
  • privacy.item.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.promptOnSanitize: False
  • privacy.sanitize.sanitizeOnShutdown: True
  • security.default_personal_cert: Select Automatically
  • security.disable_button.openCertManager: False
  • security.disable_button.openDeviceManager: False
  • security.OCSP.disable_button.managecrl: False
  • security.warn_viewing_mixed: False

Misc

  • User JS: Yes
  • Accessibility: Yes
philipp
  • Top 25 Contributor
  • Moderator
5150 solutions 22809 answers

hello, please try to reset firefox and uninstall "Speed-bit accelerator", since many users have reported that it causes the content encoding issues...

hello, please try to [[Reset Firefox – easily fix most problems|reset firefox]] and uninstall "Speed-bit accelerator", since many users have reported that it causes the content encoding issues...
cor-el
  • Top 10 Contributor
  • Moderator
16657 solutions 150560 answers

Your system details list shows this:

  • network.http.accept-encoding: true

You can check the network.http.* prefs on the about:config page.

Reset network.http prefs to the default value via the right-click context menu -> Reset if they are user set (bold).

Check at least:

Your system details list shows this: *network.http.accept-encoding: true You can check the network.http.* prefs on the about:config page. Reset network.http prefs to the default value via the right-click context menu -> Reset if they are user set (bold). Check at least: *network.http.accept-encoding (default: gzip,deflate) *http://kb.mozillazine.org/network.http.accept-encoding
XilE 0 solutions 2 answers

Are you using ZoneAlarm? Actually any firewall could be causing it but mine was in ZA and soon as I removed the new content my pages worked.

If so remove any new programs you denied before the error started.

If you're using a different firewall and you do not know how to remove them just let me know which firewall you're using and I'll explain how.

If ZoneAlarm open up the main screen then click on Program Control then click on the program you want to remove and press delete.

Are you using ZoneAlarm? Actually any firewall could be causing it but mine was in ZA and soon as I removed the new content my pages worked. If so remove any new programs you denied before the error started. If you're using a different firewall and you do not know how to remove them just let me know which firewall you're using and I'll explain how. If ZoneAlarm open up the main screen then click on Program Control then click on the program you want to remove and press delete.
dbt339 0 solutions 1 answers

I followed your fix and it worked. I am now using firefox without the maddening "content encoding error" appear.

I followed your fix and it worked. I am now using firefox without the maddening "content encoding error" appear.

Question owner

After leaving my computer on all night with Chrome and Firefox both open but doing no downloading, etc., I noticed that Wincows Task Manager icon was all green showing 100% CPU usage. I opened Internet Explorer 8 which had been off all night. I looked at Windows Task Manager "processes". It shows firefox.exe with cpu at 86 to 95, iexplore.exe two instances, both at at 00-02, and chrome.exe (2 instances) both at 00. Realpaly.exe also left on all night after burning multiple Cds 6 hours earlier was also at zero. Nothing named speed bit had an active process, but videoacellerator.exe and VideoacceleratorService.exe both of which I allowed to stay in a startup folder were both at 00. Firefox is not downloading videos etc. It has two windows open, one at eBay and one support.mozilla on this issue(content encoding error). This all started occcurring after the latest Firefox update that necessitated the restarting of my computer. I have th two Firefox extensions that like T=Real Downloader allow downloads of flash videos on web pages and neither one was active Flash and Video Download, and Flash Video Downloader the former had been active for several continuous days downloading multiple video clips but had been turned off before I went to bed. After an hour typing this things are still the same with Firefox the CPU hog , still at 84-97, chrome.exe and iexplore.exe still both under 05. For some reason with the recent update tht required restarting the computer Firefox has become a CPU hog and is not working properly withprograms (Windows downloader and Speedbit) and has the content encoding error message issue as wll as sometimes IE not able to go to some pages. My CPU icon in taskbar is teill all green, and can't close firefox without a lot of hassle as that is what I am typing this on.., but I bet that when I do total CPU usage goes to 20 or so and system idle process is the only process with numbers over 80 for CPU.

Has anyone told a webpage manager that there is an encryption problem with their webpage (such as Google or Amazon) as the error message instructs us to do?

After leaving my computer on all night with Chrome and Firefox both open but doing no downloading, etc., I noticed that Wincows Task Manager icon was all green showing 100% CPU usage. I opened Internet Explorer 8 which had been off all night. I looked at Windows Task Manager "processes". It shows firefox.exe with cpu at 86 to 95, iexplore.exe two instances, both at at 00-02, and chrome.exe (2 instances) both at 00. Realpaly.exe also left on all night after burning multiple Cds 6 hours earlier was also at zero. Nothing named speed bit had an active process, but videoacellerator.exe and VideoacceleratorService.exe both of which I allowed to stay in a startup folder were both at 00. Firefox is not downloading videos etc. It has two windows open, one at eBay and one support.mozilla on this issue(content encoding error). This all started occcurring after the latest Firefox update that necessitated the restarting of my computer. I have th two Firefox extensions that like T=Real Downloader allow downloads of flash videos on web pages and neither one was active Flash and Video Download, and Flash Video Downloader the former had been active for several continuous days downloading multiple video clips but had been turned off before I went to bed. After an hour typing this things are still the same with Firefox the CPU hog , still at 84-97, chrome.exe and iexplore.exe still both under 05. For some reason with the recent update tht required restarting the computer Firefox has become a CPU hog and is not working properly withprograms (Windows downloader and Speedbit) and has the content encoding error message issue as wll as sometimes IE not able to go to some pages. My CPU icon in taskbar is teill all green, and can't close firefox without a lot of hassle as that is what I am typing this on.., but I bet that when I do total CPU usage goes to 20 or so and system idle process is the only process with numbers over 80 for CPU. Has anyone told a webpage manager that there is an encryption problem with their webpage (such as Google or Amazon) as the error message instructs us to do?

Question owner

After entering this I closed firefox, left Chrome & IE on. Then reopened Firefox. Firefox was then using 60-14 CPU. Three hours later, that is all it still is using. I did not close Real Player nor any of the video accelerators it uses as it was not using much cpu. Total cpu usage is now at 13% whereas before it was 100% with Firefox mostly in the 90s.

After entering this I closed firefox, left Chrome & IE on. Then reopened Firefox. Firefox was then using 60-14 CPU. Three hours later, that is all it still is using. I did not close Real Player nor any of the video accelerators it uses as it was not using much cpu. Total cpu usage is now at 13% whereas before it was 100% with Firefox mostly in the 90s.
XilE 0 solutions 2 answers

Can you list every add-on you're using for Firefox and what antivirus/firewall software you're using?

Click help then select troubleshooting information. After that click copy raw data to clipboard and post it here.

Also disable your protected mode for flash since it can cause some very bad memory leaks.

To do this click on start and paste this in to the search box. %WINDIR%\System32\Macromed\Flash

Once the folder is open create a new text document and name it to mms.cfg

Open it and paste the following then save it.

ProtectedMode = 0

Can you list every add-on you're using for Firefox and what antivirus/firewall software you're using? Click help then select troubleshooting information. After that click copy raw data to clipboard and post it here. Also disable your protected mode for flash since it can cause some very bad memory leaks. To do this click on start and paste this in to the search box. %WINDIR%\System32\Macromed\Flash Once the folder is open create a new text document and name it to mms.cfg Open it and paste the following then save it. ProtectedMode = 0
mtlmuriel 0 solutions 1 answers

Changing the about:config setting did not solve all of the problems, so I reset that. Then I restarted Firefox in Safe Mode and it was working perfectly. The pages were loading without a problem.

So, now I am going to disable or uninstall my add-ons one by one to see which one is causing the issues. These are my add-ons:

-Avast anti-virus

-Autofill forms

-Dictionnaire francais

-Ecosia

-NoScript

Changing the about:config setting did not solve all of the problems, so I reset that. Then I restarted Firefox in Safe Mode and it was working perfectly. The pages were loading without a problem. So, now I am going to disable or uninstall my add-ons one by one to see which one is causing the issues. These are my add-ons: -Avast anti-virus -Autofill forms -Dictionnaire francais -Ecosia -NoScript

Modified by mtlmuriel