X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Top of window is translucent; Desktop shows through.

Posted

The top portion of my Firefox window, whether or not full-screen, is translucent across its entire width. The desktop (or the top of the window immediately underneath the one I am using) shows through, which makes it extremely difficult to see/read the top three toolbars. How can I make this area of the window opaque like the rest of the Firefox window?

Chosen solution

Try to disable transparency in Windows.

Right click in a free space on your desktop.
Left click on Personalization.
There are four options at the bottom of the screen, choose "Window Color and Appearance".
Select a border color
Uncheck: "Enable transparency"

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • npsitesafety
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • npFFApi
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • NPWLPG
  • 3.0.40624.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6629 answers

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Question owner

Reset did not solve the problem. The top portion still is sill translucent, but now I've lost most of my customization. What can I do with the Old Firefox Data and bookmarkbackups folders on my desktop to restore my toolbars, extensions, etc.?

I still need a solution to my original problem. Attached is a screenshot showing the bleedthrough of my Desktop. I moved the icons across the full width of the page, so that they can be seen easily. Please help.

Thanks.

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Chosen Solution

Try to disable transparency in Windows.

Right click in a free space on your desktop.
Left click on Personalization.
There are four options at the bottom of the screen, choose "Window Color and Appearance".
Select a border color
Uncheck: "Enable transparency"

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6629 answers

Helpful Reply

That's transparency in windows, that's normal. You can turn it off for all of windows like cor-el said.

Question owner

Thanks, cor-el (and Tylerdowner). Now, how do I get my other stuff back (see above)?

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Helpful Reply

If you reset Firefox then a new profile is created and some of your data (bookmarks, passwords, cookies, form data) is automatically imported and your current profile will be moved to the desktop (Old Firefox Data).

You can recover more data from the old profile (be cautious with doing that).

Question owner

Thanks, cor-el. I now have my old data (extensions, toolbars, etc.) back. I found my current profile folder, closed Firefox, deleted the folder's contents, copied the contents of the "Old Firefox Data" folder on my Desktop, and pasted them into the profile folder. When I reopened Firefox, everything was back to the way it was before the Reset Firefox experiment.

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

You may want to check the compatibility.ini file to see if it still has a InvalidateCaches=1 line and remove this line.

Question owner

OK. I just removed the line. What would it have done had I left it in the .ini file?

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

I don't know if the presence of it will have any during effect i.e. that the cache will be invalided on every start.
I've never seen this mentioned or tested it myself.

Question owner

Well, I deleted the line. What was the reason for your suggestion.? Could the deletion cause any problem (the reverse of my previous question)?

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

No, removing this line shouldn't have ill effects, but you can try to delete the file to force Firefox to initialize the profile properly because the original random name is probably lost and some files may store absolute paths.

Firefox appears to add this line when the profile is disabled and moved to the desktop.
In some previous versions the profile stayed in the original location and was still accessible via the Profile Manager, but now the main part (i.e. not the cache location) is moved to the desktop.

Question owner

I made it happen by pasting my old files (from the desktop) into the newly-generated, randomly-named profile, as described above. So far so good. Firefox is recognizing it. As long as it continues to work, I won't do anything more to it. Thanks for all your help.