X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 19.0.2 freezes, locks up for 30 to 90 seconds when on YouTube or certain other pages.

Posted

Every time that I try to get on YouTube or certain other sites, Firefox locks up for at least 60 seconds. Eventually I have to use Task Manager to close firefox. Then I have to go to IE or Chrome to view the pages.

I can get no help on this matter. I have tried every recommendation. I am afraid that firefox has no interest in solving this. I can use IE or Chrome [or Safari] without problem.

by the way, every time I try to contact firefox I have to register under another ID. My ID NEVER works and firefox NEVER sends a Password help email. EVERY time firefox says that my email is already used for firefox, but I NEVER receive ANY password email help at my address.

Every time that I try to get on YouTube or certain other sites, Firefox locks up for at least 60 seconds. Eventually I have to use Task Manager to close firefox. Then I have to go to IE or Chrome to view the pages. I can get no help on this matter. I have tried every recommendation. I am afraid that firefox has no interest in solving this. I can use IE or Chrome [or Safari] without problem. by the way, every time I try to contact firefox I have to register under another ID. My ID NEVER works and firefox NEVER sends a Password help email. EVERY time firefox says that my email is already used for firefox, but I NEVER receive ANY password email help at my address.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • iTunes Detector Plug-in
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • 4.1.10329.0
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 19.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0.2/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • Browsing Protection 1.10 (litmus-ff@f-secure.com) (Inactive)
  • DigitalPersona Extension 5.0.0.4951 (otis@digitalpersona.com) (Inactive)
  • Skype Click to Call 6.6.0.11664 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0102
  • adapterDeviceID2:
  • adapterDrivers: igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.1.7601.17789
  • driverDate: 6-26-2011
  • driverDate2:
  • driverVersion: 8.15.10.2430
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.blockautorefresh: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: http://www.google.com
  • browser.startup.homepage_override.buildID: 20130307023931
  • browser.startup.homepage_override.mstone: 19.0.2
  • browser.urlbar.autocomplete.enabled: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0.2
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1362806337
  • places.history.expiration.transient_current_max_pages: 84988
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
Sirtokes 0 solutions 7 answers

Well like I said before... I am running windows xp... and I no longer have this problem after updating flash and reinstalling firefox..

If you haven't tried that, then I have no idea what to tell you.

Everything works great now!

Well like I said before... I am running windows xp... and I no longer have this problem after updating flash and reinstalling firefox.. If you haven't tried that, then I have no idea what to tell you. Everything works great now!
Kaz_Kylheku 0 solutions 13 answers

I am experiencing this on a 64 bit Windows 7 box.

It continues to happen after a Firefox reset, and in safe mode.

I suspected Flash Player, and went as far as downgrading to several versions of FP 10. The behavior is always the same, so it points toward Firefox.

Firefox takes at least 15 seconds to start up (safe mode or not) and hangs very badly on Youtube videos. It is sometimes a wrestle to kill it from task manager, even.

It recovers from this state by itself, but it is unusable.

I am experiencing this on a 64 bit Windows 7 box. It continues to happen after a Firefox reset, and in safe mode. I suspected Flash Player, and went as far as downgrading to several versions of FP 10. The behavior is always the same, so it points toward Firefox. Firefox takes at least 15 seconds to start up (safe mode or not) and hangs very badly on Youtube videos. It is sometimes a wrestle to kill it from task manager, even. It recovers from this state by itself, but it is unusable.

Modified by Kaz_Kylheku

Kaz_Kylheku 0 solutions 13 answers

I uninstalled FF, rebooted and reinstalled 19.0.2. No change.

I uninstalled FF, rebooted and reinstalled 19.0.2. No change.
Crystalsno 0 solutions 12 answers

I'm just happy to see it's not just me. Someone else is stating that it is FF that has the problem.

I'm just happy to see it's not just me. Someone else is stating that it is FF that has the problem.
Kaz_Kylheku 0 solutions 13 answers

Okay, I'm now on FF 18.0.2, and Flash Player 11.5.502.110. (Maybe from around last November or thereabouts?)

The problem still persists, in a freshly created, blank FF profile on 18.0.2.

I'm finding it close to impossible to put the blame on Firefox or Flash Player. Maybe this is some malware? Whatever it is, it blows up the startup time of Firefox to 15 seconds or more and causes very bad performance upon access to pages that contain media playback content.

The entire system performs badly during these freezes. For instance, while playing a video in a stand-alone video player application, I started Firefox. Audio continued in the player, but the video froze and it became unresponsive. Then it recovered and the video "fast forwarded" to sync up with the audio.

I'm next going to see what available system restore points there are on this Windows box.

Okay, I'm now on FF 18.0.2, and Flash Player 11.5.502.110. (Maybe from around last November or thereabouts?) The problem still persists, in a freshly created, blank FF profile on 18.0.2. I'm finding it close to impossible to put the blame on Firefox or Flash Player. Maybe this is some malware? Whatever it is, it blows up the startup time of Firefox to 15 seconds or more and causes very bad performance upon access to pages that contain media playback content. The entire system performs badly during these freezes. For instance, while playing a video in a stand-alone video player application, I started Firefox. Audio continued in the player, but the video froze and it became unresponsive. Then it recovered and the video "fast forwarded" to sync up with the audio. I'm next going to see what available system restore points there are on this Windows box.
Crystalsno 0 solutions 12 answers

First you state "The behavior is always the same, so it points toward Firefox." Now you're stating that it's close to impossible to put the blame on FF? Smh...

Ok, well I don't have a problem with youtube or any other website. Just how extremely slow and the length of time it takes for FF to load for the first time on both my home xp system and my windows 7 system, hangs and then crashes. I've checked and double checked for viruses and malware with nothing found, and everything is up to date.

FF no longer hangs and crashes, but it still takes a very long time for FF to load on both systems.

First you state "The behavior is always the same, so it points toward Firefox." Now you're stating that it's close to impossible to put the blame on FF? Smh... Ok, well I don't have a problem with youtube or any other website. Just how extremely slow and the length of time it takes for FF to load for the first time on both my home xp system and my windows 7 system, hangs and then crashes. I've checked and double checked for viruses and malware with nothing found, and everything is up to date. FF no longer hangs and crashes, but it still takes a very long time for FF to load on both systems.
Kaz_Kylheku 0 solutions 13 answers

That's correct. As I gathered more information, my hypothesis changed. I initially suspected the usual suspect: Flash. But reverting it to various old versions didn't solve the problem, pointing to something else, like perhaps a new Firefox problem. But going back to old versions of FF doesn't fix it either.

Look, I'm on 15.0.1 now and it's happening still. This issue didn't exist when 15 was current. It showed up recently.

Malwarebytes' Anti-Malware found nothing on this system.

Maybe some Microsoft update screwed up some system component.

I tried turning off hardware acceleration in Flash Player, but no effect.

That's correct. As I gathered more information, my hypothesis changed. I initially suspected the usual suspect: Flash. But reverting it to various old versions didn't solve the problem, pointing to something else, like perhaps a new Firefox problem. But going back to old versions of FF doesn't fix it either. Look, I'm on 15.0.1 now and it's happening still. This issue didn't exist when 15 was current. It showed up recently. Malwarebytes' Anti-Malware found nothing on this system. Maybe some Microsoft update screwed up some system component. I tried turning off hardware acceleration in Flash Player, but no effect.
FFchatter 0 solutions 7 answers

HP laptop, Intel Core 2 duo T5600@1.83 GHz, 2 GB RAM, Windows Vista 32 bit, FireFox 19.0.2. FF plugins - Adobe Acrobat 10.1.6.1, Shockwave Flash ver 11.6.602.180, VLC Web Plugin 2.0.2.0

Did a bit of additional testing after having this problem again this morning. Cold booted my system, and when it was back up brought up Chrome. Loaded 9 tabs, and on the 10th tab loaded the tomshardware.com website. No problems. Shut down Chrome; brought up Firefox. Loaded same 9 tabs, and then tomshardware.com. BOOM! Problem. Able to click mouse 3 times (with no effect), then on the 4th click the "stop clicking me!" beep and my system locked up for about 30 seconds. After 30 seconds the system comes back and all is right with the world again. Firefox does NOT like something on the Tom's website. Or it has to load something special. Not sure which. Something Chrome has no problem loading.

Next, I shut down FF, then brought it back up. Did the same thing, and when I went to tomshardware.com I had NO problem. So it looks like something is having to get loaded info FF on the first visit, and then it stays in memory even when I shut down FF. Next step is to try and figure out what that might be - or if I'm totally wrong about this hypothesis.

HP laptop, Intel Core 2 duo T5600@1.83 GHz, 2 GB RAM, Windows Vista 32 bit, FireFox 19.0.2. FF plugins - Adobe Acrobat 10.1.6.1, Shockwave Flash ver 11.6.602.180, VLC Web Plugin 2.0.2.0 Did a bit of additional testing after having this problem again this morning. Cold booted my system, and when it was back up brought up Chrome. Loaded 9 tabs, and on the 10th tab loaded the tomshardware.com website. No problems. Shut down Chrome; brought up Firefox. Loaded same 9 tabs, and then tomshardware.com. BOOM! Problem. Able to click mouse 3 times (with no effect), then on the 4th click the "stop clicking me!" beep and my system locked up for about 30 seconds. After 30 seconds the system comes back and all is right with the world again. Firefox does NOT like something on the Tom's website. Or it has to load something special. Not sure which. Something Chrome has no problem loading. Next, I shut down FF, then brought it back up. Did the same thing, and when I went to tomshardware.com I had NO problem. So it looks like something is having to get loaded info FF on the first visit, and then it stays in memory even when I shut down FF. Next step is to try and figure out what that might be - or if I'm totally wrong about this hypothesis.
FFchatter 0 solutions 7 answers

Many reboots later and I still have no solutions. Thought at first it might be a conflict between VLC and Flash, but that was not the case. Disabled both VLC and Flash and the problem got worse. Enabled each individually and both had the same problems loading up Tom's (problem actually appears to be all the add servers you have to go through before you get to Tom's). Then I checked Chrome's addons, and it was running the same versions of the addons. So I thought maybe Chrome is running something that FF is not. Matched up the addons on both platforms as best I could (Chrome has a couple specific to it), and FF still had problems while Chrome has none. Also tried to match up the various settings as best I could on both platforms. Can't find the problem.

 I also note that FF often seems to have trouble finishing loading certain pages.  The little green arrow on the tab just keeps spinning and spinning and spinning.  Never ends.  Not sure what that problem is about either.
  Sadly, I think it might be time to try and learn to love Chrome. . .
Many reboots later and I still have no solutions. Thought at first it might be a conflict between VLC and Flash, but that was not the case. Disabled both VLC and Flash and the problem got worse. Enabled each individually and both had the same problems loading up Tom's (problem actually appears to be all the add servers you have to go through before you get to Tom's). Then I checked Chrome's addons, and it was running the same versions of the addons. So I thought maybe Chrome is running something that FF is not. Matched up the addons on both platforms as best I could (Chrome has a couple specific to it), and FF still had problems while Chrome has none. Also tried to match up the various settings as best I could on both platforms. Can't find the problem. I also note that FF often seems to have trouble finishing loading certain pages. The little green arrow on the tab just keeps spinning and spinning and spinning. Never ends. Not sure what that problem is about either. Sadly, I think it might be time to try and learn to love Chrome. . .
Kaz_Kylheku 0 solutions 13 answers

After all this, my add-ons have stopped working!

When I install extensions they are listed, but do not function. AdBlock Plus and NoScript display no UI and do not spring into action. The Brief RSS reader does not come up when I click on it in the bookmark toolbar. The browser simply does not open the chrome://brief/content/brief.xul URL.

It resembles Safe Mode, I guess. Except it doesn't clear itself when you completely exit the application.

I have tried uninstalling Firefox, rebooting the machine and reinstalling.

No avail.

After all this, my add-ons have stopped working! When I install extensions they are listed, but do not function. AdBlock Plus and NoScript display no UI and do not spring into action. The Brief RSS reader does not come up when I click on it in the bookmark toolbar. The browser simply does not open the chrome://brief/content/brief.xul URL. It resembles Safe Mode, I guess. Except it doesn't clear itself when you completely exit the application. I have tried uninstalling Firefox, rebooting the machine and reinstalling. No avail.
cor-el
  • Top 10 Contributor
  • Moderator
17588 solutions 159105 answers

Are there any errors in the Error Console (Ctrl+Shift+J)?

Do you see the source code of this file to verify that the Brief extension is at least loaded?

  • view-source:chrome://brief/content/brief.xul
Are there any errors in the Error Console (Ctrl+Shift+J)? Do you see the source code of this file to verify that the Brief extension is at least loaded? *view-source:chrome://brief/content/brief.xul
Kaz_Kylheku 0 solutions 13 answers

Thanks cor-el. I know this is off-topic for this bug (sorry), but yes, there are errors! Each time I try to run brief, two errors appear:

1. No chrome package registered for chrome://brief/content/brief.xul

2. NS_ERROR_NOT_AVAILABLE: Component returned failure code 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIWebNavigation.loadURI]

Hmm ...

Thanks cor-el. I know this is off-topic for this bug (sorry), but yes, there are errors! Each time I try to run brief, two errors appear: 1. No chrome package registered for chrome://brief/content/brief.xul 2. NS_ERROR_NOT_AVAILABLE: Component returned failure code 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIWebNavigation.loadURI] Hmm ...
Kaz_Kylheku 0 solutions 13 answers

EVERYTHING FIXED!

The solution was to force CHKDSK /F on the volume and reboot.

I started to suspect disk corruption, and indeed there was some.

The two telltale signs were: several weeks ago, a VirtualBox instance running Ubuntu behaved strangely. It had disk errors and became unusable (it was impossible to run any executable, even to reboot it). Several days later, there was a sudden crash and reboot. This system has never had problems of that sort since I set it up two years ago.

Anyway, after the CHKDSK, Firefox started to behave differently right away. The add-ons came back. I was prompted to allow the Java console add-on to install.

Then when I navigated to this web page, my credentials were gone. I had to re-authenticate myself here. I haven't had to do that all day.

Youtube videos play fine, and Firefox restarts in a second or two after being shut down.

I wonder what the damage is. I must have lost some files, but the system appears to be working.

EVERYTHING FIXED! The solution was to force CHKDSK /F on the volume and reboot. I started to suspect disk corruption, and indeed there was some. The two telltale signs were: several weeks ago, a VirtualBox instance running Ubuntu behaved strangely. It had disk errors and became unusable (it was impossible to run any executable, even to reboot it). Several days later, there was a sudden crash and reboot. This system has never had problems of that sort since I set it up two years ago. Anyway, after the CHKDSK, Firefox started to behave differently right away. The add-ons came back. I was prompted to allow the Java console add-on to install. Then when I navigated to this web page, my credentials were gone. I had to re-authenticate myself here. I haven't had to do that all day. Youtube videos play fine, and Firefox restarts in a second or two after being shut down. I wonder what the damage is. I must have lost some files, but the system appears to be working.

Modified by Kaz_Kylheku

Kaz_Kylheku 0 solutions 13 answers

Ha, now here is the kicker, explaining why this had me fooled.

My friend started having a similar issue at around the same time as me: machine suddenly stopped playing media in Firefox.

So I thought that this might be some issue that is "going around" (an automatic update went bad). Then I saw this case on this site, which also tended to confirm the hypothesis. So of course that averts suspicion from the possibility that it may just be the particular system installation having gone bad for basic storage integrity reasons not related to Firefox or Flash.

We just fixed the issue on my friend's computer and it also had to do with hard drive corruption.

I mean, what are the odds?

Ha, now here is the kicker, explaining why this had me fooled. My friend started having a similar issue at around the same time as me: machine suddenly stopped playing media in Firefox. So I thought that this might be some issue that is "going around" (an automatic update went bad). Then I saw this case on this site, which also tended to confirm the hypothesis. So of course that averts suspicion from the possibility that it may just be the particular system installation having gone bad for basic storage integrity reasons not related to Firefox or Flash. We just fixed the issue on my friend's computer and it also had to do with hard drive corruption. I mean, what are the odds?

Question owner

I did not think that my problem would be hard drive corruption, as I have several computers and have tested firefox on all of them. I have even tested it on one computer [this one] after replacing the hard drive and reloading the OS from scratch. I tested the harddrive for errors anyway and found none. Chkdsk found no errors or corruption. My problem with Firefox remains the same. I must use IE for Youtube and many other sites.

I did not think that my problem would be hard drive corruption, as I have several computers and have tested firefox on all of them. I have even tested it on one computer [this one] after replacing the hard drive and reloading the OS from scratch. I tested the harddrive for errors anyway and found none. Chkdsk found no errors or corruption. My problem with Firefox remains the same. I must use IE for Youtube and many other sites.
worldtraveler01 0 solutions 17 answers

I have the same problem running Windows 8. Mozilla needs to get to grips with it or lose their user base. Flash is a core functionality.

I have the same problem running Windows 8. Mozilla needs to get to grips with it or lose their user base. Flash is a core functionality.
worldtraveler01 0 solutions 17 answers

Helpful Reply

The only solution that I have found to work is to downgrade Firefox to 14.01 and to downgrade Flash to 10.3. The other more recent combinations I have tried all freeze page loads. Problem identified running Firefox 19.02 and Flash 11.6 under Win 8. I have tried multiple installations and combinations to fix this with no luck. Not good news for the Firefox browser (look at the number of threads on this and related topics).

The only solution that I have found to work is to downgrade Firefox to 14.01 and to downgrade Flash to 10.3. The other more recent combinations I have tried all freeze page loads. Problem identified running Firefox 19.02 and Flash 11.6 under Win 8. I have tried multiple installations and combinations to fix this with no luck. Not good news for the Firefox browser (look at the number of threads on this and related topics).
FFchatter 0 solutions 7 answers

Thanks worldtraveler01. I don't know exactly when this problem first appeared, but my recollection too was that it started sometime around version 14. I've been testing out other browsers, but they all seem to have their little quirks. Since this freezing problem occurs on some pages consistently and others not at all, I am assuming that Firefox is having problems parsing some sort of code (probably for advertising and/or tracking) that these websites have chosen to use. I've used the CNTRL-SHIFT-J function to look at the errors coming off those pages, and I do get a bunch of warning (yellow exclamations) messages. But I get the same warning messages coming off pages that don't have problems. In fact if you do that on this page you will see about a 1000 warnings of things Firefox can't process. . .

Thanks worldtraveler01. I don't know exactly when this problem first appeared, but my recollection too was that it started sometime around version 14. I've been testing out other browsers, but they all seem to have their little quirks. Since this freezing problem occurs on some pages consistently and others not at all, I am assuming that Firefox is having problems parsing some sort of code (probably for advertising and/or tracking) that these websites have chosen to use. I've used the CNTRL-SHIFT-J function to look at the errors coming off those pages, and I do get a bunch of warning (yellow exclamations) messages. But I get the same warning messages coming off pages that don't have problems. In fact if you do that on this page you will see about a 1000 warnings of things Firefox can't process. . .
southfrog 0 solutions 1 answers

don't know if you're still having this problem, but I have the same problem, but it happens with all browsers.

I have found two semi-solutions...

1- after launching the browser, open task manger, click on the process tab, then right-click on the browser executable filename.

click on "set affinity" from the dropdown menu, then uncheck CPU0 and all processors. with only CPU1 checked. my browser still freezes, but only once in a while, almost never.

2-flash only seems to freeze the computer when the computer is far away from the modem/router, more than 30 feet. when I am about 10-15 feet away I never get the problem.

...hope this helps.

don't know if you're still having this problem, but I have the same problem, but it happens with all browsers. I have found two semi-solutions... 1- after launching the browser, open task manger, click on the process tab, then right-click on the browser executable filename. click on "set affinity" from the dropdown menu, then uncheck CPU0 and all processors. with only CPU1 checked. my browser still freezes, but only once in a while, almost never. 2-flash only seems to freeze the computer when the computer is far away from the modem/router, more than 30 feet. when I am about 10-15 feet away I never get the problem. ...hope this helps.