X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Flash objects appear as very small and disappear on click.

Posted

Hello,

Since a few months ago, I've been having a problem with Flash objects in Firefox. They seem to only take up about a quarter of the space they are supposed to. And then, if I click on them in any way, say to control the video, they instantly go black. The audio continues, and in the case of video it still responds to the keyboard shortcuts for Flash video (eg. Spacebar for play/pause). But the video is totally gone. And nothing short of a refresh gets it back to visible.

I guess no BBCode, but here is a screenshot: http://i.imgur.com/q10ENly.jpg

The video and other flash things work perfectly in Safari. No problems there.

I know there is a common problem with Flash video not working properly, and I tried the fixes described there. I didn't have Real Player installed, so I just uninstalled and re-installed Flash and get the same thing.

Any help would be greatly appreciated it.

Modified by Tzalmavet

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Version 3.15.2.12038
  • Google Talk Plugin Video Accelerator version:0.1.44.24
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • 5.1.10411.0
  • Plugin to display and edit chemical structures.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Office Live Update v1.0
  • npmnqmp 071500000273
  • iPhoto6
  • Squeak Browser Plugin 3.8.15b15 http://www.squeak.org
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.

Application

  • Firefox 19.0.2
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0.2/Darwin/en-US/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • BugMeNot 2.2 ({987311C6-B504-4aa2-90BF-60CC49808D42})
  • DownloadHelper 4.9.14 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • Easy YouTube Video Downloader 6.7 ({c0c9a2c7-2e5c-4447-bc53-97718bc91e1b})
  • Elite Proxy Switcher 1.2.0.2 (eliteproxyswitcher@my-proxy.com)
  • Flagfox 4.2.6 ({1018e4d6-728f-4b20-ad56-37578a4de76b})
  • gTranslate 0.9 ({aff87fa2-a58e-4edd-b852-0a20203c1e17})
  • LastPass 2.0.0 (support@lastpass.com)
  • Places Maintenance 1.3 (places-maintenance@bonardo.net)
  • Rikaichan 2.07 ({0AA9101C-D3C1-4129-A9B7-D778C6A17F82})
  • Rikaichan Japanese-English Dictionary File 2.01.110527 (rikaichan-jpen@polarcloud.com)
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • User Agent Switcher 0.7.3 ({e968fc70-8f95-4ab9-9e79-304de2a71ee1})
  • PDF Viewer 0.7.236 (uriloader@pdf.js) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x6898
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: ATI Technologies Inc. -- ATI Radeon HD 5870 OpenGL Engine
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.history_expire_days.mirror: 180
  • browser.places.createdSmartBookmarks: True
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: google.com
  • browser.startup.homepage_override.buildID: 20130307023931
  • browser.startup.homepage_override.mstone: 19.0.2
  • browser.tabs.warnOnClose: False
  • dom.max_script_run_time: 0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0.2
  • gfx.blacklist.direct2d: 3
  • gfx.blacklist.layers.direct3d9: 3
  • gfx.blacklist.webgl.msaa: 4
  • keyword.URL: http://www.google.com/search?hl=en&q=
  • network.cookie.prefsMigrated: True
  • network.http.sendRefererHeader: 0
  • places.database.lastMaintenance: 1362801589
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • places.last_vacuum: 1279074597
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 3
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96731 answers

Try to "disable the hardware acceleration" in the Flash Player.

See also:

Flash "Display settings" window:

Try to clear the Flash local storage and settings.

Flash Website Storage Settings panel:

Global Storage Settings Panel:

Question owner

I've pretty much tried everything but disabling the hardware acceleration in Firefox. When I right click on a flash object, the context menu comes up, but "settings" is greyed out and unclickable. I tried it on a YouTube video and it wasn't greyed out for some reason. And hardware acceleration was already turned off.

It is clickable in Safari's flash, but not in Firefox.

Other than that, I've reinstalled, cleared storage settings, etc.