X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Restore bookmarks refuses to go as : resource://gre/modules/PlacesUtils.jsm:1384 will not complete. HELP

Posted

When I try to restore bookmarks from any of the back up files I get this error message - even after having reset firefox to factory defaults: 'A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete. Script: resource://gre/modules/PlacesUtils.jsm:1384

Whatever I do it finishes with : 'Unable to process the backup file'.

Problem started when half!! my bookmarks disappeared suddenly. Not all, just about half as if they had been cut off. All else seems to work fine, including creating new bookmarks. If I create a new bookmark, quit Firefox, and restart and THEN manualy delete the one new bookmark it will then be restored quite happily from the latest newly created back up file. It is only with the older backup files that there is a problem seemingly. I hope that all the 10 old backups are not somehow corrupt.

HELP.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Displays Java applet content, or a placeholder if Java is not installed.
  • RealPlayer Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Juniper Networks Safari Extensions
  • npmnqmp 07103007
  • iPhoto6

Application

  • Firefox 19.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0/Darwin/en-US/

Extensions

  • Troubleshooter 1.0a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 407
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • driverDate:
  • driverVersion:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce 8600M GT OpenGL Engine
  • windowLayerManagerType: OpenGL

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130215130331
  • browser.startup.homepage_override.mstone: 19.0
  • extensions.lastAppVersion: 19.0
  • gfx.blacklist.webgl.msaa: 4
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1362525502
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

Helpful Reply

You can check for problems with the places.sqlite database file in the Firefox Profile Folder and delete all places files to see if that makes restoring work.

Question owner

Sorry - did not mean to click yes, There are 3 places files - delete all 3?

Did not say before - but history still works OK as does making and retaining new bookmarks. Seems puzzling. And only half or so of the old ones got 'sliced' off.

Will try in the morning after a good sleep. All best and thanks for reply.

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

Yes, you can remove all places files with Firefox closed.

If Firefox isn't running then there should only be one places.sqlite file and no other places files.

Question owner

Thanks for your help, but..... No success after I shut Firefox down, removed the single places.sqlite file (I kept a copy elsewhere) from the Profile, restarted and then tried a restore. Same error message as before - "A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: resource://gre/modules/PlacesUtils.jsm:1384"

All the old History has now gone but the Bookmarks that had not disappeared before are still there.

Is there any alternative to throwing the whole current profile away (albeit saving the bookmark backup files) and starting again so to speak?