X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

On Fedora-10 firefox 18.x, 19.x crash on startup with undefined NS_CycleCollectorSuspect2_P cant load xpcom

Posted

Under fedora-10 Linux, firefox-17.0.1 worked well. After upgrading to firefox-18.0 (and also after installing later versions of firefox) when firefox attempts to start, it crashes with the error messages:

XPCOMGlueLoad error for file /usr/local/firefox.18.0/libxpcom.so Undefined symbol NS_CycleCollectorSuspect2_P Couldn't load XPCOM

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Displays Java applet content, or a placeholder if Java is not installed.
  • iPhoto6
  • Juniper Networks Safari Extensions
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • RealPlayer Plugin

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Helpful Reply

Make sure that you meet the system requirements for Firefox 18+ versions.

  1. GTK+ 2.18 or higher
  2. GLib 2.22 or higher