X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Youtube stutters (framerate 1 per second) after i switched to a new tab and back, sound most of the times stays ok. (not in chrome or safari)

Posted

If i load up youtube, click on a video it plays normal, its loading, sound is working. but when i open a new tab and then go back to the youtube tab my video stutters, or i could basically say it stopped its les then one frame per second and it skips about 50 frames everytime. sound most of the times does work but also stops sometimes. It only happens when changing tab, not if i scroll down on the videopage or anything. its really annoying. i've tried google chrome and safari aswell, all works fine.

have you heard this before, is there anything i can do?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Toont de inhoud van de Java-applet of een plaatsaanduiding als Java niet is geïnstalleerd.
  • Met de QuickTime-plugin kunt u een grote verscheidenheid aan multimediamateriaal op webpagina's bekijken. Raadpleeg voor meer informatie de website van QuickTime.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • 5.1.10411.0
  • RealPlayer Plugin
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • DivX Web Player version 2.1.1.94
  • DivX OVS Helper Plug-in
  • iPhoto6

Application

  • Firefox 19.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0/Darwin/nl/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Reddit Enhancement Suite 4.1.2 (jid1-xUfzOsOFlzSOXg@jetpack)
  • StumbleUpon 4.16 ({AE93811A-5C9A-4d34-8462-F7B864FC4696})
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • DivX HiQ 2.1.1.94 ({6904342A-8307-11DF-A508-4AE2DFD72085}) (Inactive)
  • DivX Plus Web Player HTML5 <video> 2.1.1.94 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b}) (Inactive)
  • Google Toolbar for Firefox 7.1.20110316M ({3112ca9c-de6d-4884-a869-9855de68056c}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x9488
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: ATI Technologies Inc. -- ATI Radeon HD 4670 OpenGL Engine
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 1048576
  • browser.fixup.alternate.enabled: False
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: google.nl
  • browser.startup.homepage_override.buildID: 20130215130331
  • browser.startup.homepage_override.mstone: 19.0
  • browser.tabs.warnOnClose: False
  • extensions.lastAppVersion: 19.0
  • gfx.blacklist.direct2d: 3
  • gfx.blacklist.layers.direct3d9: 3
  • gfx.blacklist.webgl.msaa: 4
  • keyword.URL: http://www.google.com/search?sourceid=navclient&hl=nl&q=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1362311610
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • places.last_vacuum: 1301229602
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.siteSettings: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
iamjayakumars
  • Top 10 Contributor
412 solutions 4875 answers

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:


  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Try to disable hardware acceleration in Firefox.


Try to "disable the hardware acceleration" in the Flash Player.

See also:

Flash "Display settings" window:

Question owner

GPU to CPU seems to work :D thanks

Oh by the way, youtube videos on external sites did not have the problem... really weird, so only Youtube on the youtube website it self was stuttering (gues thats the right english word for it)

I disabled hardware acceleration, but what does this then actually do, is there a way to "fix" this so i can start using GPU again? or is CPU good enough? i don't really feel any difference with loading and so on

Thanks!

Greets Frake

xX_JMO_Xx 0 solutions 2 answers

Helpful Reply

I have been experiencing the same problem. Start a video on youtube, switch tabs, using FF 19 or 20 on Mac OSX 10.8.3, go back to the youtube video and the video stutters, and if I roll my mouse cursor over the tabs at the top the video will advance. Audio seems unaffected.

Now I have discovered one thing, if I restart FF in safe-mode, I can switch around in tabs all day long, no stutter. So this led me to believe it was an add-on. But here is the screwy part, I disabled all add-on's and extensions save for flash player in normal mode, and the behavior was the same as before, open a Youtube video, switch tabs, go back to the video and stutter. Note, flash player does not get disabled while in safe-mode.

So it is not flash player as far as I can tell. I haven't tried disabling hardware acceleration, will try that next. I thought I would put in what I have seen so far.

xX_JMO_Xx 0 solutions 2 answers

Helpful Reply

So I tried disabling Hardware Acceleration in both flash and with FF Preferences, no cigar.

One last ditch effort, I reverted my FF theme to the default Firefox theme, and the problem has seemed to subside. Need to do a little more testing, but it seems odd that when I restart in safe mode, it doesn't change my theme to the Default, but yet the problem goes away. But so far with at least the videos I noticed the problem the most, with the theme set to default, the problem has gone away.

Modified by xX_JMO_Xx

swarajban 0 solutions 3 answers

@xX_JMO_Xx: I had the same problem and your solution (to reset the FF theme to default) seems to have completely resolved my issue.

@FF Team: Any reason this might be happening? It's not crucial, but I would like to be able to have a new FF theme AND play youtube videos without stutter.

vagos1988 0 solutions 2 answers

if i understand well what's your problem...i have the solution

!!!!!!!!!! Uninstall flash player 11 and install this one--> !!!!!!!!!!!!!!

http://download.macromedia.com/pub/flashplayer/installers/archive/fp_10.3.183.75_archive.zip


Enjoy!

swarajban 0 solutions 3 answers

@vagos: I know that may solve the problem, but unfortunately I'm currently a Flash application developer and need to be on Flash 11.

vagos1988 0 solutions 2 answers

Then you must live with your problem :D

It happened to me suddenly...I use windows 7 x64.....stupid flash!!


You better start developing in HTML5...flash is dying :P

swarajban 0 solutions 3 answers

Haha I know, luckily a workaround for me has been to disable my Firefox theme.